English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 27 October 2012, 22:07   #1
Damion
Registered User

 
Join Date: Mar 2008
Location: US
Posts: 264
Enabling "fast sync" on A4091

Hello,

Can anyone confirm a working fast synchronous mode on their 4091?

I recently found a DKB Rev B board (40.13 ROM). Synchronous mode yields ~4.4 MB/s, 2.6 MB/s asynchronous. These exact drives do just under 10 MB/s on my TekMagic 2060 (same NCR controller).

The "fast sync" mode, which should effectively double the raw transfer rate, doesn't seem to work - the dipswitch on the rear has no effect whatsoever.

Hardware is an A4000 with CSMK2 '060.

My thoughts so far:

1. Maybe the fast sync mode never worked on the 4091
2. The ROM code has some problems with the '060

Apparently, 9 MB/s or so is doable on the similar 4000T scsi, so I'm wondering if the 4091 ROM was simply never finished. The 4000T at least seemed to have several updates to its scsi device over the years.

Any ideas? Does anyone happen to have the older ROM code (40.9) laying around?
Damion is offline  
Old 21 April 2017, 16:06   #2
macce2
Retro maniac

macce2's Avatar
 
Join Date: May 2005
Location: Finland
Age: 46
Posts: 998
Has the issue been solved yet..?!
I'm interested because I just made an offer of A4091 board (rev. A).
Is there any special things regarding rev. A of the board ?
Is it possible to achieve good transfer rates using A4091 board (compared to A4000 internal Ide bus, for example ) ?!
Then, how larger hard drives are supported ?

Last edited by macce2; 21 April 2017 at 16:22.
macce2 is online now  
Old 21 April 2017, 18:26   #3
idrougge
Registered User
 
Join Date: Sep 2007
Location: Stockholm
Posts: 4,003
@Damion
I know that with Phase 5 SCSI adapters, you need to set a synchronous bit in the RDB to enable it for your specific drive besides enabling it with a jumper.

@macce2
The A4091 is about as fast as a drive controller can be when not mounted directly on an accelerator card. Much faster than the onboard IDE.

Hard drive size is not limited, at least if you run a filesystem supporting direct SCSI or OS3.9.
idrougge is offline  
Old 21 April 2017, 22:43   #4
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 2,231
With the A4091 and most SCSI-II fast controllers you want to make sure you set Sync in the RDB. You can do this with RDBFlags on Aminet. You might only see about 6MB/s on a basic A4000/A3640. However if you have a 3128 or some other Z3 RAM you should be getting above 7MB/s when the Z3 RAM has highest priority. With an A3000 or some other non crippled accelerator in the A4000 you should see above 8MB/s. If you do all that and are still getting less than 5MB/s you probably have improper termination, it being SCSI-II Fast you will need to use an Active Terminator.
grelbfarlk is offline  
Old 23 April 2017, 17:34   #5
thebajaguy
Registered User

 
Join Date: Mar 2017
Location: Rhode Island / United States
Posts: 56
The other reminder is to make sure your device supports Sync and Fast communications, and that the media transfer rate can produce that kind of throughput. Spec of SCSI (all 8-bit) is 2.5MB/sec Async, Sync doubles that to 5.0MB/sec, and Fast doubles it again. Controller command overhead and device latency, and other devices possibly polled in the middle of any testing will bring the value down from the theoretical max. From server experience back in that day, put your slower devices on a separate slower controller if cabling paths and termination become a challenge.
thebajaguy is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
"Reminder "Lincs Amiga User Group aka "LAG" Meet Sat 5th of January 2013" rockape News 4 30 January 2013 00:06
CD32 Image-Name-Bug: "...(bla)[!].zip" -> "...(bla)[" / "...[test].zip" -> "...[tes" cfTrio support.WinUAE 8 18 December 2012 16:31
Mouse movement too fast and "choppy" kwah support.WinUAE 2 14 January 2010 10:41
Another music demo which plays a "bit" fast... andreas support.Demos 5 05 September 2009 13:30
Problems with "Thespywholovedme", "Flood", "Shinobi" sareks support.Games 12 03 May 2006 14:52

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:06.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.07925 seconds with 13 queries