English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 23 September 2019, 02:26   #1
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,333
Mouse pointer resolution in P96 mode?

I've noticed that after promoting some screens to P96 screen mode, e.g. 640x512 8 bit, mouse pointer in Low Res or High Res look the same and wrongly squashed… Same for 320x240 (like NTSC proportions) or 320x256 (like PAL proportions) mouse pointer proportions look always High Res and not the same of NTSC or PAL modes where mouse pointer changes accordingly (low/high res)…
Is this correct for P96 modes?

Last edited by hexaae; 23 September 2019 at 09:42.
hexaae is offline  
Old 23 September 2019, 13:08   #2
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,529
Try to set "Big sprite"=ON and "Soft sprite"=OFF in P96 PVS tooltypes for uaegfx.
PeterK is offline  
Old 23 September 2019, 14:21   #3
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,333
Tested: mouse pointer gets low res and bigger, but changing from Prefs/Pointer Hi/Lo still won't change anything…


Last edited by hexaae; 23 September 2019 at 14:36.
hexaae is offline  
Old 23 September 2019, 14:33   #4
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,333
Unfortunately I don't have any experience with gfx cards on real Amiga (my A1200+B1260 was AGA only).

Setting Soft Sprite and unticking WinUAE RTG/Hardware Sprite Emulation looks much more as I expected in "low res" 320x256 P96 screens with correct proportions finally, even though pointer colors are still wrong on 320x256 8bit P96 compared to 320x256 8bit PAL native…




EDIT:
mmmh, in PPaint 7.3c set to RTG now pointer correctly switches to "bigger and low res" when in 320x256 P96 modes, which is what I wanted.
The pointer color issue shows up only promoting Bloodnet AGA to a 320x256 8bit P96 screen, compared to PAL 320x256 8bit but maybe it's just a game issue since PPaint, Elastic Dreams etc. now behaves correctly switching to "bigger and low res" pointers on small P96 screens and pointer colors seem to be ok…
On WB screen switching to lo/high Pointer resolution won't change anything though…

EDIT2:
Soft Sprite wasn't required, pointer res switching in low res P96 modes works fine with just WinUAE RTG/Hardware Sprite Emulation unticked

Last edited by hexaae; 23 September 2019 at 14:58.
hexaae is offline  
Old 23 September 2019, 15:07   #5
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,529
Yes, with WinUAE RTG/Hardware Sprite Emulation enabled the pointer size doesn't change from LowRes to HiRes, but I don't use the Hardware Sprite Emu. My rtg.library is v40.3994 patched.

Last edited by PeterK; 24 September 2019 at 12:01.
PeterK is offline  
Old 23 September 2019, 18:55   #6
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,333
Ok, thanks. I think I'll keep Hardware Sprite Emu OFF for better compatibility.
hexaae is offline  
Old 24 September 2019, 20:37   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,118
Hardware sprite emulation size is always 1:1 to native resolution because of some reasons, will be "fixed" someday, maybe..
Toni Wilen is online now  
Old 24 September 2019, 21:29   #8
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,333
Quote:
Originally Posted by Toni Wilen View Post
Hardware sprite emulation size is always 1:1 to native resolution because of some reasons, will be "fixed" someday, maybe..
Disadvantages in using it OFF? Speed?
hexaae is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse Pointer resolution problem rsn8887 support.WinUAE 3 13 December 2015 18:26
ClassicWB OS3.9 : High resolution Pointer vertically stretched? Amon_RA project.ClassicWB 2 10 July 2015 22:37
Mouse Pointer Washac support.WinUAE 2 19 February 2012 20:57
Minor mouse pointer glitch in windowed mode andreas support.WinUAE 2 14 May 2010 19:34
Mouse pointer Washac support.Other 4 12 February 2010 01:38

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 09:43.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.06847 seconds with 14 queries