English Amiga Board


Go Back   English Amiga Board > Other Projects > project.WHDLoad

 
 
Thread Tools
Old 19 August 2017, 20:44   #1
haynor666
retro maniac

haynor666's Avatar
 
Join Date: May 2002
Location: Tarnobrzeg/Poland
Age: 39
Posts: 1,592
Problem with WHDLoad 18.3 upgrade

Today I've upgraded WHDLoad from 18.2 to 18.3 and many games simply does not work anymore - I get black screen. After some investigation I realized that problem is keys configuration: Quit, Debug, Freeze, Restart. Different configurations cause games to stop working for example Shadow of the Beast hangs with quitkey=$5c but works with $5d (which seems to be default for this game). Bart vs Space Mutants does not work with $5c but works with $5d. What's going on?

NOTE. This is not problem with key - it's not needed now.
haynor666 is offline  
Old 27 August 2017, 09:41   #2
haynor666
retro maniac

haynor666's Avatar
 
Join Date: May 2002
Location: Tarnobrzeg/Poland
Age: 39
Posts: 1,592
Nobody have this problem really?
haynor666 is offline  
Old 27 August 2017, 11:52   #3
Wepl
Moderator
Wepl's Avatar
 
Join Date: Nov 2001
Location: Germany
Posts: 663
Are you sure you haven't a broken key present on your disk?
You may also try latest beta http://whdload.de/whdload/whd184.lha
Wepl is offline  
Old 07 September 2017, 09:59   #4
haynor666
retro maniac

haynor666's Avatar
 
Join Date: May 2002
Location: Tarnobrzeg/Poland
Age: 39
Posts: 1,592
I'll try beta today.
haynor666 is offline  
Old 07 September 2017, 21:47   #5
haynor666
retro maniac

haynor666's Avatar
 
Join Date: May 2002
Location: Tarnobrzeg/Poland
Age: 39
Posts: 1,592
...and with beta also hangs when prefs file is present.
haynor666 is offline  
Old 07 September 2017, 21:58   #6
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 3,527
it's back 18.2 the problems are resolved?
AMIGASYSTEM is offline  
Old 07 September 2017, 23:30   #7
haynor666
retro maniac

haynor666's Avatar
 
Join Date: May 2002
Location: Tarnobrzeg/Poland
Age: 39
Posts: 1,592
Everything is fine with 18.2
haynor666 is offline  
Old 02 October 2017, 13:28   #8
Wepl
Moderator
Wepl's Avatar
 
Join Date: Nov 2001
Location: Germany
Posts: 663
Please open a issue at http://mantis.whdload.de/
Wepl is offline  
Old 11 October 2017, 10:36   #9
DesktopDynamite
Registered User

DesktopDynamite's Avatar
 
Join Date: Mar 2016
Location: MALTA
Posts: 84
Can confirm that 18.3 have cause problems with other games/demos.

Tried to run both demos version of WorldofCommodore and it's alternate version. Both stop after a while with same error. [dever 1.4, and 1.5]

Noticed music slowdown on Jim Power's intro title screen while text is scrolling up and down.

Elysium demo also with music slowing down.

This is tried on both A600 with ACA620EC and 2mb chipmem, ks 3.0 and 3.1.
DesktopDynamite is offline  
Old 11 October 2017, 16:23   #10
Akira
Registered User

Akira's Avatar
 
Join Date: May 2001
Location: New York
Posts: 19,265
Quote:
Originally Posted by DesktopDynamite View Post
Noticed music slowdown on Jim Power's intro title screen while text is scrolling up and down.

Elysium demo also with music slowing down.
Those are slave issues, not WHDLoad issues.
Akira is offline  
Old 17 September 2018, 13:35   #11
haynor666
retro maniac

haynor666's Avatar
 
Join Date: May 2002
Location: Tarnobrzeg/Poland
Age: 39
Posts: 1,592
I'll try latest 18.4 today and if something changes.

There are some other problems as well - http://eab.abime.net/showthread.php?p=1269521
haynor666 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade to 3.1 Problem... Nobby_UK support.Other 20 05 November 2014 03:13
WHDload upgrade pucci project.WHDLoad 7 13 July 2014 13:38
A500 1mb Chipram Upgrade - Trapdoor problem Amicol Hardware mods 6 07 February 2014 00:37
Memory upgrade killed WHDLoad WildW project.WHDLoad 20 10 August 2008 09:23
Amiga 1200 Kickstart Upgrade - Problem douglasamcintos support.Hardware 9 29 September 2007 21:08

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:09.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.07091 seconds with 13 queries