English Amiga Board


Go Back   English Amiga Board > Coders > Coders. General > Coders. Releases

 
 
Thread Tools
Old 28 December 2019, 20:57   #1
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 597
DevilutionX PPC niche.

Work credits are for Marlon Beijer and Artur Jarosik doing the official Amiga port.

Meanwhile I deal with the results of warpos testing versions:

https://github.com/Cowcat5150/devilutionX/releases

0.1.1 release is compiled with 8bit screenmode code as official port.
0.1 release has an alternative wos version for Morphos systems.

FPS, bugs, comments and death threats: This is the place.
Cowcat is offline  
Old 28 December 2019, 22:54   #2
tolkien
AmigaMan

tolkien's Avatar
 
Join Date: Oct 2012
Location: Castro Urdiales/Spain
Posts: 584
Aupa CowCat!
I have tried it under morphos.
As I said in morphzone, the runs ok but there a few graphic glitches with wrong colors and the save option is not working.

Gracias por el curro tío. Un saludo!
tolkien is offline  
Old 29 December 2019, 00:54   #3
nujack
Zone Friend
nujack's Avatar
 
Join Date: Apr 2005
Location: Leipzig/Germany
Age: 45
Posts: 414
Tested on my A4000 with CSPPC 604/200 and Voodoo3. Game is very playable but has wrong colours in intro and in-game pictures. Furthermore No sound and save-option. After I tried to save I had wrong colours in game too. But good results so far!!!
Attached Thumbnails
Click image for larger version

Name:	1AFDC5F7-0E50-40D4-978D-B8F7F1EA691B.jpg
Views:	61
Size:	895.5 KB
ID:	65716   Click image for larger version

Name:	452ABC3A-4AC0-44D3-8C35-ECD4D8FA96ED.jpg
Views:	82
Size:	1,021.2 KB
ID:	65717   Click image for larger version

Name:	4BA25475-7481-495F-A7E6-CB1F0AF9793A.jpg
Views:	68
Size:	1.02 MB
ID:	65718   Click image for larger version

Name:	43F0A45F-BD3E-4426-AABF-34581DC4A238.jpg
Views:	70
Size:	1.00 MB
ID:	65719   Click image for larger version

Name:	B4DB0A04-A308-46FD-9952-DCDB5A103E6E.jpg
Views:	56
Size:	1.04 MB
ID:	65720  

Click image for larger version

Name:	4DD89E02-FE89-4CB6-A758-3944C17C9697.jpg
Views:	45
Size:	1.10 MB
ID:	65721  
nujack is offline  
Old 29 December 2019, 10:54   #4
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 597
@tolkien De nada tío !

The "wrong" color pictures happen when an error related to filesystem is displayed. Then colors get messed but should be restored when entering game. Playing with menu back and forth could also mess the colors.

What is known for all versions, besides the ppc's.

- The "out of disk space" is one of the symptoms of failing to assign where the amiga paths are.

- Trying to read or save is still not working in official Amiga port.

- In Morphos environment if you let blizzard/movie go to the intro/game, sound is disabled for the game. So be quick to go to principal menu. Of course if you choose see the intro in menu, you get the problem again. It's a hacked compile with sound disabled in movies.

- What versions are people using?

To sumarize:

- devilutionx-alt binary should be used only for Morphos.
- devilutionx and 8bit binaries only for normal Amiga's. The non 8bit version is not tied to a particular screen depth.

@nujack I see "pink" colours in game and don't know what version you used. My guess is if a gfx card is used maybe the non-8 bit could be better. Or try to promote a 640x480 8bit screen for the game.

I also have "pink" colors on Morphos when using my 8bit own version: Of course I have 16bit depth on all screens by default.

Last edited by Cowcat; 29 December 2019 at 11:03.
Cowcat is offline  
Old 29 December 2019, 19:20   #5
AMike
Registered User
AMike's Avatar
 
Join Date: Jan 2007
Location: near Vienna/Austria
Posts: 187
Quote:
Originally Posted by Cowcat View Post
0.1.1 release is compiled with 8bit screenmode code as official port.
Is it possible that this version is not as graphically beautiful as the older version? 8bit is a little faster on my system (15FPS vs. 12FPS 0.1). For both versions it makes more sense to use Paula and not the soundcard - no scratches or bad noises with paula.
AMike is offline  
Old 29 December 2019, 19:56   #6
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 597
Quote:
Is it possible that this version is not as graphically beautiful as the older version?
For what I see (8bit) certainly not.
Cowcat is offline  
Old 29 December 2019, 22:23   #7
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 560
It is missing 8bit fix which is present on 68k.

https://github.com/AmigaPorts/devilu...l_compat.h#L98
arti is offline  
Old 29 December 2019, 22:51   #8
BULI
Registered User

 
Join Date: Dec 2017
Location: Rzeszów
Posts: 257
After little update my settings in system on Ragnarok.

In 16bit version I have:
37-33 FPS sound via SoundBlastera (not perfect synchronized sound in intro)
55-51 FPS sound via Paula (perfect synchronized sound in intro)



In 8bit version I have:
47-40 FPS sound via SoundBlastera (bad/distorted sound in game- SB Stereo ++ 44100)
51-45 FPS sound via Paula (sound OK)
Wrong colors in game.
Wrong playing Intro- in small window, incorrect visible.


Save/Load, EXIT, return to level back (like back from dungeon to ground) are not working in both versions.
BULI is offline  
Old 29 December 2019, 22:55   #9
tolkien
AmigaMan

tolkien's Avatar
 
Join Date: Oct 2012
Location: Castro Urdiales/Spain
Posts: 584
stupid question. How can I see the fps?
tolkien is offline  
Old 29 December 2019, 23:13   #10
BULI
Registered User

 
Join Date: Dec 2017
Location: Rzeszów
Posts: 257
Quote:
Originally Posted by tolkien View Post
stupid question. How can I see the fps?
Use parametr -f in cli/shell
BULI is offline  
Old 29 December 2019, 23:27   #11
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 597
@arti Of course !

Intro in small window is rendered bad. Maybe 6 days of missing github upgrades but other stuff needs to be sorted out.
Cowcat is offline  
Old 29 December 2019, 23:29   #12
tolkien
AmigaMan

tolkien's Avatar
 
Join Date: Oct 2012
Location: Castro Urdiales/Spain
Posts: 584
With a quick test in my morphos machine (powermac g5 2.0ghz) I get around 60fps.
tolkien is offline  
Old 30 December 2019, 00:15   #13
BULI
Registered User

 
Join Date: Dec 2017
Location: Rzeszów
Posts: 257
Quote:
Originally Posted by tolkien View Post
With a quick test in my morphos machine (powermac g5 2.0ghz) I get around 60fps.



He, he litle bether than my A4000 :-)
BULI is offline  
Old 30 December 2019, 00:39   #14
AMike
Registered User
AMike's Avatar
 
Join Date: Jan 2007
Location: near Vienna/Austria
Posts: 187
Quote:
Originally Posted by tolkien View Post
With a quick test in my morphos machine (powermac g5 2.0ghz) I get around 60fps.
I think the game limited to 60fps. On my 2.7 G5 with Radeon 9800pro I got also the same number. Compared to the original Diablo the red and blue colours are changed. Easy to check when you look at your life and mana. Am I the only one with this bug?
AMike is offline  
Old 30 December 2019, 00:41   #15
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 560
Latest 68k version , asm and AMMX optimised gets over 50fps on 78MHz Vampire :-)
arti is offline  
Old 30 December 2019, 00:43   #16
tolkien
AmigaMan

tolkien's Avatar
 
Join Date: Oct 2012
Location: Castro Urdiales/Spain
Posts: 584
Quote:
Originally Posted by AMike View Post
I think the game limited to 60fps. On my 2.7 G5 with Radeon 9800pro I got also the same number. Compared to the original Diablo the red and blue colours are changed. Easy to check when you look at your life and mana. Am I the only one with this bug?
you are right. I have the left sphere in blues and the right in red.
tolkien is offline  
Old 30 December 2019, 15:22   #17
BULI
Registered User

 
Join Date: Dec 2017
Location: Rzeszów
Posts: 257
Quote:
Originally Posted by arti View Post
Latest 68k version , asm and AMMX optimised gets over 50fps on 78MHz Vampire :-)

Very nice result
BULI is offline  
Old 30 December 2019, 23:06   #18
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 560
Quote:
Originally Posted by Cowcat View Post
@arti Of course !

Intro in small window is rendered bad. Maybe 6 days of missing github upgrades but other stuff needs to be sorted out.
Yes, it's fixed in newest upgrades.
arti is offline  
Old 31 December 2019, 12:08   #19
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 597
Quote:
fixed in newest upgrades
Next year then.

Regarding one system performance vs another, people forget that SDL could be a context switch orgy in a warpos binary. Warpos SDL library is in a better shape with Hedeon's involvement, but I guess DevilutionX relies too much on some particular sdl calls, specially events and sound. Great for other systems, not so good here.
Cowcat is offline  
Old 04 January 2020, 01:40   #20
Foxman
Registered User
 
Join Date: Dec 2009
Location: Germany
Posts: 158
I was able to solve the graphics problem under MorphOS

I played around with the screen modes and first went to the ingame resolution of 640x480 with 16 bits and now the colors worked correct.
It is therefore due to the standard 24-bit screen mode from MorphOS.

Simply switch the screen mode from 24bit to 16bit (resolution does not matter) and the twisted colors are over.

Captured here in the video:

[ Show youtube player ]


Have fun
Foxman is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Blizzard PPC 060@66MHz/PPC@330MHz + 128MB RAM (no SCSI) stachu100 MarketPlace 0 07 April 2011 08:45
FS: Blizzard PPC 060@66MHz/PPC@330MHz with SCSI + 128MB RAM stachu100 MarketPlace 1 16 March 2011 00:46
[Found: Mercenary] Fairly niche vector graphics FPS Mountaingod Looking for a game name ? 16 03 December 2008 19:33
Sale: Phase 5 Blizzard PPC 603e+ 68040/25 PPC 240 Mhz wizard66 MarketPlace 6 09 February 2007 18:34
SALE: Amiga Blizzard PPC card PPC@160 , 68040 @25 MHz morka MarketPlace 3 12 October 2006 01:28

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:34.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.09780 seconds with 16 queries