English Amiga Board


Go Back   English Amiga Board > Main > Amiga scene

 
 
Thread Tools
Old 24 December 2019, 16:58   #401
grond
Registered User

 
Join Date: Jun 2015
Location: Germany
Posts: 713
I think the P96 screenmodes just need a little adjusting. Usually setting the pixclock a little higher or lower will do the trick.
grond is offline  
Old 24 December 2019, 21:43   #402
MartinW
Registered User

 
Join Date: Mar 2017
Location: Minehead / UK
Posts: 550
I managed to bring one mode to life by adjusting it slightly but the screen flashes a lot and loses audio. More "normal" modes such as 1280x720 (720p?) I can't get to work at all despite my monitor supporting them (I know because I use other devices at 720p). I was advised to update the SAGA drivers and upgrade to an updated P96 'card' file which I did and it has so far made no difference. There is also a new core on Slack but it's in jic format so I can't install it until I've bought a USB Blaster (wasn't aware I'd need one and all my FPGA stuff either has programming built in or is Xilnix so I only have a Xilinx platform cable, no USB blaster)
MartinW is offline  
Old 28 December 2019, 16:07   #403
MartinW
Registered User

 
Join Date: Mar 2017
Location: Minehead / UK
Posts: 550
SO, finally got enough screen modes working to have a good play about last night. I also installed a network module.

Very much a mixed bag. If I were to be brutal I would certainly say that this is not ready for general release yet. BUT, I understand the need to get it out into the hands of more people in order to test loads of scenarios and get stuff working. I just hope people are realistic in their expectations. Hopefully a lot of these issues will move quite quickly after the holidays.

So right now the biggest issue still seems to be video. As with nearly every Amiga out there as soon as you go beyond PAL / NTSC or the high res versions things become an exercise in frustration. But that's pretty normal for Amiga. What is less so is that the HDMI output is prone to locking up and crashing requiring a power off if it goes into a mode the monitor doesn't support. I think that is a known issue. I don't know if it is drivers or core.

So, about that "mixed bag". This thing is fast. Obviously we know that. Some things I was blown away by how smooth they were. All the doom variants for example - a much better experience than my 68060/100. Freespace - blimey! Never played that before so I can't comment on how it compares. But then I was quite suprised that Worthy crashes at the title screen just as it tries to draw the main menu.

I'm using a CF to SD card adapter plugged into the 44pin header and this works well and is again fast. 10Mbit/s+ according to sysinfo. That's good for an Amiga for sure. But PFS3 corrupted on reset once and I had to re-image. We'll put that one down to me not noticing the drive was active? The external SD works very well for file transfer once I had got it setup correctly (formatted Fat32 from Windows, but there are other ways). It can also load "kick.rom" from external SD too which is also working well.

I'll leave it there for now but I can look at specifics if anyone is interested I guess. So in summary, do I regret buying the V4? Hell no. With one proviso, that it continues to evolve and improve but things are very active and especially given it was Xmas, people were very responsive. But if you are not an experienced user and you are expecting a "just works" experience then it may be prudent to not sweat over availability, sit back and wait a while. I think all the time you will be waiting, this will be improving.

Oh, while writing this,I got a resolution to why Worthy doesn't work. It's related to caches I beleive. If you turn off fastmem then the V4 obviously does that, but also goes into a slow or regular kind of mode. There's still 11+MB of chip mem available but sysinfo will report your machine as 2MIPs. And sure enough, in this mode Worthy worked perfectly. So it may be the answer to a lot of other things that I saw which crashed too like WHDLoad demos. Given Worthy is a title from 2019, maybe we'll see an update so this tweak isn't necessary? For all I know, it may have already been fixed, I don't really track things that well so I don't know if there have been any updates to Worthy since I bought it.

[EDIT] I just wanted to add that I also have a GB-A1000 with 68060 running at 100Mhz, RTG grphics and 128MB fast. While I won't be in a rush to sell that, it was (mostly) built with my own hands afterall, I can't really see me using it anymore. I can see the V4SA completely replacing it! And I consider that high praise indeed.
MartinW is offline  
Old 28 December 2019, 17:31   #404
grond
Registered User

 
Join Date: Jun 2015
Location: Germany
Posts: 713
Hi, Martin,

yes, it is not as simple as the C64-in-a-joystick, it is an Amiga with all the problems that Amigas may have and some more on top because it is not finished yet. Mine now does 1280x720 fine now. So RTG is sorted out for me but e.g. audio doesn't seem to work correctly in anything but PAL modes. Surely a work in progress and already a very fine product. It's already much, much more mature than the V600/500 were when they came out.
grond is offline  
Old 28 December 2019, 17:54   #405
MartinW
Registered User

 
Join Date: Mar 2017
Location: Minehead / UK
Posts: 550
What refresh rate is 1280x720 running at for you? 50 or 60? On the resolution below that (1024x576 maybe?) I had to drop to 40Hz to get a picture and 1280x720 doesn't produce anything at all as much as I have tried. I'm not convinced it will be very usable at that size though anyway!

Believe it or not there are 13 monitors or TVs in this house but only 4 are either available or suitable for the Vampire. It has just dawned on me that the 4th which is in the loft is an old "HD Ready" monitor that only does up to 720p. That might be worth a shot when I get some time.
MartinW is offline  
Old 28 December 2019, 18:03   #406
grond
Registered User

 
Join Date: Jun 2015
Location: Germany
Posts: 713
25 and 30 Hz. I think I already mentioned that mine is a small Techwood TV. It seems to be very tolerant.
grond is offline  
Old 28 December 2019, 18:35   #407
MartinW
Registered User

 
Join Date: Mar 2017
Location: Minehead / UK
Posts: 550
Ahh, right - maybe I'm not going down low enough then! The Apollo wiki says it will maintain 60Hz up to 720p and reduce after that. Either I'm misunderstanding that or that is incorrect information then. I think I'll go a try and find my old 720p TV. That might do the trick too.
MartinW is offline  
Old 28 December 2019, 18:59   #408
grond
Registered User

 
Join Date: Jun 2015
Location: Germany
Posts: 713
I think maximum possible pixel clock is 75 MHz which already may be too high for some cards. The lower you can get a stable picture, the better.
grond is offline  
Old 31 January 2020, 10:13   #409
jbilander
Registered User

jbilander's Avatar
 
Join Date: Jun 2018
Location: Stockholm
Posts: 126
Quote:
Originally Posted by seb132 View Post
@jbilander: nice design, mate.
I like the use of the Bodoni font (original Amiga font) for the Vampire engraved text and the little groove for the logo sticker.
I’d get one if it can be made.
Quote:
Originally Posted by jbilander View Post
Thanks, sure, I'll make it publicly available once I've done a trial printout and verified everything fits correctly, will maybe do some small changes, but before that I need to get all the correct dimensions so I can design for connector cutouts...so will have to wait until I get my hands on a V4 Standalone and then start measure it with a digital caliper.
As promised the 3d-model is now publicly available (on grabcad). I didn't dare to put AMIGA on the case because of the legal situation. I went with VAMPIRE, however it is trivial to DIY in the model should you want to.
jbilander is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to forward data to serial port? utri007 support.Hardware 10 11 November 2016 15:26
CF won't boot A1200 - best path forward? AmigaJules support.Hardware 13 28 June 2016 16:46
"LAG 38 meeting date brought forward a month !!!" rockape News 2 11 June 2014 19:42
CD32 Pad Reverse+Forward+Run Reset Game Problem Hillsy_ support.Games 10 04 May 2014 22:14
Which FPGA Implementation of Amiga are you looking forward too? digiflip Amiga scene 44 06 June 2011 00:22

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 03:52.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.10059 seconds with 16 queries