English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 12 September 2017, 17:05   #1
Phantom
Adventurer

Phantom's Avatar
 
Join Date: Jun 2009
Location: Colossal Cave, Valaii
Posts: 363
Picasso96 problem with HiColor resolutions (slow screen redraw)

I'm having a problem with my Picasso96 settings and although I'm trying to find a solution to this, till now I'm in a dead end. Hope that somebody will enlighten me further.

But first let's start with my hardware setup:

Monitor is a BENQ BL702A 17" (with maximum resolution of 1280x1024)

Amiga 4000D with CyberStorm MKII 060/50Mhz Rev 1
8GB CF IDE HD + 1.44 HB Floppy Drive
PicassoIV + FlickerFixer module
X-Surf 100 + RapidRoad USB module
BigRamPlus 256MB

Chip RAM: 2 MB
Fast RAM: 16 MB (on board) + 256 MB (BigRamPlus) + 128MB CyberStorm MK II = 400 MB

In terms of software:

AmigaOS 3.9 with latest BB4 installed
Kickstart v45.57, Workbench v45.5
Picasso96 1.2e

First of all to clarify some things. Every resolution in chunky mode (8 bit) is fast, with rapid screen redraw etc even on 1280x1024 resolution (non-interlaced).

The problem arises when I try to use the same resolution of 1280x1024 in 16bit HiColor mode (or 24bit TrueColor, but I don't care about that right now), even if I've managed to have a refresh rate of around 53Hz. When I try to switch screens from the Workbench (as an example) the screen redraw is slow, it even needs 3-4 seconds to complete! Also when I try to view some JPG files on the Workbench and try to move the window to a new position, again the redraw of the picture is slow (even if the window dimensions are small, regardless if I use WarpDTs). Again I'm speaking about a non-interlace resolution as I haven't managed to create an interlaced one.

So, do I have hit the maximum of the PicassoIV card or not?

Any help will be much appreciated, thanks.

Last edited by Phantom; 12 September 2017 at 17:10. Reason: Typo.
Phantom is offline  
AdSense AdSense  
Old 12 September 2017, 17:30   #2
Daedalus
Registered User

Daedalus's Avatar
 
Join Date: Jun 2009
Location: Dublin, then Glasgow
Posts: 2,165
1280x1024x16 screenmodes use about 2.6MB of video RAM, so with only 4MB of RAM available on the Picasso IV, switching to a second screen will require that screen's data to be transferred from memory elsewhere in the machine (normally fast RAM), unless it's a lower resolution so it can fit into 1.4MB. This bulk transfer is relatively slow, which is why it feels sluggish at swapping screens. A 1280x1024x24 screen eats pretty much the entire 4MB, so it'll have to swap with fast RAM for pretty much everything. Windows use their own segment of video RAM, so again, having many large or deep windows open will require swapping of that information from the main system RAM.

This is totally separate to refresh rate, which is handled by the Picasso's hardware and not limited by the amount of RAM on board, but the throughput of the RAMDAC.
Daedalus is offline  
Old 12 September 2017, 18:03   #3
Phantom
Adventurer

Phantom's Avatar
 
Join Date: Jun 2009
Location: Colossal Cave, Valaii
Posts: 363
So you mean that a resolution of 1024x768x16 will use approx. 1,57MB of video RAM, thus it will have fast screen redraw?
Phantom is offline  
Old 12 September 2017, 21:57   #4
Daedalus
Registered User

Daedalus's Avatar
 
Join Date: Jun 2009
Location: Dublin, then Glasgow
Posts: 2,165
Well, it will allow more windows and screens to be open with a fast screen draw, yes. But once all your open screens and windows add up to more than 4MB, you'll have slowdowns.
Daedalus is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Different resolutions on the same screen whitebird support.Hardware 11 21 September 2014 09:18
ReSource slow on Picasso96 screen? girv support.Apps 1 12 January 2005 17:44
HELP: Picasso96 to WinUAE: ...too slow Tolismlf support.WinUAE 11 29 November 2004 19:14
Demos slow after Picasso96 prismra support.WinUAE 4 30 March 2004 20:40
picasso96 and screen mode problem Thunderstorm support.WinUAE 1 09 October 2002 05:24

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:26.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.13963 seconds with 12 queries