English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 31 December 2012, 02:39   #1
Yushatak
 
Posts: n/a
Indivision Mk2 A1200 And Now No Turn On :D

Bought A1200. First Amiga, excited. It's a UK model with a UK PSU, so I bought a converter and such. I have no monitor, so I bought an Indivision Mk2 and while I waited, I hooked it up to my CBM 1701 and got a shitty fuzzy cut-off black and white picture of it and had it boot to workbench, so I knew it was in working order.

Indivision arrives. I installed it following directions, grounded properly etc.. Amiga won't turn on. No power light.. I remove the ground, Amiga won't turn on. I remove the Indivision entirely, and Amiga won't turn on. Nothing smells burned, no obvious signs of anything bad... it just won't turn on.

This has the original A1200 PSU so my guess is somehow the Indivision was enough to overwork and kill it?
 
Old 31 December 2012, 13:57   #2
diablothe2nd
Registered User

diablothe2nd's Avatar
 
Join Date: Dec 2011
Location: Northampton, UK
Age: 36
Posts: 1,232
Quote:
Originally Posted by Yushatak View Post
This has the original A1200 PSU so my guess is somehow the Indivision was enough to overwork and kill it?
My thoughts too, unless you put the indi in the wrong way around which I doubt you have as it's pretty self explanatory to fit.

Have you got a multimeter to test the 12v and 5v lines?

Welcome to Club Amiga

edit- also check the fuse in the psu plug, as it may have blown from old age.
diablothe2nd is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Indivision AGA Mk2 CR Loedown Amiga scene 91 05 December 2016 23:06
Indivision AGA MK2 & A1200 shielding manic23 support.Hardware 6 29 May 2013 09:44
WTB - Indivision AGA Mk2 A1200 caver99 MarketPlace 7 09 April 2013 07:09
Indivision AGA Mk2 stopped working Crawff support.Hardware 24 24 August 2012 15:46
Indivision AGA MK2 Wanted Seblington MarketPlace 5 22 August 2011 12:52

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 06:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.64481 seconds with 15 queries