English Amiga Board


Go Back   English Amiga Board > Support > support.Other

 
 
Thread Tools
Old 22 December 2017, 11:22   #1
xxx777
Registered User

 
Join Date: Dec 2017
Location: cardiff/uk
Posts: 1
im getting cant open libncurses.ixlibrary even though its installed

ive tried adding and assigning the usr directory (whatever that is for) too and this doesnt make any difference either.
xxx777 is offline  
AdSense AdSense  
Old 23 December 2017, 14:26   #2
ViLXDRYAD
Avocado lover

ViLXDRYAD's Avatar
 
Join Date: Nov 2016
Location: Avocado Forest
Posts: 56
can you elaborate more? where did libncurses.ixlibrary came from? is a fille from an instalation? are you trying to open it from another program? what program if so? just says "Can't open libncurses.ixlibrary" and nothing else?

i can't determine what's wrong with just the info you posted
ViLXDRYAD is offline  
Old 23 December 2017, 14:48   #3
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
looking on aminet I found ncurses-5.5-1-usr-m68k.
I made the usr: assign and tested bastet.

bastet does work if you set the TERM variable before you start bastet itself:
1> setenv TERM amiga
1> bastet

not all keys work, but this way it does start.
basket you can stop by using CTRL-C in the shell it is running.

the usr: folder holds many different terminal configs, one of them is amiga.
just take a look, there are many more you can test:
1> setenv TERM amiga-f
1> setenv TERM commodore
1> setenv TERM ansi
...
emufan is offline  
Old 23 December 2017, 15:31   #4
Locutus
Registered User

 
Join Date: Jul 2014
Location: Finland
Posts: 831
random thoughts:

it might try to look in /usr/share/ for termcap files and thats what it needs the USR: assign for.

it might not link 'unix-side' because of a missing LDPATH environment variable
Locutus is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Open Screen / Open Font AGS Coders. System 7 02 March 2014 05:08
Open Amiga Game Database - Open Beta FrodeSolheim support.FS-UAE 3 01 May 2013 22:37
Installed Deneb and now nothing. RMK support.Hardware 8 03 February 2011 02:12
Various HD-installed Games Echo support.WinUAE 2 20 July 2003 14:15
Installed OS 3.9 but.....!!! dmrvf support.Hardware 8 11 June 2003 16:04

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 01:41.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.05671 seconds with 13 queries