English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 18 April 2018, 15:56   #181
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 2,882
Quote:
Originally Posted by mark_k View Post
Has anyone noticed keyboard issues, with keys sometimes repeating several times quickly?
Yes also with Win7 32Bit, i had said it HERE, furthermore also creates problems with audio (fragmented mp3s)
AMIGASYSTEM is offline  
AdSense AdSense  
Old 18 April 2018, 16:09   #182
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,065
Quote:
Originally Posted by Leandro Jardim View Post
The color bars are flickering all over the screen but mainly at the top. They seem to compete for its place, sometimes. The first beta it was 99% stable all the time.
And first beta is still stable? Please confirm because sometimes something else caused the problem.

EDIT: also disabling sound makes no difference?

Last edited by Toni Wilen; 18 April 2018 at 17:25.
Toni Wilen is online now  
Old 18 April 2018, 16:27   #183
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 46
Posts: 11,030
A bit of the color bars (not enabled with F9+End though) are part of the actual Amiga image. It was gone in some older 4.0 betas but with todays beta it's back. Happens only with lagless Vsync enabled.

Retro-Nerd is offline  
Old 18 April 2018, 16:31   #184
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,065
Quote:
Originally Posted by Retro-Nerd View Post
A bit of the color bars (not enabled with F9+End though) are part of the actual Amiga image. It was gone in some older 4.0 betas but with todays beta it's back.

They are extra debug colors that sometimes I forgot to disable.

It shows if positioning is correct: large color bars should always change color in the middle of small color bars. (except first one)

Can be easily seen when autoscale is enabled, color changes are not in correct positions, causing tearing.
Toni Wilen is online now  
Old 18 April 2018, 16:34   #185
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 46
Posts: 11,030
Ah ok, good to know.
Retro-Nerd is offline  
Old 18 April 2018, 16:40   #186
Pyromania
Moderator

Pyromania's Avatar
 
Join Date: Jan 2002
Location: Chicago, IL
Posts: 1,810
Thanks for all the hard work you put into WinUAE Toni.
Pyromania is offline  
Old 18 April 2018, 20:24   #187
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,065
http://www.winuae.net/files/b/winuae_4000b3.7z
http://www.winuae.net/files/b/winuae64_4000b3.7z

Beta 3:

- New low latency vsync should now work under Windows XP, D3D9 only.
- Added ICD AdSCSI ROM with icddisk.device v33.0 (unknown ROM version, most likely v2.0 or v2.1) and v34.0 (v2.2 ROM version)
- Added MacroSystem DraCo v1.3 Boot ROM. Set it as extended ROM, A3000 KS 3.1 as normal ROM. (Boots and hangs like Casablanca)
- Fixed MOVE16 debugger disassembly.
- Fixed HDF/directory harddrive unit number conflict (if directory was between HDFs in harddrives list) introduced in b1.
- Fixed randomly occurring timing issue. Reported refresh rate suddenly increased and it looked like warp mode was activated.
- Full-window mode is now supported in virtual multi monitor mode. Native mode window opens on selected monitor, next virtual monitor opens on following real monitor and so on (or on top of existing window if not enough real monitors)
Toni Wilen is online now  
Old 18 April 2018, 21:53   #188
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 41
Posts: 11,040
Thanks for beta 3 Toni

Just thought I'd mention.

Tested "Low latency VSync" with both Direct3D9 and Direct3D11

Both work but I'm still suffering from everything seeming sped up i.e. audio / tunes are 50% quicker. Also CPU LED is always around 90% -100%.

Let me know if you want logs etc. but not important for now.

Last edited by DamienD; 18 April 2018 at 22:05.
DamienD is offline  
Old 18 April 2018, 22:03   #189
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 46
Posts: 11,030
I thought you can't output real 50Hz, Damien. In 60Hz all PAL games runs faster if Vsync is enabled. Not 50% though.
Retro-Nerd is offline  
Old 18 April 2018, 22:07   #190
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 41
Posts: 11,040
Quote:
Originally Posted by Retro-Nerd View Post
I thought you can't output real 50Hz, Damien. In 60Hz all PAL games runs faster if Vsync is enabled. Not 50% though.
Maybe not 50% but 25%.

Yeah, I can't output to 50Hz on my laptop.

This isn't an issue with - / default Vsync with Direct3D9; all is pretty perfectly.
DamienD is offline  
Old 18 April 2018, 22:09   #191
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 46
Posts: 11,030
I guess the default Vsync doesn't work anymore like years before.
Retro-Nerd is offline  
Old 18 April 2018, 22:10   #192
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 41
Posts: 11,040
No default Vsync still works great for me
DamienD is offline  
Old 18 April 2018, 22:12   #193
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 46
Posts: 11,030
But you do understand what i wrote? I meant that the default Vsync works differently as years before. It's not fixable with lagless Vsync enabled. It will always run a bit faster.
Retro-Nerd is offline  
Old 18 April 2018, 22:16   #194
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 41
Posts: 11,040
Quote:
Originally Posted by Retro-Nerd View Post
But you do understand what i wrote? I meant that the default Vsync works differently as years before. It's not fixable with lagless Vsync enabled. It will always run a bit faster.
Yeah understand

Hence why I haven't been that excited about this new feature; I mean, sounds friggin' awesome but not going to happen on my laptop...

...anyway, I'm very cool with how things are with Direct3D9 and default Vsync.
DamienD is offline  
Old 18 April 2018, 23:08   #195
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 46
Posts: 11,030
But as i said. For a quick test you could load the NTSC version of Pinball Fantasies, with NTSC Amiga settings enabled+60Hz lagless vsync. Then the music plays in the correct speed and you get a glimpse of the wow effect.
Retro-Nerd is offline  
Old 18 April 2018, 23:10   #196
mcbpete
Zone Friend
mcbpete's Avatar
 
Join Date: Oct 2004
Location: London, England
Age: 36
Posts: 154
Send a message via MSN to mcbpete Send a message via Yahoo to mcbpete
Damien - As a gfx card buddy, just to mention d3d11 has been working absolutely fine at my end since it was introduced around 3.6.x. Seemed to drop the CPU usage from when I had WinUAE running d3d9 as well. Obviously no joy with LL due to the same 60hz issue...
mcbpete is offline  
Old 19 April 2018, 00:33   #197
Steve
Truth seeker...
Steve's Avatar
 
Join Date: Jul 2001
Location: UK
Age: 39
Posts: 2,165
Is there any way to eliminate the tearing at the top of the screen on low latency 50hz mode? A couple of times in the earlier beta's it seemed fairly solid (maybe by accident only or just randomly) but since then there has always been tearing at the top of the screen during scrolling.

End+F9 vsync bars show a small dark blue line as a constant presence in the top 5% of the display. Strange because everything else seems fine apart from the tearing. CPU usage is around 60% only.
Steve is offline  
Old 19 April 2018, 01:21   #198
Leandro Jardim
Registered User
Leandro Jardim's Avatar
 
Join Date: Nov 2009
Location: Legoland
Age: 39
Posts: 1,196
Quote:
Originally Posted by Steve View Post
Is there any way to eliminate the tearing at the top of the screen on low latency 50hz mode? A couple of times in the earlier beta's it seemed fairly solid (maybe by accident only or just randomly) but since then there has always been tearing at the top of the screen during scrolling.

End+F9 vsync bars show a small dark blue line as a constant presence in the top 5% of the display. Strange because everything else seems fine apart from the tearing. CPU usage is around 60% only.
Here too. But seems that a good game to check this is James Pond II AGA. A couple of times it gave problems here... Of which game in particular you are speaking?
Leandro Jardim is offline  
Old 19 April 2018, 02:22   #199
MagikGimp
Registered User
MagikGimp's Avatar
 
Join Date: Dec 2011
Location: Neath / Wales
Age: 35
Posts: 41
Send a message via ICQ to MagikGimp Send a message via AIM to MagikGimp Send a message via MSN to MagikGimp Send a message via Yahoo to MagikGimp
Floppy disk

Hi Toni,

Some "mini-dump" crash files or whatever they are I've had generated over the last few days of recently revisiting this hobby, if you're interested. I get the feeling my whole setup is borked. Please do let me know if this is actually the case!

Oh, they're for beta 2. And now you've released 3. Damn it!
Attached Files
File Type: zip WinUAE dmp files.zip (378.3 KB, 3 views)

Last edited by MagikGimp; 19 April 2018 at 02:23. Reason: Falling off the cutting edge
MagikGimp is offline  
Old 19 April 2018, 10:51   #200
Mclane
Old fart!

Mclane's Avatar
 
Join Date: Apr 2002
Location: Northolt, West London
Age: 56
Posts: 558
The audio here under the new non lag vsync is faster because its tuned like most cheap monitors to 60 / 75Hz so you get a roughly 17.5% increase in speed which I expected but it seems some are getting more speed. I can get double speed by pressing Prntscreen key but that screws up the picture too.

(resets ok when F12 used)

Moral of the story for PAL users on PAL games, get a better monitor that handles 50 or 100HZ, damn I wish my iilyama still worked!!

CRT still rules the waves for scrolling...
Mclane is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
psygon
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE 3.2.2 beta series Toni Wilen support.WinUAE 21 20 December 2015 17:35
WinUAE 3.1.0 beta series Toni Wilen support.WinUAE 305 06 June 2015 23:25
WinUAE 2.3.3 beta series Toni Wilen support.WinUAE 124 17 September 2011 15:48
WinUAE 2.0.0 beta series Toni Wilen support.WinUAE 445 13 December 2009 14:46
WinUAE 1.6.1 beta series Toni Wilen support.WinUAE 54 18 June 2009 11:05

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:51.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.09974 seconds with 16 queries