English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 10 November 2020, 01:25   #281
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,362
Quote:
Originally Posted by Toni Wilen View Post

Attach dump from 4.4.0, thanks. (Not really beta related but it still might be same problem after all)
Toni I attach Log and config from 4.4.0 , i do not have a dump how to generate it?

Last edited by AMIGASYSTEM; 22 November 2020 at 21:35.
AMIGASYSTEM is offline  
Old 10 November 2020, 17:49   #282
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,566
Quote:
Originally Posted by AMIGASYSTEM View Post
Toni I attach Log and config from 4.4.0 , i do not have a dump how to generate it?
Quote:
Toni last version worked is WinUAE 4.4.0 beta8
Quote:
WinUAE 4.4.0 no problem.
Does not compute
Toni Wilen is offline  
Old 10 November 2020, 20:03   #283
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,566
Quote:
Originally Posted by Mad-Matt View Post
Small bug that's probably a quick fix.

With CVision3D (Not tested any others) Doublescan is not producing expected behavior with HiColor screens.

With both cgxmode and p96mode selecting a 320x240 or any other low res mode results with doublescan only vertically doubling in 15/16 mode. 8,24,32 bit modes fully double vert/hori as expected.
Fixed. And also interlace modes fixed.
Toni Wilen is offline  
Old 10 November 2020, 20:38   #284
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,362
Thanks Toni, with winuae.7z today also the problem i reported has been fixed.
AMIGASYSTEM is offline  
Old 10 November 2020, 20:39   #285
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,566
Quote:
Originally Posted by AMIGASYSTEM View Post
Thanks Toni, with winuae.7z today also the problem i reported has been fixed.
It isn't "fixed". See previous posts about the problem. winuae.7z is not compiled with best optimization settings.
Toni Wilen is offline  
Old 12 November 2020, 12:17   #286
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,362
Yes I read Toni, I just wanted to report that the problem I reported is no longer with the last winuae.7z
AMIGASYSTEM is offline  
Old 12 November 2020, 15:25   #287
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 45
Posts: 1,622
Quote:
Originally Posted by AMIGASYSTEM View Post
Yes I read Toni, I just wanted to report that the problem I reported is no longer with the last winuae.7z
Always try to reproduce the bug with 64bit AND 32bit beta versions. There were some problems with previous 64bit versions that never showed up with 32bit build, and Winuae.7z are usually 32bit versions AFAIK... in addition to what Toni said about missing optimizations.
hexaae is offline  
Old 13 November 2020, 23:01   #288
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 45
Posts: 1,622
Quote:
Originally Posted by Toni Wilen View Post
Fixed. winuae64.7z updated. Was too simple, 64-bit JIT uses different m68k to x64 flag mapping but required define was missed. (I'd have expected much larger problems than rexx interpreter getting confused, so most likely this code was only used when there was some specific JIT to non-JIT or vice versa transition was needed)
Mmh, today I got a suspicious 'AREXX Handler' 80000008 crash using my usual THE shortcuts from WB. Never seen before.
Using WinUAE zip b10 10/nov
Will try to reproduce it if I can...

Last edited by hexaae; 13 November 2020 at 23:08.
hexaae is offline  
Old 22 November 2020, 17:39   #289
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,566
https://download.abime.net/winuae/fi...uae_4500b11.7z
https://download.abime.net/winuae/fi...e64_4500b11.7z

Beta 11:

- S3Trio/S3Virge double scan mode detection fixed. Calculation used size parameters before bit depth specific screen width adjustments.
- Hardware emulated RTG boards interlace modes fixed.
- Added DMA capable RAM checkbox to RAM GUI panel.
- Added force 16-bit checkbox to RAM GUI panel. Affects more compatible and cycle-exact CPU modes only. If 68020+ and 16-bit: CPU always splits 32-bit accesses to two 16-bit accesses. Defaults have not changed, chip ram is 32-bit if A3000 or AGA, all other RAM is 32-bit if 68020+ CPU. Most common use case is to be able to change "slow" RAM bus width. ("Real" 16-bit "slow" ram vs 32-bit accelerator board "slow" ram)
- Lightpen cursor left trails if vertical centering was enabled.
- Effects 11 (FX11) updated to latest (and apparently final) version. WinUAE uses it to support D3D9 shaders in D3D11 mode.
- Fixed HAM left border corruption if overscan HAM mode and bitplane horizontal start was earlier than current filter horizontal start. (Old bug)
- scp disk image format support fix (keirf). Account for residual flux time at end of final revolution. Fix double replay of revolution #0 when track is initially loaded.
- uaedbg does not anymore report word reads from execbase or exception vectors as invalid if CPU is 68000/68010 or if chip ram is 16-bit wide.
- $bfff00 debug logging word/long behavior changed. Format string without %l (except pointers: %p, %s and %b) is now consided word even if long was written to $bfff00.
- A2386SX 1.2M floppy error workaround. It expects to read 1.2M and 1.4M floppies using 720k floppy bit rate. 1.4M was already worked around previously. (Software thinks it is using shared Amiga 1760k drive, "Flipper" hardware is not emulated).
Toni Wilen is offline  
Old 23 November 2020, 22:08   #290
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 49
Posts: 4,942
I've noticed that since some 4.5 beta (can't say exactly when), when the computer is set to sleep mode with winuae running (paused or interrupted in winuae debugger), on resume it's impossible to get control of the app: the app doesn't respond and I have to kill it and relaunch.

When interrupted in winuae debugger, it's possible to return to emulation with "g" but then the program ceases to respond.
jotd is offline  
Old 24 November 2020, 18:33   #291
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,566
Quote:
Originally Posted by jotd View Post
I've noticed that since some 4.5 beta (can't say exactly when), when the computer is set to sleep mode with winuae running (paused or interrupted in winuae debugger), on resume it's impossible to get control of the app: the app doesn't respond and I have to kill it and relaunch.

When interrupted in winuae debugger, it's possible to return to emulation with "g" but then the program ceases to respond.
I can't duplicate. After resuming from sleep + g in debugger: no hang. Anything in logs? (use windowed mode log window = use -log parameter or you might lose last few messages)
Toni Wilen is offline  
Old 26 November 2020, 19:03   #292
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 45
Posts: 1,622
b11 runs very well for me. Even some nasty WHDLoad games now run better and more "consistently" (i.e. I have to use less strange degradation combos through uae-configuration tool to make some of them run perfectly well in speed and smoothness)
hexaae is offline  
Old 30 November 2020, 21:47   #293
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 996
first time this happens to me using winuae64.exe beta11
definitely a false positive.
The elimination of winuae64.exe happened while I was using a "folder" on the windows desktop as an archive with only files dedicated to amiga.
sorry for reporting certainly repeat a false positive

Last edited by White; 12 December 2020 at 11:52.
White is offline  
Old 30 November 2020, 22:14   #294
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 996
I repeated several times the copy from the "folder" of the desktop with the amiga files inside the hd using winuae64.exe beta11, nothing is detected anymore
White is offline  
Old 06 December 2020, 16:05   #295
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,566
https://download.abime.net/winuae/fi...uae_4500b12.7z
https://download.abime.net/winuae/fi...e64_4500b12.7z

Beta 12:

- 68000/010 cycle-exact/prefetch: If long write access, check IPL when first word of long has been written, not after last word. Fixes Made in Croatia / Binary (again).
- Cycle-exact blitter DMA sequencer emulation now matches real hardware shift register based logic. Includes almost accurate emulation of on the fly modifications of BLTCON0/BLTCON1 (blitter cycle diagram changes). This should fix remaining A500 demos that do stupid things with the blitter. For example TLC Lotus 2 crack intro which is very broken.
- When in warp mode, alternate between 10 and 11 skipped frames (was always 10). Previously if program showed exactly 10 frame animation, it looked like emulation had paused.
- Reverted b1 copper skip update, it broke Tek/Rampage.
- Added Hardital Synthesis emulation.
- Added M.A.S.T. Fireball emulation

Hardital Synthesis:
- Clone of ICD AdSCSI (It seems to be common theme: Hardital Dotto is a clone of ICD AdIDE, Hardital TQM appears to be a clone of DKB Cobra)
- Identical autoconfig data.
- Driver has strings "ICDBoot.device", "ICD BootRom (C)1992" "hidden" in nibble part of boot ROM. All visible strings have been edited from "ICD" to "SYN". Different than AdSCSI ROMs, probably based on later not yet dumped AdSCSI ROM version.

M.A.S.T. Fireball:
- True DMA! Has really weird way to set up DMA controller address pointer, it needs minimum of 7*2 IO writes, max (7+6*7)*2 IO writes to configure it. Yes, amount of writes depends on DMA address value.
- Not RDB compatible. Uses same partition table structure as A2090.
- ROM version string: "FireBall 0.4 (10 Mar 1990)"
Toni Wilen is offline  
Old 06 December 2020, 18:50   #296
AZka
Registered User

 
Join Date: Dec 2016
Location: Budapest
Posts: 26
Thank You!!!!
AZka is offline  
Old 08 December 2020, 23:18   #297
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 45
Posts: 1,622
Issues with WHDLoad Blastar (Core Games) and flickering parallax background/sprites... Was perfect with b11.
hexaae is offline  
Old 08 December 2020, 23:50   #298
DesertBlizzard
Registered User

 
Join Date: Jul 2018
Location: Gilbert
Posts: 11
Andromeda's D.O.S demo via whdload. Prior versions also have problems with this demo, but 4.5b12 has improved it somewhat. Not sure if this is a good test candidate for improving WinUAE. I cannot seem to find any combination of options that will make this demo work without artifacts. Exact cycle, nothing.

Also. Selecting a rom and saving the configuration seems to save the selected rom, however it will not actually stick and take effect until WinUAE is closed and restarted, or if the selected configuration is reloaded by pressing the reload button. Pressing Reset does nothing.

https://www.pouet.net/prod.php?which=404
DesertBlizzard is offline  
Old 09 December 2020, 01:08   #299
hexaae
Bug hunter

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 45
Posts: 1,622
Quote:
Originally Posted by DesertBlizzard View Post
Andromeda's D.O.S demo via whdload. Prior versions also have problems with this demo, but 4.5b12 has improved it somewhat. Not sure if this is a good test candidate for improving WinUAE. I cannot seem to find any combination of options that will make this demo work without artifacts. Exact cycle, nothing.

Also. Selecting a rom and saving the configuration seems to save the selected rom, however it will not actually stick and take effect until WinUAE is closed and restarted, or if the selected configuration is reloaded by pressing the reload button. Pressing Reset does nothing.

https://www.pouet.net/prod.php?which=404
I've found some settings that seem to work (also for Blastar game above) which degrade WinUAE enough to make this demo run fine. Use these tooltypes and see if it works:

Code:
SLAVE=DOS.slave
  PRELOAD
  ExecuteStartup=
  ExecutePostDisk=uae-configuration cachesize 0 finegrain_cpu_speed 0 cpu_speed real cpu_throttle -850
  Cache
Weird combo of options but seems ok slowing down WinUAE even more than CYCLE_EXACT TRUE, CPU_SPEED REAL.
The mysterious setting "finegrain_cpu_speed <n>" is a lifesaver in these cases when you have to slow it down to a slow A500.
My cfg in signature (060 AGA+RTG WB+JIT...)

P.S. There's just a small glitch at the red-blue pyramids scene, an horizontal line but I'm afraid is reproducible also on real HW + current WHDLoad version. Probably a slave issue.

Last edited by hexaae; 09 December 2020 at 02:26.
hexaae is offline  
Old 09 December 2020, 02:35   #300
DesertBlizzard
Registered User

 
Join Date: Jul 2018
Location: Gilbert
Posts: 11
Quote:
Originally Posted by hexaae View Post

P.S. There's just a small glitch at the red-blue pyramids scene, an horizontal line but I'm afraid is reproducible also on real HW + current WHDLoad version.
Sadly I do not have real hardware to confirm glitches. Yes, I also always see the same problems with the pyramids, as well as flickering of the scrolling checkerboard floor the balls are bouncing on. The wobbling Andromeda wobble animation flickers (same thing as the pyramids) behind the AmigaDos text, and the scoller below the gears stutters and "The End" screen is not smooth.

This one really needs the Wait for Blitter hack to work properly, but other than that, the results are exactly the same regardless of the options or tooltypes I try.

Also, on another note, DX11 screen tears A LOT compared to other betas and older revisions of WinUAE. DX9 is great, just as are all the others.

AmiKitXE on 3.1.4.1 / 020.
DesertBlizzard is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE 4.2.0 beta series Toni Wilen support.WinUAE 69 09 April 2019 19:31
WinUAE 3.4.0 beta series Toni Wilen support.WinUAE 464 20 December 2016 16:56
WinUAE 3.2.0 beta series Toni Wilen support.WinUAE 385 09 November 2015 00:06
WinUAE 2.4.1 beta series Toni Wilen support.WinUAE 223 09 May 2012 17:16
WinUAE 2.2.0 beta series Toni Wilen support.WinUAE 119 28 June 2010 03:35

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 06:36.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.10342 seconds with 14 queries