English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 12 November 2009, 18:57   #1
Fieldday
Registered User
 
Join Date: May 2009
Location: Germany
Posts: 60
A4091 problem?

Hi, I got a A4091 SCSI Controller but when I put it into my Amiga 4000 the system hung. I see a black screen und hear no clicking from the floppy drive. I use a A4000 with 3630 accelation card. Does anyone has a hint what could be damaged?
Fieldday is offline  
AdSense AdSense  
Old 12 November 2009, 19:14   #2
zipper
Registered User
 
Join Date: Mar 2004
Location: finland
Posts: 1,031
http://wonkity.com/~wblock/a4000hard/a4091ref.html
zipper is offline  
Old 12 November 2009, 19:36   #3
Fieldday
Registered User
 
Join Date: May 2009
Location: Germany
Posts: 60
Thanks for that link. Did I understand it right, that card works only with > 040 accelation card?
Fieldday is offline  
Old 12 November 2009, 21:04   #4
alexh
Thalion Webshrine
alexh's Avatar
 
Join Date: Jan 2004
Location: Oxford
Posts: 11,227
I dont think that is what the reference is saying. It is just pointing out that if you use an A3640 then there are problems with v3.0 of that board.

I imagine A4091 should work with A3630.

The important thing is you need a REV 11 buster chip
alexh is offline  
Old 13 November 2009, 00:01   #5
Fieldday
Registered User
 
Join Date: May 2009
Location: Germany
Posts: 60
In this case, my Amiga have alle requirements. - A4000 - Buster 11 - A3630 - only A4091 on daughterboard When I turn on the Amiga, black screen and I canīt hear clicking floppy drive. There are a lot of wires on front and back side. First I will check there correct connections. Thanks FD
Fieldday is offline  
Old 13 November 2009, 00:57   #6
alexh
Thalion Webshrine
alexh's Avatar
 
Join Date: Jan 2004
Location: Oxford
Posts: 11,227
Try a different slot.
alexh is offline  
Old 13 November 2009, 11:28   #7
Fieldday
Registered User
 
Join Date: May 2009
Location: Germany
Posts: 60
Same effect on all 4 slots. Well, I want try re-flashing the rom but donīt know where I could find the hex file.
Fieldday is offline  
Old 19 November 2009, 00:19   #8
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 9,689
Quote:
Originally Posted by Fieldday View Post
Well, I want try re-flashing the rom but donīt know where I could find the hex file.
http://vintagecomputercafe.com/amiga...91rev40.11.zip
prowler is offline  
Old 19 November 2009, 01:39   #9
alexh
Thalion Webshrine
alexh's Avatar
 
Join Date: Jan 2004
Location: Oxford
Posts: 11,227
Are the ROMS are flash / have ICP (in circuit programming)? Will you not need an EPROM programmer?

Before programming anything you need to verify what is what. The link above says v40.11 but the txt file in it says v40.13 which was the last one.
alexh is offline  
Old 30 November 2009, 08:07   #10
TjLaZer
Registered User
TjLaZer's Avatar
 
Join Date: Sep 2004
Location: Tacoma, WA USA
Age: 42
Posts: 674
It's version 40.13

http://vintagecomputercafe.com/amiga...91rev40.13.zip
TjLaZer is offline  
Old 30 November 2009, 12:22   #11
Fieldday
Registered User
 
Join Date: May 2009
Location: Germany
Posts: 60
Thanks for the download link. I will test it when I have more spare time. FD
Fieldday is offline  
Old 30 November 2009, 22:17   #12
Fieldday
Registered User
 
Join Date: May 2009
Location: Germany
Posts: 60
ok, back from front. Prgramming the eprom dosenīt has any effect. Maybe one or more gals are not correct working. So I want to desolder them but where could I find the jdec files?
Fieldday is offline  
Old 07 December 2009, 22:37   #13
Fieldday
Registered User
 
Join Date: May 2009
Location: Germany
Posts: 60
Hi,
does anyone know where I could find GAL jedec files?
What are the differences between boardlayout from Commodore to DKB?
I also looking for a hires picture of the backsite from Commodore A4091.

thanks

FD
Fieldday is offline  
Old 07 December 2009, 23:01   #14
alexh
Thalion Webshrine
alexh's Avatar
 
Join Date: Jan 2004
Location: Oxford
Posts: 11,227
They were in the Dave Haynie archive but it is down atm.

Maybe someone made a copy of them?

Here is a picture of the back of C= A4091

http://www.amiga-hardware.com/downlo...4091_3_big.jpg
alexh is offline  
Old 08 December 2009, 07:26   #15
zipper
Registered User
 
Join Date: Mar 2004
Location: finland
Posts: 1,031
Quote:
Originally Posted by alexh View Post
They were in the Dave Haynie archive but it is down atm.
Don't forget the time machine:

http://web.archive.org/web/200804202...ii/a4091/pals/
zipper is offline  
Old 08 December 2009, 11:48   #16
alexh
Thalion Webshrine
alexh's Avatar
 
Join Date: Jan 2004
Location: Oxford
Posts: 11,227
Very rare archive.org stores binaries.

For some reason they have archived these as txt files

Edit: Ooops they are txt files.
alexh is offline  
Old 08 December 2009, 13:53   #17
Fieldday
Registered User
 
Join Date: May 2009
Location: Germany
Posts: 60
Hi,
Quote:
Originally Posted by alexh View Post
Here is a picture of the back of C= A4091

http://www.amiga-hardware.com/downlo...4091_3_big.jpg
Thank, but itīs from DKB A4091. The one from Commodore had a lot of wires on front and back side.
Thanks for the GALs, I want try them

FD
Fieldday is offline  
Old 08 December 2009, 14:49   #18
alexh
Thalion Webshrine
alexh's Avatar
 
Join Date: Jan 2004
Location: Oxford
Posts: 11,227
Quote:
Originally Posted by Fieldday View Post
Thank, but itīs from DKB A4091.
Ok. It does say C= A4091 REV B / Commodore Electronics LTD but maybe the DKB one also had Commodore on the silk screen?

Quote:
Thanks for the GALs, I want try them
PALs?
alexh is offline  
Old 08 December 2009, 20:17   #19
Fieldday
Registered User
 
Join Date: May 2009
Location: Germany
Posts: 60
Hi,
original Commodore Board has Rev. A
Fieldday is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
A590 and A4091 ROM? Fieldday request.Other 10 11 February 2014 22:06
A4091 troubles (3.9GB limit?) Zetr0 support.Hardware 12 26 September 2010 21:22
A4091 info JuvUK support.Hardware 8 21 July 2010 17:05
Picasso IV and A4091 jimbo100 support.Hardware 5 29 July 2007 11:18
DKB A4091 SCSI Hard Drives jimbo100 support.Hardware 1 10 June 2007 21:46

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 03:05.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Page generated in 0.30405 seconds with 11 queries