English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 15 May 2016, 06:42   #1
Starglider 2
Registered User

Starglider 2's Avatar
 
Join Date: Jan 2014
Location: California
Posts: 759
Any A500 apps that trick other apps into seeing a 68020?

I'm running an A500+ with 68000 but there's just one program I really need to get running, but it requires a 68020. Are there any utilities that will trick other programs to think they "see" a 68020 environment, and therefore run (however slowly)?
Starglider 2 is offline  
AdSense AdSense  
Old 15 May 2016, 07:24   #2
alexh
Thalion Webshrine
alexh's Avatar
 
Join Date: Jan 2004
Location: Oxford
Posts: 11,880
Only an emulator. You would be better off posting the app and seeing if anyone can patch it to run on 68000
alexh is offline  
Old 15 May 2016, 07:27   #3
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,490
Your mileage may vary but here it is:

http://aminet.net/util/misc/Run68017.lzh
gulliver is offline  
Old 15 May 2016, 08:26   #4
Starglider 2
Registered User

Starglider 2's Avatar
 
Join Date: Jan 2014
Location: California
Posts: 759
Quote:
Originally Posted by gulliver View Post
Your mileage may vary but here it is:

http://aminet.net/util/misc/Run68017.lzh
Thanks but unfortunately this didn't work. The program just kept crashing.

Edit: The program I'm trying to get working is YAM 2.9, or any email client that allows me to specify the SMTP Port and set Authentication to "OFF". End goal, send email from A500+ (see http://eab.abime.net/showthread.php?t=81616&page=3)

Last edited by Starglider 2; 15 May 2016 at 08:39.
Starglider 2 is offline  
Old 15 May 2016, 08:38   #5
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,490
Another option that works is disassebling the executable with ADis and reassemble it back with Phxass. Small programs are most of the time straightforward, but big programs require lots of rework.
gulliver is offline  
Old 15 May 2016, 08:39   #6
Starglider 2
Registered User

Starglider 2's Avatar
 
Join Date: Jan 2014
Location: California
Posts: 759
Quote:
Originally Posted by gulliver View Post
Another option that works is disassebling the executable with ADis and reassemble it back with Phxass. Small programs are most of the time straightforward, but big programs require lots of rework.
Yikes, I wouldn't know where to start. I edited my post above with my ultimate need however.
Starglider 2 is offline  
Old 15 May 2016, 14:11   #7
utri007
mä vaan
 
Join Date: Nov 2001
Location: Finland
Posts: 644
Some programs wich requires 68020, works nicely with 68010 wich is drop in Place replacent for 68000 cpu
utri007 is offline  
Old 15 May 2016, 19:24   #8
nogginthenog
Amigan

 
Join Date: Feb 2012
Location: London
Posts: 472
Quote:
Originally Posted by utri007 View Post
Some programs wich requires 68020, works nicely with 68010 wich is drop in Place replacent for 68000 cpu
Not true. The 68010 is a 68000 with a very small cache (and a few bits that are not relevant to AmigaOS). I think you can move the VBR to fast ram which is nice though.
nogginthenog is offline  
Old 15 May 2016, 19:26   #9
nogginthenog
Amigan

 
Join Date: Feb 2012
Location: London
Posts: 472
Quote:
Originally Posted by Starglider 2 View Post
I'm running an A500+ with 68000 but there's just one program I really need to get running, but it requires a 68020. Are there any utilities that will trick other programs to think they "see" a 68020 environment, and therefore run (however slowly)?
Did the 68000 version that someone built of YAM for you not work?
nogginthenog is offline  
Old 15 May 2016, 19:28   #10
Starglider 2
Registered User

Starglider 2's Avatar
 
Join Date: Jan 2014
Location: California
Posts: 759
Sadly not. Feel free to peruse the thread 5 posts up. It just crashes when run.

I'd love either:
- A working 68000 version of YAM 2.x
- Or a hack of YAM 1.3 (already 68000 compatible) that adds the correct port 25 and sets authentication to OFF

Please check the thread 👍

Cheers!
Starglider 2 is offline  
Old 15 May 2016, 20:31   #11
nogginthenog
Amigan

 
Join Date: Feb 2012
Location: London
Posts: 472
Quote:
Originally Posted by Starglider 2 View Post
Sadly not. Feel free to peruse the thread 5 posts up. It just crashes when run.

I'd love either:
- A working 68000 version of YAM 2.x
- Or a hack of YAM 1.3 (already 68000 compatible) that adds the correct port 25 and sets authentication to OFF

Please check the thread 👍

Cheers!
For what it's worth I tried to compile a 68000 version of YAM for you but it failed. Something to do with my includes being wrong. I'll give it another go tomorrow. Will let you know how it goes.
nogginthenog is offline  
Old 15 May 2016, 20:43   #12
Starglider 2
Registered User

Starglider 2's Avatar
 
Join Date: Jan 2014
Location: California
Posts: 759
Quote:
Originally Posted by nogginthenog View Post
For what it's worth I tried to compile a 68000 version of YAM for you but it failed. Something to do with my includes being wrong. I'll give it another go tomorrow. Will let you know how it goes.
Thank you!

Cheers!
Starglider 2 is offline  
Old 16 May 2016, 20:55   #13
nogginthenog
Amigan

 
Join Date: Feb 2012
Location: London
Posts: 472
The good news is that I managed to compile a 68000 version of YAM easy enough. Next YAM requires codesets.library which I also managed to compile a 68000 version.

The next problem is YAM uses some MUI controls that are 68020 only. TheBar.mcc is where I am stuck at. I suspect there are others...

I've not given up yet!
nogginthenog is offline  
Old 16 May 2016, 21:01   #14
Starglider 2
Registered User

Starglider 2's Avatar
 
Join Date: Jan 2014
Location: California
Posts: 759
Quote:
Originally Posted by nogginthenog View Post
The good news is that I managed to compile a 68000 version of YAM easy enough. Next YAM requires codesets.library which I also managed to compile a 68000 version.

The next problem is YAM uses some MUI controls that are 68020 only. TheBar.mcc is where I am stuck at. I suspect there are others...

I've not given up yet!
I'm excited at your progress!
Starglider 2 is offline  
Old 23 May 2016, 07:33   #15
Starglider 2
Registered User

Starglider 2's Avatar
 
Join Date: Jan 2014
Location: California
Posts: 759
Quote:
Originally Posted by nogginthenog View Post
The good news is that I managed to compile a 68000 version of YAM easy enough. Next YAM requires codesets.library which I also managed to compile a 68000 version.

The next problem is YAM uses some MUI controls that are 68020 only. TheBar.mcc is where I am stuck at. I suspect there are others...

I've not given up yet!
Any luck there good sir?

Cheers!
Starglider 2 is offline  
Old 23 May 2016, 11:09   #16
nogginthenog
Amigan

 
Join Date: Feb 2012
Location: London
Posts: 472
Unfortunately not. YAM's dependencies (e.g. thebar.mcc) seems to use a bunch of non-standard functions that are not available in my compiler (GCC).
nogginthenog is offline  
Old 23 May 2016, 13:44   #17
alexh
Thalion Webshrine
alexh's Avatar
 
Join Date: Jan 2004
Location: Oxford
Posts: 11,880
Maybe the authors/maintainers can help? There was a build of this last year.

https://github.com/amiga-mui/thebar/releases

The authors were active 13 days ago

The source code README says :

TheBar.mcc is compiled with GCC. All required third party header files
should already be included in the SVN [GIT] repository. However, please note that
you might need some more third party tools/utilities not included/listed
here.

make OS=os3 CPU = -m68000

Last edited by alexh; 23 May 2016 at 13:57.
alexh is offline  
Old 24 May 2016, 08:26   #18
Starglider 2
Registered User

Starglider 2's Avatar
 
Join Date: Jan 2014
Location: California
Posts: 759
Quote:
Originally Posted by alexh View Post
Maybe the authors/maintainers can help? There was a build of this last year.

https://github.com/amiga-mui/thebar/releases

The authors were active 13 days ago

The source code README says :

TheBar.mcc is compiled with GCC. All required third party header files
should already be included in the SVN [GIT] repository. However, please note that
you might need some more third party tools/utilities not included/listed
here.

make OS=os3 CPU = -m68000
Thanks.

@noggintgenog do you think that will help? We could be the first to get full email send and receive working on the A500 with a modern SMTP server.

Cheers!
Starglider 2 is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
On the Look out for Apps Paradroid90 request.Apps 11 09 September 2008 19:46
3 new apps in the Zone beverins request.Apps 21 03 March 2008 21:58
3D Apps mds request.Apps 2 17 August 2005 12:48
Various Apps Djay request.Apps 1 31 March 2003 13:52
Looking for the following apps Einstein request.Apps 3 26 April 2002 17:07

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:28.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.20610 seconds with 14 queries