English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 07 November 2009, 18:12   #61
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,695
Quote:
Originally Posted by gulliver View Post
Thanks Doobrey & Ratte for your work on icon.library 45.5.
I have 2 questions for you:

Please confirm me if this library features IconBeFast like functionality/capable and if it is romable.

Then which icon.library do people think we should put in Boing Bag 3? 46.4a from PeterK or 45.5 from Doobrey & Ratte?
Many thanks for publishing the icon.library 45.5 from me, too

You can patch it with IconBeFast as explained in my previous post above and as shown on the screenshot below.

Please, don't get confused by the new version number. The internal version of the patched library will be 45.4 again, because the workbench.library 45.131 really wants revision 4 of icon.library in order to support long filenames for icon copying. Nevertheless, the full ID-string is $VER: iconlib 45.5.5 IBF/68000cpu.
Attached Thumbnails
Click image for larger version

Name:	Making45.5.5.png
Views:	305
Size:	17.2 KB
ID:	23203  

Last edited by PeterK; 07 November 2009 at 19:19.
PeterK is offline  
AdSense AdSense  
Old 07 November 2009, 18:12   #62
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,496
Thanks Doobrey & PeterK!
icon.library 45.5 removed from the list so as not to confuse anyone.

Last edited by gulliver; 07 November 2009 at 18:18.
gulliver is offline  
Old 07 November 2009, 18:15   #63
cosmicfrog
The 1 who ribbits
cosmicfrog's Avatar
 
Join Date: Apr 2006
Location: leek, Staffs, UK
Age: 50
Posts: 3,555
Send a message via MSN to cosmicfrog
ow just for me thanks, but would rather have it confirmed not working first,
anyways
great work all round, thanks chaps

edit:
think my problem was/is related to using the us2.aminet.net mirror

Last edited by cosmicfrog; 07 November 2009 at 18:21.
cosmicfrog is offline  
Old 07 November 2009, 20:21   #64
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 754
Quote:
Originally Posted by Doobrey View Post
IMHO,45.5 is pointless unless you use a 68000 and run WB3.1
OK, so it's pointless when I run WB3.9 on 68000

Anywas, I tried various, just for the heck of it:

45.1 - works fine, displays newicons/colouricons, png icons seems to be ignored, fair enough

45.1.6 - works fine as long as no newicons/colouricons show upare present, as that leads to a reboot, a strangely colourfull reboot even

45.5 - works fine, doesnt show newicons/colouricons though, as far as I can see

45.5.5 - same as above, and then something that really pussles me - when I just run "version icon.library" in shell, it says "icon.library 45.4", but only after workbench is load - what's going on?



Anyways, it seems good ol'e 45.1 is best for my minimig
kolla is offline  
Old 07 November 2009, 23:58   #65
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,496
Yesterday I emailed Stefan Robl author of AmiDock. The idea besides thanking him for his work, was to kindly ask him if he could release the early OS4 development version of AmiDock which according to an article i read somewhere, was running in AmigaOS 3.9 and had the dockies/subdockies feature. I remeber the article had a couple of screenshots showing AmiDock in action. I tryed to find them on google, but only found the following image at http://www.amiga-magazin.de/magazin/...aos4/os4_4.jpg which i recall was quoted on the article I read.
Hopefully, with some luck i will get an answer from him. Fingers crossed!
gulliver is offline  
Old 08 November 2009, 00:01   #66
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,695
@kolla

45.1 is 68000 code, but PNG icons were never supported by OS 3.5 or 3.9 without the PowerIcons patch, AfA or Scalos.

45.1.6 has two 68020 instructions in the IconBeFast hunk and thus crashes. I'll make a special version for you with 68000 instructions only if 45.5.5 really won't work for you. OK?

45.5 is 68000 code, but maybe you have to delete and recreate some ENVARC:sys/*.prefs first to get all icons. Check the settings of Sys:Prefs/Workbench for color icons! Ask Ratte for the details, please.

45.5.5 Please read my previous post #61 about the strange version info.

Last edited by PeterK; 08 November 2009 at 00:12.
PeterK is offline  
Old 18 November 2009, 01:10   #67
Ratte
Registered User
 
Join Date: Sep 2008
Location: Germany
Posts: 314
Icon Presettings for 45.5(.5.IBF) are OS3.1 compatible.
If you boot with a 45.1-4 in rom into a OS3.1 WB-Disk, you will see NOTHING!
Because presettings want to display "OS3.9-newicons" and on "old" disks there are non newicons ...
With icon45.5(.5IBF) you will allways see the normal "oldskool" icons, with borders and so on .. just like in old 3.1 times.
But icon45.5(.5IBF) is also 3.9 compatible to newicons, if you boot into your 3.9 wb, your settings (wb.prefs) get activated by iprefs.
Tada ... OS3.9-style.

PeterK: Remember my screenshot with Kick3.9 and WB1.3 ...
Ratte is offline  
Old 19 November 2009, 00:08   #68
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,695
Quote:
Originally Posted by Ratte View Post
PeterK: Remember my screenshot with Kick3.9 and WB1.3 ...
Yes, I know, there once was a nice demo and a screenshot from you, but it has already faded from my memory, because my brain works with lossy compression methods
PeterK is offline  
Old 19 November 2009, 23:01   #69
merlinkv
Amiga user since 1989
merlinkv's Avatar
 
Join Date: Nov 2009
Location: Spain
Age: 54
Posts: 109
Smile Updating scsi.device

Hi to all,

I'm new on EAB.

I don't know the procedure to apply the patch of scsi.device and update to 44.2.

I have AmigaSYS 4 AGA R1.3 updated to OS 3.9 BB2. All work fine with drives of 120GB, but with drives of 160 or more I receive "seek" erros. It's a problem of LBA-48, right?

Mi scsi.device is 43.43

Please, help!

Thanks to all & Best Regards

Last edited by merlinkv; 19 November 2009 at 23:18.
merlinkv is offline  
Old 20 November 2009, 00:41   #70
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 39
Posts: 5,584
Send a message via MSN to FOL Send a message via Skype™ to FOL
Quote:
Originally Posted by merlinkv View Post
Hi to all,

I'm new on EAB.

I don't know the procedure to apply the patch of scsi.device and update to 44.2.

I have AmigaSYS 4 AGA R1.3 updated to OS 3.9 BB2. All work fine with drives of 120GB, but with drives of 160 or more I receive "seek" erros. It's a problem of LBA-48, right?

Mi scsi.device is 43.43

Please, help!

Thanks to all & Best Regards
Download the 4.22 scsi patch, all the info is in the readme.
This patch will solve your drive problem, but its only half the story. Its a good idea to downlaod the fast file system patch to and apply that.
FOL is offline  
Old 20 November 2009, 00:46   #71
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,496
@merlinkv

Hi, welcome to EAB

Yes, you are getting into trouble because you need to patch scsi.device. It is not an easy task for a newbie. I may give you some instructions, but then if you want it the easy way, send me a private mail showing me some proof of purchase of OS3.9 and i will send you that specific patched file.
Anyway, if you still want the longish explanation on how to do it, give me some time and i will post the information in this thread.

I hope it helps
gulliver is offline  
Old 20 November 2009, 02:53   #72
cosmicfrog
The 1 who ribbits
cosmicfrog's Avatar
 
Join Date: Apr 2006
Location: leek, Staffs, UK
Age: 50
Posts: 3,555
Send a message via MSN to cosmicfrog
something like this
http://eab.abime.net/showpost.php?p=524635&postcount=5
cosmicfrog is offline  
Old 20 November 2009, 07:03   #73
merlinkv
Amiga user since 1989
merlinkv's Avatar
 
Join Date: Nov 2009
Location: Spain
Age: 54
Posts: 109
Smile Patching scsi.device

Hi to all.

I'm working now with one IDE 120GB HDD: DH0 as FFS and several partitions of 4 & 15 GB's with SFS 1.279

Concerning purchase, I take one old A1200 with a big pack of programs containing OS, applications, games, etc. on eBay near two years a go. Recently I take a new A1200 ("new old stock") with a lot of extensions and I want to use one IDE 2.5 500GB.

The scsi_44.2.lha from Aminet only have a three files inside with ".pch" extension.

Thanks to all

Last edited by merlinkv; 20 November 2009 at 08:52.
merlinkv is offline  
Old 20 November 2009, 12:05   #74
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 39
Posts: 5,584
Send a message via MSN to FOL Send a message via Skype™ to FOL
Quote:
Originally Posted by merlinkv View Post
Hi to all.

I'm working now with one IDE 120GB HDD: DH0 as FFS and several partitions of 4 & 15 GB's with SFS 1.279

Concerning purchase, I take one old A1200 with a big pack of programs containing OS, applications, games, etc. on eBay near two years a go. Recently I take a new A1200 ("new old stock") with a lot of extensions and I want to use one IDE 2.5 500GB.

The scsi_44.2.lha from Aminet only have a three files inside with ".pch" extension.

Thanks to all
I thought there was a readme with it?
FOL is offline  
Old 21 November 2009, 20:50   #75
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,496
@Doobrey

Any news regarding this post on 10-10-09?

Quote:

Quote:
Originally Posted by yaqube View Post
I also modified the scsi.device (last known version 44.2) back to use word transfers instead of long words as it's faster
End of Quote

DOH!
I noticed the other week when I was patching up IDEFix to use CF cards, that it only patched in the faster(?) longword read/write functions if it found Gayle.
I didn't really think much of it at the time, busy looking for other things at the time!
I'll fix the patch when I get a spare moment or three... (finally found my first A1200 hiding under the stairs covered in dust.. retro time!)
I believe anyone over here would apreciate a slightly faster scsi.device, so pleaaaseeeeeeee...
gulliver is offline  
Old 21 November 2009, 22:21   #76
Doobrey
Hamster tamer
 
Join Date: Apr 2007
Location: Out in the woods
Posts: 122
Quote:
Originally Posted by gulliver View Post
@Doobrey
Any news regarding this post on 10-10-09?
Yup, the a4000 scsi.device patch has had the SpeedyIDE patch removed as per yaqube's suggestion.
http://www.doobreynet.co.uk/files/remus/scsi_44.2.lha

Last edited by Doobrey; 22 November 2009 at 14:53. Reason: Some moron typed in the wrong url
Doobrey is offline  
Old 21 November 2009, 23:03   #77
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,496
Thank you very much!
gulliver is offline  
Old 22 November 2009, 08:07   #78
Cosmos
Banned
 
Join Date: Jan 2007
Location: France
Posts: 655
>the a4000 scsi.device patch has had the SpeedyIDE patch removed

Why ?
Cosmos is offline  
Old 22 November 2009, 15:06   #79
Doobrey
Hamster tamer
 
Join Date: Apr 2007
Location: Out in the woods
Posts: 122
@Cosmos
Yaqube tested it and found it quicker on an A4000 without it.
Probably the same reason why IDEFix doesn't do SpeedyIDE on the A4000 too..

http://eab.abime.net/showpost.php?p=603519&postcount=40
Doobrey is offline  
Old 22 November 2009, 18:18   #80
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,496
Many links are down

I guess nobody liked to have direct links to the files they hosted. Will have to create a website, a torrent, a file or something like that. Just be patient and you will see this in some form.


PS: I am really sorry for those webmasters/site owners who didnt like i linked their files. My sincere appologies!
gulliver is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Boing Bag keitha1200 support.Apps 5 27 June 2012 22:40
Boing Bag 2 password? GreenMeanie support.Apps 37 02 April 2008 05:10
Boing Bag 2 for OS 3.9 ? Tony Landais request.Apps 1 06 January 2006 15:22
Boing Bag #2: here at last Minuous Amiga scene 2 22 March 2002 08:29
Boing Bag 2 Minuous Amiga scene 12 24 October 2001 09:52

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:18.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.23590 seconds with 15 queries