English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 04 August 2016, 23:49   #1
hexaae
Registered User

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 41
Posts: 740
Skidmarks2 issue: flickering hi-res scrolling

Skidmarks2/Superskidmarks/Skidmarks2CD32 archive: https://1drv.ms/u/s!ApMUGr0cuN398mvQJ6iO6ubO_J-G

When set in Hi-Res mode (main menu button: Lo-Res/Hi-Res), while racing, the screen flickers like hell when scrolling horizontally on my G-Sync display 1080p 75Hz...
Attached Files
File Type: uae Hexaae most stable Auto Scaling.uae (32.1 KB, 20 views)

Last edited by hexaae; 05 August 2016 at 00:39.
hexaae is offline  
AdSense AdSense  
Old 05 August 2016, 13:43   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,682
You need to narrow down the problem. Disable everything unneeded or start from basic config and add options until problemappears.

It may be also normal, especially if game uses shres and shres scrolling and selected display mode only shows every other pixel.
Toni Wilen is online now  
Old 05 August 2016, 18:20   #3
hexaae
Registered User

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 41
Posts: 740
10 minutes of tests later...
I would've bet it was WinUAE issue with resolutions and G-Sync but... you're right once again: it was just an Amiga software issue.
I've had to force promote the screen opened by Skidmarks2 to PAL:$21000... problem solved!
On the Amiga side in my devs/monitors I use to keep PAL, NTSC, uaegfx drivers, but for some reason Skidmarks2 didn't like it clean
hexaae is offline  
Old 05 August 2016, 18:40   #4
hexaae
Registered User

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 41
Posts: 740
No, wait... still happens but only if I choose all Computer players (???) without a single human in Hi-Res mode.
Selecting at least 1/8 human player doesn't flicker..
A game bug?

EDIT: tried original IPFs booting from WinUAE Quickstart A1200 mode 4MB RAM and the flickering issue selecting all Computer players and starting an Hi-Res race is still present. I don't have a real Amiga to test it though and definitely confirm a game bug...

Last edited by hexaae; 05 August 2016 at 23:09.
hexaae is offline  
Old 06 August 2016, 10:48   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,682
Attach statefile (when booted from floppies, no harddrives!) and I'll check what it does.
Toni Wilen is online now  
Old 06 August 2016, 16:43   #6
hexaae
Registered User

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 41
Posts: 740
Here is it: https://1drv.ms/u/s!ApMUGr0cuN398nWb31fv-PvKFscJ
hexaae is offline  
Old 06 August 2016, 18:39   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,682
It does look like game issue. Cars are made from sprites and they also move in perfect sync with background graphics when it does that weird jumping. (Sprites and bitplanes works totally differently)

It looks like game can't decide which car is used to center the screen when all cars are computer controlled..
Toni Wilen is online now  
Old 06 August 2016, 20:20   #8
hexaae
Registered User

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 41
Posts: 740
Quote:
Originally Posted by Toni Wilen View Post
It looks like game can't decide which car is used to center the screen when all cars are computer controlled..
Exactly my same feeling...
I'll add a WHDLoad report, maybe someone will fix it one day. Thanks for testing.
hexaae is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Flickering Striations AshtonPete support.Other 4 28 October 2013 17:03
Alien Bash II Savestate Screen-res issue mnc99 support.WinUAE 14 16 December 2011 16:26
Skidmarks2 HD installation (not WHDLoad) Whitestar support.Games 7 02 October 2007 01:40
hires flickering... sometimes Tony Landais support.WinUAE 11 17 July 2006 16:10
Flickering sprites Mr Softy support.WinUAE 2 17 December 2002 12:56

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:02.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.26522 seconds with 15 queries