English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 02 November 2010, 21:39   #1
Photon
Moderator
Photon's Avatar
 
Join Date: Nov 2004
Location: Hult / Sweden
Posts: 4,437
Right Shift+Right Amiga works, but not Left shift+Left Amiga

Left shift + Left Amiga + S works on my real A500 (to search in Asm-One), not with below Quickstart-based hardware config and below host config. The exact same combination of keys works fine in Windows if I make a shortcut for a desktop icon, for example.

I've used the shiny new Remap button (it is excellent Toni ), since I was unsure which keyboard-type to select in the top left dropdown. All the other remapped keys work, including shifts and Amigas - but combining left-shift and left-Amiga doesn't give the same as Right-shift+Right-Amiga. Left-shift + normal letters give capital letters, Left-shift+left-alt+letter-key works.

The only thing that doesn't work is left-shift+left-amiga+letter. (As a further clue, left-win+left-shift+S works in Windows.)

Left-Amiga+Left-Alt triggers left mousebutton as it should, same for right (but right mousebutton, of course). BUT: Amiga+arrowkeys doesn't move the mouse pointer as on a real Amiga. Maybe that's a clue, maybe not.

Changing kick to 2.0 for A500+ didn't change anything. I think I've tested as much as I can, but let me know if I can make some specific tests. This could be a tricky one, I guess. I mainly came here to post kudos about the Remap button anyway, so.
Attached Files
File Type: uae A500-3.1-compat.uae (15.0 KB, 99 views)
File Type: txt winuaebootlog.txt (12.3 KB, 140 views)
Photon is offline  
AdSense AdSense  
Old 16 November 2010, 21:28   #2
Photon
Moderator
Photon's Avatar
 
Join Date: Nov 2004
Location: Hult / Sweden
Posts: 4,437
I can add some more strangeness, I again got the strange thing that the key next to backspace (=+) becomes the key next to leftshift (<>) ... while typing

It happened in WB 3.1 CLI and now it happened while writing a text in AsmOne, 10 lines up, there's a plus I typed, current line, it's impossible to type a + on the keyboard (or = )

I'll try to remember next time to check if ctrl-amiga-amiga fixes it... restart of WinUAE fixes it anyway! I haven't re-bound this key.

I haven't had this in WinUAE before upgrading to V2.3 stable.
Attached Files
File Type: txt winuaebootlog.txt (14.6 KB, 145 views)
File Type: uae A500-3.1-compat.uae (15.5 KB, 101 views)
Photon is offline  
Old 16 November 2010, 21:52   #3
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,663
Does non-working key do anything if you open Input panel and click Test-button? (Always use Test-button to check input issues first)

Key pressed and nothing happens: not WinUAE problem.

Rawinput keyboard access mode is now the default.
Toni Wilen is offline  
Old 17 November 2010, 00:35   #4
Photon
Moderator
Photon's Avatar
 
Join Date: Nov 2004
Location: Hult / Sweden
Posts: 4,437
Last I tried rebinding a (nother) key, RAW KEYBOARD came up automatically.

Selected RAW KEYBOARD, Test, press button, --> EQUALS

Or did you mean to try the next time it happens? (I wrote the previous post right after the problem and as you can see the + and = worked in Windows, if you suspect the keyboard itself).
Photon is offline  
Old 17 November 2010, 08:26   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,663
I meant: if key name appears in Test mode, make sure it is mapped to correct key.
Toni Wilen is offline  
Old 17 November 2010, 20:19   #6
Photon
Moderator
Photon's Avatar
 
Join Date: Nov 2004
Location: Hult / Sweden
Posts: 4,437
After the error occurs?

With a fresh start of WinUAE, in Test mode when the name appears, Equals is mapped to EQUALS.
Photon is offline  
Old 17 November 2010, 20:47   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,663
I meant alt/amiga issues in your earlier posts.

I don't care what Amiga software or keymap decides to do.
Toni Wilen is offline  
Old 17 November 2010, 21:07   #8
Photon
Moderator
Photon's Avatar
 
Join Date: Nov 2004
Location: Hult / Sweden
Posts: 4,437
LCONTROL - Left Amiga
LSHIFT - Left shift

These two keys + S (3 keys combo) works in Windows.
Photon is offline  
Old 17 November 2010, 21:08   #9
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,663
You still haven't said what happens with those keys in Test mode
Toni Wilen is offline  
Old 17 November 2010, 22:43   #10
Photon
Moderator
Photon's Avatar
 
Join Date: Nov 2004
Location: Hult / Sweden
Posts: 4,437
I just ran test mode and reported the bindings in test mode above. Is there some extra test mode besides the Test button next to the Remap button in Input panel?

When I Click TEST BUTTON and press the below keys, this is what is hilighted in the list of keys with a lot of columns in it. The strings typed below separated by ' - ' correspond to the first two columns:

LCONTROL - Left Amiga
LSHIFT - Left shift
Photon is offline  
Old 17 November 2010, 23:17   #11
Photon
Moderator
Photon's Avatar
 
Join Date: Nov 2004
Location: Hult / Sweden
Posts: 4,437
OK, tested some more.

By chance, since LAmiga+cursor didn't move the mouse-cursor, I tried Lalt+cursor which DID...! LAlt+shift+cursor moves it in bigger steps. Just as LAmiga does on A500.

And then a few moments later, it stopped working. I went into F12, Input panel to see if some of them were toggles, but no. When I went back, Alt+cursor keys started working again.

All this time, LAmiga+LAlt has always worked (=Left mousebutton), and same for RAlt+RAmiga (right mousebutton). All this time, Ctrl+Amiga+Amiga has worked to reset WinUAE.

And all this time, Ramiga+S searches but LAmiga+S does not. LAmiga seems 'dead', except when combined with LAlt.

Tested with Test button right after this, the bind is still there (LCONTROL->Left Amiga).

Checked so all remapped keys are in the same config (config #1, same as in file above).


Don't know if it's related, but: if you rebind the Ctrl key, that key + F11 quits WinUAE. Probably not and normal, it's been that way for many versions.

Edit: Funny thing is that LAmiga+M, LAmiga+N always works, but not LAmiga+S. The left-Amiga issue could be in the emulation, then? Maybe, maybe not.

Just now I got a strange thing: for a few seconds, LAlt (not remapped at all - Test button says LMENU->Left Alt) seemed to function as LAlt+LAmiga combo (ie. left mousebutton!) Then, a few seconds later as I tested it some more, it disappeared, and LAlt works as normal (Alt+S gives expected result).


(Edit 2: Now I got the > instead of + (< instead of =) - bug again! (First it works like normal, a few minutes later I get another symbol when I press that key.) I quickly Test'ed the key and pressed =, and got - LSHIFT->Left Shift!

It's the key to the left of backspace. I am out of ideas. Could it have to do with me using US Layout in Windows?)

Last edited by Photon; 18 November 2010 at 00:54.
Photon is offline  
Old 21 November 2010, 22:19   #12
Photon
Moderator
Photon's Avatar
 
Join Date: Nov 2004
Location: Hult / Sweden
Posts: 4,437
OK, tested some more. LAmiga+shift+S is software bug/not implemented. So disregard that. Still no ideas about the LAmiga+M always working but not LAmiga+cursor keys, or the dropped =/+ key.
Photon is offline  
Old 22 November 2010, 09:02   #13
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,526
Quote:
And all this time, Ramiga+S searches but LAmiga+S does not.
This is correct behaviour. Right Amiga key is menu key, left Amiga key is not.
thomas is offline  
Old 22 November 2010, 21:43   #14
Photon
Moderator
Photon's Avatar
 
Join Date: Nov 2004
Location: Hult / Sweden
Posts: 4,437
Yep, duh. I mistakenly associated that with the other weird behaviors.
Photon is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead shift keys... clownstyle support.Hardware 21 13 October 2013 22:30
[Found: Night Shift] Help me to find a retro Amiga game! pandion Looking for a game name ? 4 15 October 2012 11:37
Amiga 1200 video color shift? desiv Hardware pics 6 31 August 2010 17:02
Sound shift mcferson support.WinUAE 26 15 October 2008 13:03
WinXP and right shift key thomas support.WinUAE 13 22 April 2005 04:53

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:01.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.36070 seconds with 13 queries