English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 21 May 2019, 18:31   #1
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,179
Forced CD eject strange issue with external 4K player/recorder

WinUAE 4.2.1.
Windows 10 1809 17763.503, external USB BD-RE Verbatim 43888.

Hi Toni, I switched from Verbatim 43890 (Pioneer BDR-UD03) to 43888 (Pioneer BDR-UD04, 4K UHD support) and found a new issue with physical discs (tested Genetic Species and T0 mixed mode CDs)…

The problem: when I boot to WB with WinUAE and then insert a CD, the disc icons will appear on WB dekstop but suddenly Windows will eject the disc with a requester asking me to insert a valid disk in F:\
Curiously, if I insert the disc BEFORE I run WinUAE and then boot my WB, then I'll have no issue (= no unrecognized CD + forced eject) even if I eject/insert the disc from WB multiple times!
The same happens if I start WinUAE in Image Mode, insert the disc from WB, and then switch to real drive F:\ from WinUAE interface: WB will find the disc, display icons and Windows will just notify me of the new disc inside with no forced eject, as expected!

In short: the problem happens only when I boot WB in Automatic/specified F:\ drive mode, and then insert the CD for the first time from Windows desktop or WB. In this case Windows will reject the disk all the time.
If I don't run WinUAE at all of course I'll have no issue with the same disc from Win desktop, never.

This happens even with old WinUAE 2.5.1 so it has nothing to do with recent SCSI changes...

SCSI Log: https://hastebin.com/weruwuxupa.makefile
My cfg: https://gofile.io/?c=feNHOk

Last edited by hexaae; 22 May 2019 at 10:23.
hexaae is offline  
Old 22 May 2019, 14:47   #2
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,179
Just upgraded to Win 10 Pro 1903 (18362.116), and the bug disappeared.
I hate Windows
hexaae is offline  
Old 22 May 2019, 23:24   #3
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 47
Posts: 3,026
I sometimes have this issue (when inserting CDs/DVDs to rip them in a windows program), and sometimes not. I made the relation with WinUAE after a while. Not systematic. Exiting WinUAE generally solved this.
jotd is offline  
Old 23 May 2019, 13:36   #4
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,179
Quote:
Originally Posted by jotd View Post
I sometimes have this issue (when inserting CDs/DVDs to rip them in a windows program), and sometimes not. I made the relation with WinUAE after a while. Not systematic. Exiting WinUAE generally solved this.
Win 10 1903 solved this cd detection conflict. It is (was with 1809 and before) reproducible carefully following the steps above.
It must be a side-effect of CD routines in WinUAE anyway… maybe Toni could improve/rewrite some parts, even if 1903 seems to have fixed it by itself, so don't know if it's worth it.

Last edited by hexaae; 23 May 2019 at 13:41.
hexaae is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange External Floppy Drive connector MikeyG support.Hardware 5 05 February 2019 15:07
A600 and external 5.25" disk drive: strange issue Supamax support.Hardware 22 30 March 2014 00:20
CD32 games, External DVD recorder, Xenon II. Paul_s MarketPlace 0 16 May 2010 16:53
Strange External floppy jolly11 support.Hardware 18 10 March 2009 18:47
Forced keymap Groundhog project.WHDLoad 2 17 May 2008 17:53

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:29.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.06096 seconds with 15 queries