English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.Other

 
 
Thread Tools
Old 28 August 2017, 14:28   #101
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 56
It's been a while since my last post and I want to let people know what's going on.

I have been quite active and my main focus has been to support Amiga OS 3.9 and with it more tweaks was needed, so here's a list of the features that next release will include:
- Installation of Amiga OS 3.9 from either cd-drive or iso mounted through WinUAE supported by both install and self install modes. For self install mode it will fallback to mount iso through Amiga system using filedisk.device and AmiCDFS. This is to support installation from Amiga OS 3.9 iso from OS39DIR: directory added in emulator, if emulator doesn't have support for cd-drive emulation. In it's current state I don't know how to make it work properly on a real amiga as there's are many different cd-rom drive solutions Amiga and it will be hard to support them all, therefore Amiga OS 3.9 installation is only possible through an emulator.
- Installation of Boing Bags 1-4. HstWB Installer will detect presence of boing bag lha files in OS39DIR: directory added in emulator.
- Automated detection of Workbench 3.1 adf from WORKBENCHDIR: for self install mode. This prevents the manual need for inserting Workbench 3.1 disk in any floppy device and thereby improving speed of installation through an emulator. It will fallback to floppy devices, if WORKBENCHDIR: doesn't contain a valid Workbench 3.1 adf file.
- Added ClassicWB 3.9 package.
- Added Picasso96 package.
- Verified self install works in both WinUAE and FS-UAE.
- Running HstWB Installer in install or self install modes will now build configuration files for both WinUAE and FS-UAE with powershell install script that changes paths for harddrives and kickstart rom files to be system specific making self install images easy to install and use. It also adds adf files as swappable floppies in FS-UAE from detected workbench directory containing adf files for Workbench 3.1. A python version of install scripts will be created as well to support Mac/Linux environments running self install images.

I will soon release new BETA versions of self install images with Amiga OS 3.9 support for anyone to test. Then I need to update the documentation, but the self install images has good guides build-in just by running the self install images.

I also want better support for Vampire accelerator cards and plan to make a Vampire-Support-Package, that automatically installs Saga drivers and relevant programs (RiVA etc.) to use Vampire card to its fullest.
cyberhead97 is offline  
AdSense AdSense  
Old 28 August 2017, 17:34   #102
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 1,942
I would avoid leaving WB3.1, better WB3.0 to avoid small incompatibilities, Well too install 3.9 directly from CD-Rom.
AMIGASYSTEM is offline  
Old 28 August 2017, 21:50   #103
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 56
Is it better/recommended to install Amiga OS 3.9 on top of Workbench 3.1?

I have no experience with Amiga OS 3.9 and a complete newbie in that area, so just asking to make HstWB Installer build a better Amiga OS 3.9 installation. I can easily make an option that allows installation of both, first Workbench 3.1 then Amiga OS 3.9 if available.
cyberhead97 is offline  
Old 28 August 2017, 23:38   #104
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 1,942
WB3.1+OS3.5+OS3.9 or WB3.0+OS3.5+OS3.9 (In my opinion the best choice)
AMIGASYSTEM is offline  
Old 29 August 2017, 01:50   #105
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,582
Send a message via Skype™ to Retrofan
Quote:
Originally Posted by AMIGASYSTEM View Post
WB3.1+OS3.5+OS3.9 or WB3.0+OS3.5+OS3.9 (In my opinion the best choice)
Why do you need OS3.5 in the middle of the installation?

And why do you prefer to install it over OS3.0 instead of OS3.1?
Retrofan is offline  
Old 29 August 2017, 08:42   #106
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 56
All right, it will make the support to install Amiga OS 3.9 over Workbench 3.1.

Actually, the Amiga OS 3.9 install script I have created does the same as running the installer from Amiga OS 3.9 cd selecting full installation over wb3.0/3.1 or empty hd. This installation process first copies AmigaOS3.5 files and then AmigaOS3.9 files from cd-rom to hard disk and I have replicated the same process by examining the installer.

I guess you would only install OS3.9 over WB3.0, if that's the only Workbench one would have at hand. I would personally go for WB3.1+(OS3.5 indirectly installed)+OS3.9.

Last edited by cyberhead97; 29 August 2017 at 08:46. Reason: Added response to Retrofan
cyberhead97 is offline  
Old 29 August 2017, 09:21   #107
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 1,942
Quote:
Originally Posted by Retrofan View Post
Why do you need OS3.5 in the middle of the installation?
If you install 3.1+3.9 you can find icons without color, see scrennshot

OS3.5 upgrade 3.0/3.1
OS3.9 Is upgrade 3.5

Quote:
And why do you prefer to install it over OS3.0 instead of OS3.1?
I feel a cleaner update.


Screenshot Install 3.1+3.9 / Install 3.1+3.5+3.9
Attached Thumbnails
Click image for larger version

Name:	Install-3.1+39.jpg
Views:	31
Size:	92.9 KB
ID:	54364   Click image for larger version

Name:	Install-3.1+3.5+3.9.jpg
Views:	27
Size:	95.4 KB
ID:	54365  

Last edited by AMIGASYSTEM; 29 August 2017 at 09:34.
AMIGASYSTEM is offline  
Old 29 August 2017, 15:07   #108
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 56
Hmm interesting, there seems to be a visual difference with the colors of icons. I just tried 3.1+3.9 using my installer and I get same result as your first screenshot.

Then I noticed you have AmigaOS3.9 drawer open in your screenshots where icons has the better colors. Examining icons on the Amiga OS 3.9 cd in drawer "AmigaOS3.9:OS-VERSION3.9/Workbench3.5" looks the same as your second screenshot, which indicates that the Amiga OS 3.9 cd has and does install these icons with high colors. But during the installation of Amiga OS 3.9 something must touches/patches them resulting in low colors.

Looking at the installer script the only part that does anything with icons, is a tool called "IconPos" located at "AmigaOS3.9:OS-VERSION3.9/INSTALL-TOOLS/ICONPOS" and modifying this gave following result with attached screenshots:
  1. Screenshot 1: Install 3.1+3.9, IconPos used all icons. All icons have low colors.
  2. Screenshot 2: Install 3.1+3.9, IconPos partly used for 3 icons. Icons Prefs, Prefs->Fonts and Prefs->Locale touched by IconPos and has low colors, but rest have high colors.
  3. Screenshot 3: Install 3.1+3.9, IconPos removed. All icons have high colors.

I'm not sure what IconPos does, but from it's name it sounds like a tool reposition icons within a drawer.

Removing use of IconPos seems to achieve same result as installing 3.1+3.5+3.9, which makes me believe that installation of OS3.5 is irrelevant and that IconPos is incorrectly used even by Amiga OS 3.9 own installer.
Attached Thumbnails
Click image for larger version

Name:	1_os3.1+os3.9_iconpos_all.png
Views:	16
Size:	54.5 KB
ID:	54371   Click image for larger version

Name:	2_os3.1+os3.9_iconpos_partly.png
Views:	18
Size:	42.9 KB
ID:	54372   Click image for larger version

Name:	3_os3.1+os3.9_iconpos_none.png
Views:	20
Size:	73.4 KB
ID:	54373  
cyberhead97 is offline  
Old 29 August 2017, 15:20   #109
fgh
Registered User
 
Join Date: Dec 2010
Location: Norway
Posts: 576
Great work, keep it up!
I'd make sure the unofficial boing bags 3-4 are optional, as many people prefer to stop at BB2.
But making the whole install as easy to use as possible is even more important, so I'd even consider defaulting to BB2 and just include BB3-4 install instead.
fgh is offline  
Old 29 August 2017, 15:28   #110
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 56
Quote:
Originally Posted by fgh View Post
Great work, keep it up!
I'd make sure the unofficial boing bags 3-4 are optional, as many people prefer to stop at BB2.
But making the whole install as easy to use as possible is even more important, so I'd even consider defaulting to BB2 and just include BB3-4 install instead.
Thanks, I'm getting deeper and deeper into the Workbench dungeon .

Boing bags are optional. They are detected from mounted OS39DIR directory and HstWB Installer will only install the ones that are present:
  • Empty OS39DIR = no boing bags are installed.
  • BoingBag39-1.lha in OS39DIR = install boing bags 1.
  • BoingBag39-1.lha + BoingBag39-2.lha in OS39DIR = install boing bags 1 and boing bags 2.
  • BoingBag39-2.lha in OS39DIR = no boing bags are installed as boing bags 1 doesn't exist and boing bags must be installed in the correct order 1, 2, 3, 4.
cyberhead97 is offline  
Old 30 August 2017, 23:17   #111
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 1,942
If it may be interesting, there is also the way to install it OS3.9 Directly from the CD Os3.9 without using it WB3.0/3.1 and OS3.5, HERE find a nice tutorial by Thomas.
AMIGASYSTEM is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Legal Issues if Sharing RP9 Snapshots? tygre Retrogaming General Discussion 17 18 September 2014 20:04
ImageStudio preinstalled retrogamer request.Apps 5 31 March 2011 05:59
Making cf_ClassicWB_FULL.hdf bigger? emuola project.ClassicWB 3 06 June 2009 00:23
New ruling making retro-archives legal? Bloodwych Retrogaming General Discussion 3 24 November 2006 19:30

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 09:37.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.17355 seconds with 14 queries