English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 24 July 2014, 21:47   #1
Kristian95
A4000T owner :)
Kristian95's Avatar
 
Join Date: Jan 2006
Location: California, USA
Age: 43
Posts: 498
Need help resuscitate a Phoenix

Hi guys,

I have a nice Phoenix board (with a 030 accelerator card and flicker fixer) which I finally got to try to get set-up. Unfortunately the unit does not boot. The power LED is on but there is no disk drive activity nor any output on the monitor.

I am not feeling savvy enough to fix it myself and was hoping someone on these boards residing in the US can help me out. I have no clue as to what the repair would entail but will of course pay nicely to get the unit working.

Cheers,

Kristian95
Kristian95 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Phoenix Fighters rare_j request.Old Rare Games 21 09 April 2015 19:26
Phoenix Fighters manic23 Games images which need to be WHDified 1 10 March 2014 11:03
Greetings from Phoenix Arizona Smakar Member Introductions 4 25 August 2012 20:13
phoenix galaga like turrican3 Looking for a game name ? 6 06 January 2009 22:08
Phoenix Fighters Heavy Stylus request.Old Rare Games 11 12 September 2008 18:59

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:52.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.05598 seconds with 13 queries