English Amiga Board


Go Back   English Amiga Board > Coders > Coders. General > Coders. Releases

 
 
Thread Tools
Old 23 December 2018, 03:25   #41
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,986
Quote:
Originally Posted by amigoun View Post
I have tried LOL with the WOS port and keyboard movement works here, good.
I also experienced false graphics colors like AMike in Fullscreen or windowed mode on cybervisionppc and cybergraphics4 at my friends A4000. Only with 15bit or 24bit screemode and windowed mode colors are correct.

Is the 15bit mode looking generally correct and running at a reasonable speed?
grelbfarlk is offline  
Old 23 December 2018, 04:30   #42
amigoun
Registered User
amigoun's Avatar
 
Join Date: May 2010
Location: Czech Rep
Posts: 555
Colors were correct in 15bit, it was bit slow (at least for 2x mode) not unbearable (like 24bit) but still little bit slower than I would like it to be
amigoun is offline  
Old 23 December 2018, 05:34   #43
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,986
Quote:
Originally Posted by amigoun View Post
Colors were correct in 15bit, it was bit slow (at least for 2x mode) not unbearable (like 24bit) but still little bit slower than I would like it to be

I could probably do a 15-bit version until the SDL updates happen, maybe that would work for other CGX cards.

What was the PPC speed, less than 200MHz I hope?
Don't know there's all that much I can do to speed it up, next experiment is using P96/CGX instead of SDL for Video, I'll spend some tinkering with that this week, after I give up or put aside my other project that's almost built.
grelbfarlk is offline  
Old 23 December 2018, 11:37   #44
AMike
Registered User
AMike's Avatar
 
Join Date: Jan 2007
Location: near Vienna/Austria
Posts: 187
I've tested it again with 15bit 1280x1024 - the colours were only correct in the window mode - fullscreen same gfx errors as in the past. Speed is good for the old games like Indy IV - Monkey Island III is buggy and slow. Only a bit faster than the 68k Version from nova. (CyberstormPPC 366Mhz)
AMike is offline  
Old 23 December 2018, 15:05   #45
amigoun
Registered User
amigoun's Avatar
 
Join Date: May 2010
Location: Czech Rep
Posts: 555
I tested on 604/233. I think it would run fast enough if could be fixed for 15bit fullscreen and 320x240 lores 1x mode.
And when SDL 8bit is fixed or native P96/CGX it will be even better.
amigoun is offline  
Old 24 December 2018, 02:42   #46
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,986
If someone has some time to waste with a CVPPC, try the versions I just put up in the zone, scummBEbig and small.
grelbfarlk is offline  
Old 24 December 2018, 03:45   #47
amigoun
Registered User
amigoun's Avatar
 
Join Date: May 2010
Location: Czech Rep
Posts: 555
I confirm versionBEsmall now working with correct colors in fullscreen. Also games LOL and Monkey1 I tested run fast, perfectly playable. But I experience sudden freezes of the ScummVM. Not long after the program starts. Can also freeze in menu/gui too.
r15big works with correct colors only in window mode. Crashes too for me. I think the crashes were there with the previous builds too. Maybe its the machine related? Will wait for AMike tests.

Last edited by amigoun; 24 December 2018 at 04:00.
amigoun is offline  
Old 24 December 2018, 04:53   #48
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,986
Quote:
Originally Posted by amigoun View Post
I confirm versionBEsmall now working with correct colors in fullscreen. Also games LOL and Monkey1 I tested run fast, perfectly playable. But I experience sudden freezes of the ScummVM. Not long after the program starts. Can also freeze in menu/gui too.
r15big works with correct colors only in window mode. Crashes too for me. I think the crashes were there with the previous builds too. Maybe its the machine related? Will wait for AMike tests.

The big version might need a larger stack-guessing. I also dicked around with the mixer buffer size between the two, the larger one actually has the smaller buffer.

And is that with correct colors in what depth, 15bit?

I was actually hoping this wouldn't work so I could throw my hands up. I guess I could put in checks for the two platforms.

Adding P96 native support is a bigger task than I thought, so that might be a while.

Last edited by grelbfarlk; 24 December 2018 at 04:58.
grelbfarlk is offline  
Old 24 December 2018, 17:10   #49
AMike
Registered User
AMike's Avatar
 
Join Date: Jan 2007
Location: near Vienna/Austria
Posts: 187
Quote:
Originally Posted by grelbfarlk View Post
If someone has some time to waste with a CVPPC, try the versions I just put up in the zone, scummBEbig and small.
ScummSmall works great here. I've tested several Lucasarts games and Lands of Lore. It was only a short 30 minute test, but no freezes and gfx errors so far. Every game was fast and playable - only Monkey 3 was a little bit slow, but ok. I've tested it in fullscreen. (15,16 & 24bit) Thanks for the fix and merry christmas to you.
AMike is offline  
Old 24 December 2018, 17:38   #50
amigoun
Registered User
amigoun's Avatar
 
Join Date: May 2010
Location: Czech Rep
Posts: 555
Thanks for the test. So the crashes here seem to be related to the particular hardware I was testing on.
Thanks grelbfarlk for your efforts and merry christmas.
amigoun is offline  
Old 25 December 2018, 03:14   #51
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,986
Great, happy holidays everyone. I'll put out another one with the rest of the engines.
grelbfarlk is offline  
Old 25 December 2018, 17:09   #52
TheMrKocour
Registered User
TheMrKocour's Avatar
 
Join Date: Apr 2018
Location: Prague, Czech Republic
Posts: 15
DosBox Sonnet

Hi!
I tried DosBox on my Sonnet 7200.
I downloaded Dosbox074_wos-A1 [Dosbox 0.74 for WarpOS Alpha 1.].lha and it didn't worked for me. Cant open tool message. Then i got Dosbox_wos_GL22.lha and that worked. Here is some video of it.

[ Show youtube player ]
TheMrKocour is offline  
Old 26 December 2018, 05:02   #53
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,986
I'm glad you got some use out of it.
Did you try with less cycles? Depending on how fast your CPU is, less CPU cycles leaves more time for the graphics and sound, the most basic VGA 256 color games can run as low as 1500 cycles, just a balancing act to find the best setting for what you want to run.

In the dosbox.conf file under the mixer settings you can play with:
rate=22050
blocksize=4096
prebuffer=100

Lower blocksize and prebuffer settings might reduce lag at the risk of more stuttering, and rate at 11025 might sound slightly worse but have better performance.

Also what Sonnet settings are you using?
DisSigBounce and less often EnStackPatch can make a big difference in performance.

Someone start a gofundme or some other bounty so we can hire someone (not me) to finally make a PowerPC (or 68k?) JIT/Dynrec CPU core.

Last edited by grelbfarlk; 26 December 2018 at 05:20.
grelbfarlk is offline  
Old 06 January 2019, 21:34   #54
amigoun
Registered User
amigoun's Avatar
 
Join Date: May 2010
Location: Czech Rep
Posts: 555
Quote:
Originally Posted by grelbfarlk View Post
It could be an input problem of some kind I notice if I leave it idle for 30 seconds then move the mouse it freezes then too. Seems like it might be related to mouse-overing things but I'm really not sure. Then again, maybe it's video, or anything else I forgot, em, timer?

Greg, did you find a solution to this problem? I still have this problem with sudden freezing, especialy when mooving mouse.. With all the recent ScummVM ports even the Hedeons v2 port. Setups I tested on were CSPPC/CVPPC and BPPC/BVision same problem.
amigoun is offline  
Old 06 January 2019, 21:42   #55
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,986
Quote:
Originally Posted by amigoun View Post
Greg, did you find a solution to this problem? I still have this problem with sudden freezing, especialy when mooving mouse.. With all the recent ScummVM ports even the Hedeons v2 port. Setups I tested on were CSPPC/CVPPC and BPPC/BVision same problem.

The suggestion was that it was not happening when using compressed audio, with a guess that it was the load on the (hdd controller, AHI, something else?) loading the original tracks. On my GemRB port, it was something different, at least it seems to be, guess that it was a Sonnet setting DisSigBounce that greatly speeds up the PPC at the expense of compatibility. Can't say for sure though.
grelbfarlk is offline  
Old 06 January 2019, 22:05   #56
amigoun
Registered User
amigoun's Avatar
 
Join Date: May 2010
Location: Czech Rep
Posts: 555
By me it can freeze even in startup gui. Weird.
amigoun is offline  
Old 06 January 2019, 23:24   #57
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,986
Quote:
Originally Posted by amigoun View Post
By me it can freeze even in startup gui. Weird.

Yeah I've seen that too, does it go away if you remove the themes, so it uses the built-in basic Green/Black one? To throw out random ideas, maybe it's a problem in our .png library or it is just input.

Ah the themes aren't in png anyway. Just BMP for some of the buttons and cursor, leaves like maybe Truetype, possibly.
grelbfarlk is offline  
Old 27 January 2019, 01:09   #58
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,986
Quote:
Originally Posted by amigoun View Post
By me it can freeze even in startup gui. Weird.

It seems to be connected to the themes as far as I can tell. After converting the COMI audio it runs so great, screen transitions are very fast, no random pausing, but bringing up the load/save in-game menu sometimes will trigger it, only if I have the modern theme activated.
grelbfarlk is offline  
Old 28 February 2019, 16:58   #59
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,373
Can the AMiGA version of ScummVM be executed in Windows Mode?
The PC version does this with the keys Alt+Enter key combination in-game !
AMIGASYSTEM is offline  
Old 28 February 2019, 19:15   #60
jurassicman
Registered User

jurassicman's Avatar
 
Join Date: Dec 2017
Location: Bologna/Italy
Posts: 269
Quote:
Originally Posted by AMIGASYSTEM View Post
Can the AMiGA version of ScummVM be executed in Windows Mode?
The PC version does this with the keys Alt+Enter key combination in-game !

In the file scummvm.ini a line says:

(...)
fullscreen=true
(...)

If you set it as "false" scummvm starts in windowed mode.
jurassicman is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
GemRB for Classic Amiga WarpOS grelbfarlk Coders. Releases 13 22 September 2019 03:11
DGen for Classic Amiga WarpOS grelbfarlk Coders. Releases 14 11 July 2019 02:53
PrBoom (Doom Engine) for Classic Amiga WarpOS grelbfarlk Coders. Releases 14 06 June 2019 04:21
ScummVM WarpOS PPC drluking support.Apps 6 30 September 2018 00:29
Dosbox for WarpOS or WOS grelbfarlk request.Apps 0 06 May 2017 00:26

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:06.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.09641 seconds with 16 queries