English Amiga Board


Go Back   English Amiga Board > Support > support.FS-UAE

 
 
Thread Tools
Old 20 December 2020, 10:53   #1
-K-
Registered User

 
Join Date: Jul 2019
Location: London
Posts: 2
"No Shader Passes Loaded" error message

Hi all,

The talk around shaders below spurred me on to see if I could get any more advanced shaders working on FS-UAE. I have put a few in the data / shaders folder, but every time I try to enable it in the advanced settings menu, I just get an error message saying "[SHADERS] NO SHADER PASSES LOADED". FS-UAE seems to work fine after this, but obviously without any shaders visible.

What am I doing wrong? I'm running FS-UAE 3.02 on OSX; the shaders I'm trying to run are crt-hyllian and crt-trinitron; they're in documents / FS-UAE / Data / Shaders; I'm enabling it by putting "shaders = [name of shader]" in advanced settings.

Any help would be gratefully received. Many thanks!
-K- is offline  
Old 20 December 2020, 22:42   #2
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 40
Posts: 3,794
Hi, you can probably find some more information about the error in FS-UAE.log.txt (In FS-UAE/Cache/Logs).

That being said, you're probably not doing anything wrong. The shaders are probably simply not compatible to your system. That could for example be caused by shaders being written in a manner that is not portable enough between different OpenGL vendors, or that they require features that are not present on your machine. Apple has deprecated OpenGL already, and haven't updated OpenGL to support more modern features in years. So my guess is that the problem is Apple's sucky OpenGL implementation (and it might be possible to work around that in shader code, or not).
FrodeSolheim is offline  
Old 21 December 2020, 19:12   #3
-K-
Registered User

 
Join Date: Jul 2019
Location: London
Posts: 2
Thanks for the reply - sounds like it's just not supported, so will leave it there.
-K- is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
"SERIOUS ERROR" message from PFS3 Overmann support.Other 3 05 December 2018 19:50
Shaders - no shader passes loaded Cowilf support.FS-UAE 0 19 July 2018 11:05
"Error validating disk" message.. what's wrong? scifi Hardware mods 4 19 November 2011 21:28
"block zero write failed!" Error message MoreGrog support.WinUAE 5 21 July 2010 21:30
"Unpack.library failure" error message Another World New to Emulation or Amiga scene 1 16 December 2008 14:01

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:14.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.06743 seconds with 15 queries