English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 25 June 2018, 08:47   #481
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,886
Quote:
Originally Posted by fl@sh View Post
Is there any setting I can check to speedup ppc emulation? Does all old chipset related stuff go to definitively sleep when the ppc starts?
I'm waiting for qemu compatibility but meantime I'm using winuae for OS4.
I hope, one day maybe, Toni will be major focused on this 'new' branch of Amiga emulation.
Chipset is not inactive when running OS4 for classics. CIAs are active, Paula is active (all interrupt handling) and so on. PPC boards for classics are only a huge klugdes..

PPC CPU still runs as fast as possible (separate thread for PP CPU) except when it needs to access mainboard IO, which is very slow (mainly keyboard, mouse, interrupt status). It is as optimal as it can be without requiring any major chipset side changes. Which won't ever happen.

Note that any UAE device is slow. Fixing it, especially uaegfx would mean moving the native code "driver" completely to Amiga side to remove context switch slowdowns. Which would be really, really annoying task and would need maintaining..

And even more important: it would be totally pointless task because obviously correct way is to write native OS4 driver but driver API is private!
Toni Wilen is online now  
Old 25 June 2018, 09:53   #482
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 332
@Hi Toni,
thanks for version 4 of winUAE.

@Fl@sh
Hi, you could attach your winUAE 64bit configuration, I'd like to see it.
Thank you.

Last edited by White; 25 June 2018 at 09:54. Reason: error
White is offline  
Old 28 June 2018, 06:58   #483
fl@sh
Registered User

 
Join Date: Mar 2018
Location: italy
Posts: 12
@toni

so what do you suggest to maximize emulation speed for ppc os4? Are there some settings to flag/unflag or others undocumented features to try?

@white
at this time I'm replyng from anoter pc (notebook) so I haven't winuae cfg file.
fl@sh is offline  
Old 01 August 2018, 18:53   #484
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 332
Hi Toni,
Excuse me if I ask you, I was trying qemu with linux
But I do not understand the situation.
With your experience I hope to receive a suggestion, after I will not ask you more questions on this topic.
I read here
http://zero.eik.bme.hu/~balaton/qemu/amiga/

that at the moment the requested iso and that of the final edition 4.1 sam460ex 53.58
so the classic version of amigaos4.1 53.71 does not work?
Is the executable to be used qemu-ppc?
I have an I5 2400 64bit processor

Thanks for any response and sorry I still rely on your experience.
White is offline  
Old 01 August 2018, 19:32   #485
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,886
Quote:
Originally Posted by fl@sh View Post
so what do you suggest to maximize emulation speed for ppc os4? Are there some settings to flag/unflag or others undocumented features to try?
Don't use UAE expansions. They are slower than hardware emulated boards. Faster PC also works

Quote:
Originally Posted by White View Post
that at the moment the requested iso and that of the final edition 4.1 sam460ex 53.58
so the classic version of amigaos4.1 53.71 does not work?
Yes, classic version only supports classic hardware (CSPPC/BlizzardPPC).
Toni Wilen is online now  
Old 01 August 2018, 19:40   #486
White
Registered User
 
Join Date: Sep 2016
Location: italy
Posts: 332
Toni, thank you very much for your reply.
White is offline  
Old 13 August 2018, 15:09   #487
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 3,537
@bernd roesch

Ciao bernd, what do you think of this: http://eab.abime.net/showthread.php?t=64079&page=126
AMIGASYSTEM is online now  
Old 14 October 2018, 13:54   #488
_ThEcRoW
Amiga Geek
_ThEcRoW's Avatar
 
Join Date: Apr 2005
Location: Spain
Age: 39
Posts: 907
Hello all, long time since my last post. I saw recently that winuae is on v4 and gave it a try. I'm trying to run a classic environment for 3.1 + blizzardppc (no os4), and the emulator gives therror of the plugin not found. I have it on the folder plugins as the docs says. Still it says that plugin isn't found.
Anyone has a clue?
_ThEcRoW is offline  
Old 14 October 2018, 19:57   #489
_ThEcRoW
Amiga Geek
_ThEcRoW's Avatar
 
Join Date: Apr 2005
Location: Spain
Age: 39
Posts: 907
Problem solved. Was using the wrong dll.
_ThEcRoW is offline  
Old Yesterday, 15:55   #490
_ThEcRoW
Amiga Geek
_ThEcRoW's Avatar
 
Join Date: Apr 2005
Location: Spain
Age: 39
Posts: 907
Well, i finally got it running and have a installation of 3.1 classic tih the ppc support but the problem i noticed is that i can't give it more than 128mb of ram, be it with the z3 slider or with the accelerator memory, anything passing 128 mb gets stuck in black screen and system halt. It's been a lont time since i played with winuae and its ppc part. Anyone knows what could be the cause?.
Thanks in advance!!!!!!!!!

Last edited by _ThEcRoW; Yesterday at 15:56. Reason: typo
_ThEcRoW is offline  
 


Currently Active Users Viewing This Thread: 2 (1 members and 1 guests)
stompas
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
QEMU TCG as JIT replacement? KillaByte request.UAE Wishlist 21 30 January 2018 16:05
PPC emulation for winuae marauder request.UAE Wishlist 25 04 November 2014 06:13
WinUAE PPC thread B14ck W01f support.WinUAE 301 10 September 2014 16:34
WinUAE ppc support? blasterreal support.WinUAE 8 29 September 2010 00:51
PPC on WinUAE ? glue request.UAE Wishlist 4 28 January 2007 12:04

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:48.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.07944 seconds with 16 queries