English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 15 May 2017, 17:36   #1
Jilly_C
Registered User
 
Join Date: May 2017
Location: Ivybridge/England
Posts: 3
Zappo CD Drive

Hello everyone. We have just unearthed our old Amiga 1200 and some of the bits and bobs that go with it all. We have a Zappo CD drive and all the software is still installed on the 1200's internal hard drive. We attached the CD drive to the 1200 and plugged the power supply into the mains but nothing is happening. It has been so long since we last used it and I can't remember if it should show up on the workbench automatically or not. I see that if I turn the machine on with the left mouse button down there is an option to CD boot but again, nothing is happening. I wonder if the hard drive is just no good after being in the cupboard since the late 90's! There is just a slight flicker of green from the CD drive but that's all. I can't find the manual (if there was one with it). We have lots of CD32 games (can't find the lead to connect that machine to an appropriate TV/monitor) and would like to see if they still work as I believe they can be played using the Zappo drive. If anyone could share any ideas please it would be much appreciated.
Jilly_C is offline  
AdSense AdSense  
Old 15 May 2017, 21:21   #2
Daedalus
Registered User

Daedalus's Avatar
 
Join Date: Jun 2009
Location: Dublin, then Glasgow
Posts: 2,666
Welcome along!

Normally CD drives show up automatically, but only when there's a CD inserted - unlike PCs, an empty drive is invisible on the Amiga. It could be the case however that the CD driver is not being loaded on boot. Check your boot partition's Devs/DOSDrivers drawer and make sure there's an icon in there for the CD drive. If you double-click it, it should give you a "Device CD0: is already mounted" or similar error if it's already been activated.
Daedalus is offline  
Old 16 May 2017, 11:54   #3
Jilly_C
Registered User
 
Join Date: May 2017
Location: Ivybridge/England
Posts: 3
Quote:
Originally Posted by Daedalus View Post
Welcome along!

Normally CD drives show up automatically, but only when there's a CD inserted - unlike PCs, an empty drive is invisible on the Amiga. It could be the case however that the CD driver is not being loaded on boot. Check your boot partition's Devs/DOSDrivers drawer and make sure there's an icon in there for the CD drive. If you double-click it, it should give you a "Device CD0: is already mounted" or similar error if it's already been activated.
Hi Daedalus. Thank you so much for your help. I have checked the Devs/DOSDrivers drawer and clicked the icon for the CD drive as you suggested and it throws up the error that you mentioned. When we push the open/close button on the drive nothing happens. I have tried clicking the 'Drive Door' icon, which places a small bar at the top of the workbench but that is all. As before the drive light flashes green for a split second on booting the 1200. The power supply to the CD drive has a red light. Perhaps the CD drive is just gone to the great hardware resting place in the sky?
Jilly_C is offline  
Old 16 May 2017, 12:21   #4
Daedalus
Registered User

Daedalus's Avatar
 
Join Date: Jun 2009
Location: Dublin, then Glasgow
Posts: 2,666
Hmmm, it's possible I guess... The doors don't usually open if the device is trying to read, so perhaps there's an issue along those lines. You can normally open drives with a paperclip in a small "emergency release" hole on the front of the drive. It's worth opening it while it's powered off and then powering it on to see if it resets the door or laser mechanisms.
Daedalus is offline  
Old 17 May 2017, 22:18   #5
Jilly_C
Registered User
 
Join Date: May 2017
Location: Ivybridge/England
Posts: 3
Quote:
Originally Posted by Daedalus View Post
Hmmm, it's possible I guess... The doors don't usually open if the device is trying to read, so perhaps there's an issue along those lines. You can normally open drives with a paperclip in a small "emergency release" hole on the front of the drive. It's worth opening it while it's powered off and then powering it on to see if it resets the door or laser mechanisms.
Hello again, sorry for the late response. Thanks again for your input. We don't seem to be able to open the CD drive even with a paperclip. Not looking good I think we will have to put it down as no longer functioning. Thank you very much for your help though
Jilly_C is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
zappo smartstor plus cf card vertigo support.Hardware 2 29 April 2015 11:58
Zappo CDROM for SALE!! r6stu MarketPlace 0 02 September 2008 20:28
CD file systems and Zappo CD r6stu support.Hardware 1 08 November 2007 08:35
Archos PCMCIA CDRW drive (not zappo) on 1200 _ThEcRoW support.Hardware 11 28 March 2006 22:51
Overdrive/Zappo CD-ROM Drive Parsec support.Hardware 7 01 September 2003 10:35

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:34.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Page generated in 0.13193 seconds with 14 queries