English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 27 December 2019, 07:09   #1
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 670
Question Yet Another Help with SMBFS?

Hi all!

I had to reinstall from scratch my Raspberry PI, including its Samba server, and I'm running into a problem that I cannot explain/solve. I have installed Samba and configured it. It runs on my Raspberry PI called CHAMSAE. I can access all the shares as expected from a Windows 10 laptop. BUT, I cannot access the shares from my Amiga. (I could connect to a Samba server from my Amiga before reinstalling my Raspberry PI, so the problem is certainly (?) with my config. Also, I can ping CHAMSAE from my Amiga.)

Here is my smb.conf file (from testparm):

Code:
[global]
        log file = /var/log/samba/log.%m
        logging = file
        max log size = 1000
        workgroup = GIB
        idmap config * : backend = tdb


[Public]
        create mask = 0777
        directory mask = 0777
        path = /media/Backup/Public
        read only = No


[Software]
        create mask = 0777
        directory mask = 0777
        path = /media/Backup/Software
        read only = No


[Work]
        create mask = 0777
        directory mask = 0777
        path = /media/Backup/Work
        read only = No


[Music]
        create mask = 0777
        directory mask = 0777
        path = /media/WWW/Music
        read only = No
I use this command line:

Code:
smbfs DOMAIN=GIB USER=*** PASSWORD=*** SERVICE=//CHAMSAE/Music
When using smbfs-1.74, the error is:

Code:
smbfs: ERRDOS - ERRnoaccess (Access denied).
smbfs: Cannot connect to server (13, Permission denied).
smbfs: Could not connect to server (13, Permission denied).
When using smbfs-2.1, the error is:

Code:
smbfs: ERRDOS - ERRnoaccess (Access denied).
smbfs: Could not connect to server 'CHAMSAE' (1/5, ERRDOS/Access denied).
Anyone could explain me what I'm doing wrong?

And happy holidays!
tygre is offline  
Old 27 December 2019, 10:27   #2
jurassicman
Registered User

jurassicman's Avatar
 
Join Date: Dec 2017
Location: Bologna/Italy
Posts: 269
This is my smb.conf on Debian 9:

Code:
[global]

	workgroup = ROUTER
	server string = Samba Server Version %v
	server min protocol = NT1
	ntlm auth = yes 
	raw NTLMv2 auth = yes

# --------------------------- Logging Options -----------------------------

	# log files split per-machine:
	log file = /var/log/samba/log.%m
	# maximum size of 50KB per log file, then rotate:
	max log size = 50

# ----------------------- Standalone Server Options ------------------------

	security = user
	passdb backend = tdbsam

# --------------------------- Printing Options -----------------------------

	load printers = no
	cups options = bsd

[Storage] 
comment = Storage Partition for Amiga 
path = /media/Storage/
valid users = amiga,user1 
public = no 
browseable = yes
guest ok = no
writable = yes 
printable = no
create mask = 0777

[Backup] 
comment = Backup Partition for Amiga 
path = /media/Backup/
valid users = amiga,user1
public = no 
browseable = yes
guest ok = no
writable = yes 
printable = no
create mask = 0777
I have two shares and I can access both of them.
I think that you have to specify the "ntlm auth" and also the "server min protocol". Check also "security" and "passdb backend".
I specified that I need authentication to access my shares, though, I don't know what you have to do without authentication but it should be easier...

Good luck!

Last edited by jurassicman; 27 December 2019 at 16:22.
jurassicman is offline  
Old 27 December 2019, 15:33   #3
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,465
I also guess that it could be samba version issue. Raspbian has changed the default minimum version from 1.0 to 3. As far as I know smbfs supports only the old 1.0. So you need to make sure that server and client talk the same language. Set min/max protocol level like jurassicman example could already solve your problem. For details read "man smb.conf".
daxb is offline  
Old 27 December 2019, 22:07   #4
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 670
Hi jurassicman and daxb and thank you!

With your help, I manged to get access to my Raspberry PI from my Amiga through Samba

After copying/pasting jurassicman's security options:

Code:
server min protocol = NT1
ntlm auth = yes 
raw NTLMv2 auth = yes
security = user
passdb backend = tdbsam
I figured that the only option needed for my setup was:

Code:
ntlm auth = yes
which means that the server will "Allow NTLMv1 and above for all clients."
So, yes, daxb you were right on the mark: it was indeed a communication problem!
My working config (testparm) is:

Code:
[global]
        log file = /var/log/samba/log.%m
        logging = file
        max log size = 1000
        ntlm auth = ntlmv1-permitted
        workgroup = GIB
        idmap config * : backend = tdb


[Public]
        create mask = 0777
        directory mask = 0777
        path = /media/Backup/Public
        read only = No


[Software]
        create mask = 0777
        directory mask = 0777
        path = /media/Backup/Software
        read only = No


[Work]
        create mask = 0777
        directory mask = 0777
        path = /media/Backup/Work
        read only = No


[Music]
        create mask = 0777
        directory mask = 0777
        path = /media/WWW/Music
        read only = No
Cheers and happy holidays!
tygre is offline  
Old 28 December 2019, 10:59   #5
jurassicman
Registered User

jurassicman's Avatar
 
Join Date: Dec 2017
Location: Bologna/Italy
Posts: 269
Thanks for your feedback tygre! I'm glad to have helped, ciao!
jurassicman is offline  
Old 28 December 2019, 13:37   #6
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,465
I was wrong because I thought it could be the default used version issue. However, I didn't found "ntlm auth = ntlmv1-permitted" in the man page. Only this:
Code:
       ntlm auth (G)

           This parameter determines whether or not smbd(8) will attempt to authenticate users
           using the NTLM encrypted password response. If disabled, either the lanman password
           hash or an NTLMv2 response will need to be sent by the client.

           If this option, and lanman auth are both disabled, then only NTLMv2 logins will be
           permited. Not all clients support NTLMv2, and most will require special configuration
           to use it.

           The primary user of NTLMv1 is MSCHAPv2 for VPNs and 802.1x.

           The default changed from "yes" to "no" with Samba 4.5.

           Default: ntlm auth = no
daxb is offline  
Old 28 December 2019, 21:38   #7
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 670
Hi daxb!

Indeed

Code:
ntlm auth = yes
and

Code:
ntlm auth = ntlmv1-permitted
means the same things, see these man pages under section "ntlm auth (G)":

Quote:
The available settings are:
  • ntlmv1-permitted (alias yes) - Allow NTLMv1 and above for all clients.
Cheers!
tygre is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
SMBFS released AMIGASYSTEM News 9 20 April 2019 01:22
SMBFS: Problems AMIGASYSTEM support.Apps 9 25 April 2018 00:35
How to use SMBFS @UAE support.Apps 18 08 February 2016 10:42
Help with SMBFS? madman support.Apps 1 14 August 2011 20:32
SMBFS And Windows VIsta @UAE support.Apps 11 12 April 2011 21:41

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 15:01.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.08553 seconds with 15 queries