English Amiga Board


Go Back   English Amiga Board > Coders > Coders. System

 
 
Thread Tools
Old 21 January 2018, 00:29   #2101
TuKo
Apollo Team

TuKo's Avatar
 
Join Date: May 2014
Location: Switzerland
Posts: 190
That's great ! Thanks !
TuKo is offline  
AdSense AdSense  
Old 21 January 2018, 06:13   #2102
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,508
Thanks, great solution for an old annoying problem.
gulliver is offline  
Old 21 January 2018, 07:40   #2103
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,789
Removed 468, still not working perfectly when swapping images.
PeterK is offline  
Old 21 January 2018, 08:11   #2104
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,508
No worries, we are patient, and trust your skills
gulliver is offline  
Old 21 January 2018, 18:57   #2105
hexaae
Registered User

hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 42
Posts: 797
Is there a tool like Eastern http://m68k.aminet.net/package/util/wb/eastern available with support for 24+bit palette icons thanks to iconlib46?
hexaae is offline  
Old 21 January 2018, 23:55   #2106
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,789
Update to icon.library 46.4.469:

The bugs of 468 should be fixed. The problem was that the filename of the Ram Disk can be an absolute path or just a file relative to the current dir, and the root can be the device RAM: or any volume name like "Ram Disk" or "RamDisk" as I use it to avoid spaces in the path. Not so easy to detect the Ram Disk. Usually RAWBInfo and SwazInfo are using the tool DefIcons to get the default icon. If DefIcons is not installed icon.library loads def_RAM.info now instead of def_Disk.info.

So, the automatical updating of def_RAM.info works now on the Workbench 3.5/3.9 and 68020+ CPUs, even if you have OS 3.0/3.1 installed. No need for DefIcons running. It doesn't work on DOpus5 or 68000 systems. That's why I have removed the 68000 code again.

@hexaae
Quote:
The 68k build of Eastern assumes an OS4 compatible icon.library when the version number of the library is v51 or higher. In this case truecolor icons will be created.
I would assume that v51 has some additional features compared to v45/46. Didn't analyze yet what Eastern really needs for TrueColor support.
PeterK is offline  
Old Yesterday, 13:24   #2107
indigolemon
Bit Copying Bard

indigolemon's Avatar
 
Join Date: Jan 2017
Location: Kelty, Fife, Scotland
Age: 35
Posts: 249
Hi Peter, the ram disk icon is working perfectly for me with 469, softlink removed from startup-sequence. Great work as always!

You also made me investigate AmberRAM which is also setup and working well now too
indigolemon is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
ClassicWB Full and icon.library 46.4 Retroplay project.ClassicWB 6 03 December 2012 13:47
WB library conflict/versions Akira support.Apps 3 22 July 2010 19:47
PNG Icon to Color Icon Converter? Leandro Jardim request.Apps 1 24 May 2010 05:39
What's the latest version of icon.library for OS3.9? NovaCoder support.Apps 3 30 June 2009 16:43
Requesting icon.library v44+... nikvest request.Other 2 16 September 2007 02:58

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 07:48.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Page generated in 0.27632 seconds with 14 queries