English Amiga Board


Go Back   English Amiga Board > Support > support.FS-UAE

 
 
Thread Tools
Old 23 October 2016, 11:13   #1
BastyCDGS
Registered User
 
Join Date: Nov 2015
Location: Freiburg / Germany
Age: 39
Posts: 117
Send a message via ICQ to BastyCDGS
Strange problem when fullscreen + mouse integration enabled with intuition windows

Hello folks,

I am having a problem with FS-UAE 2.8.0 in Ubuntu 14.04 32-bit.
It happens, when mouse integration is enabled while in fullscreen mode. It doesn't seem to appear in windowed mode.

The problem at least occurs in my WB1.3 harddrive installation on ECS as well as OS3.9 RTG installations when the top-most screen is AGA.

The issue is that clicks on the close window gadget as well as clicking the front/back gadgets in the right-top corner are only partially recognized, i.e. sometimes I click on close gadgets and the click is not registered, so intuition doesn't even draw the clicked graphics.
Retry the close gadget click sometimes does work, but other times I have to move the pointer to the right side of screen and try clicking there first before close gadgets starts working again. Sometimes I have to right-click first. Sometimes it's pure random.

The screen resolution is 640x256 in 16 colors. Workbench on 1.3 is same but 4 colors and on 3.9 is RTG with 1280x1024 in true color.

Another issue is that reboot on WB1.3 sometimes suddenly boots in NTSC mode. I know of an old bug in WB1.3 which also caused this on original Amigas. But it happens way more often with mouse integration enabled.

EDIT: Right clicking instead of clicking on close gadgets also shows the mentioned behaviour, i.e. is ignored by intuition (normally you would have to see the window title disappear in order to show the menu, which doesn't happen here). It seems that mouse clicking events aren't always fired and sent to AmigaOS.

EDIT2: Screen-dragging also can cause strange behaviour because of this, sometimes intuition doesn't get the mouse button released event and the screen drags with mouse, even with no button pressing. Switching to windowed mode during the above problems solves them until switch back to fullscreen again.

Last edited by BastyCDGS; 23 October 2016 at 11:57. Reason: Further investigation
BastyCDGS is offline  
Old 21 May 2019, 20:49   #2
BastyCDGS
Registered User
 
Join Date: Nov 2015
Location: Freiburg / Germany
Age: 39
Posts: 117
Send a message via ICQ to BastyCDGS
Both problems seem to be fixed with the latest git from Frode in the WinUAE 4.2.1 branch.

Couldn't reproduce them after some twenty minutes.

Guess, this issue can be closed.
BastyCDGS is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Window sizing mouse pointer issue when RTG enabled mark_k support.WinUAE 1 05 February 2013 15:30
Intuition window WinAPI integration? Mequa support.WinUAE 10 12 November 2010 21:46
winuae crashing windows on fullscreen petee1979 support.WinUAE 3 25 May 2009 12:02
Windows/Amiga integration vodley support.WinUAE 1 28 June 2008 19:32

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.06367 seconds with 13 queries