English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 12 January 2020, 05:01   #1
cbmeeks
Registered User

 
Join Date: Dec 2015
Location: Hixson, TN USA
Posts: 42
Keyboard problems on Amiga 600

Back in July 2019, I recapped my Amiga 600 HD. It went really well. I tested everything, played some mods for a long time, loaded pics, etc.


I then packed it away and decided to open it back up this evening. Upon first boot, the caps lock key stayed lit and it asked me to insert a disk (I have WB2 loaded on a HD). I power cycled it.


Next, the caps lock key went off and it booted to the hard drive as normal.


However, the keyboard does not work at all. Caps lock will not turn on, none of the keys work, etc.


I power cycled it a few more times. Sometimes the caps lock will come on and stay on. Sometimes not. In either case, none of the keys work.


Something to note is that the only PSU I have is from my Amiga 500. This machine was missing the PSU when I bought it.


Any ideas on what it could be?


I will take it apart tomorrow and see what I can see (too tired tonight).


Thanks!
cbmeeks is offline  
Old 12 January 2020, 10:41   #2
aeberbach
Registered User

 
Join Date: Mar 2019
Location: Melbourne, Australia
Posts: 131
How sure are you about your PSU? They also need to be recapped.
aeberbach is offline  
Old 12 January 2020, 15:38   #3
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 711
Reseat the keyboard ribbon cable - it may have come loose.

Or, if you inspect it, the ribbon cable pads may have become worn and you might have to do the trick of cutting off a bit of it at the end so that the ribbon connector makes contact with the ribbon cable pads further up on a non worn out part of it.

When you disconnect/reconnect the ribbon cable, make sure you do it the right way. Loosen the connector before pulling the ribbon cable out, or pushing the ribbon cable it. If you don't do it like this then this is what normally destroys the ribbon cable pads - as the connector pins will scrape against the ribbon cable pads.
solarmon is offline  
Old 12 January 2020, 22:24   #4
cbmeeks
Registered User

 
Join Date: Dec 2015
Location: Hixson, TN USA
Posts: 42
No luck. I reseated the ribbon cable several times. Cleaned it. Used DeoxIT in the connector and eventually trimmed the edge. Still doesn't work.

Does anyone sell replacement membranes for these?

Thanks for the suggestions.
cbmeeks is offline  
Old 13 January 2020, 00:17   #5
supaduper
Registered User
supaduper's Avatar
 
Join Date: Oct 2012
Location: Birmingham UK
Posts: 901
Yep here just make sure you buy the correct one for your A600, Blue or Green
link below

https://www.sellmyretro.com/offer/de...c471b%29-29079
supaduper is offline  
Old 13 January 2020, 00:52   #6
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 711
Use Amiga Test Kit to do a health check of your A600, and to also to test the keyboard.

I assume you have got another A600 you can test the keyboard on, or test the keyboard from the other A600?
solarmon is offline  
Old 16 January 2020, 12:34   #7
Kin Hell
Registered User
Kin Hell's Avatar
 
Join Date: Mar 2009
Location: Cornwall, UK
Posts: 702
Quote:
Originally Posted by cbmeeks View Post
No luck. I reseated the ribbon cable several times. Cleaned it. Used DeoxIT in the connector and eventually trimmed the edge. Still doesn't work.

Does anyone sell replacement membranes for these?

Thanks for the suggestions.
When you trimmed the Keyboard cable, did you peel back the green coating?

See Here:

http://eab.abime.net/showthread.php?t=100286
Kin Hell is offline  
Old 16 January 2020, 18:22   #8
Pollock
Registered User

 
Join Date: Apr 2018
Location: Glasgow
Posts: 58
i had this exact same thing happen, keyboard membrane was about GBP30.

make sure you order the right one, there is a green one, and blue one.
Pollock is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amiag 600 Furia and Keyboard problems lupenbit support.Hardware 3 08 January 2020 18:59
Amiga 600 keyboard problem Mekanikal support.Hardware 6 13 July 2018 01:38
Amiga 600 keyboard - how to remove keys? eebuckeye support.Hardware 2 29 August 2014 12:48
Buy keyboard for Amiga 600 OldMan MarketPlace 0 14 August 2014 20:13
Wanted: Amiga 600 keyboard membrane (Blue) or full keyboard assembly RetromanIE MarketPlace 8 19 August 2012 15:48

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 15:19.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.07002 seconds with 15 queries