English Amiga Board


Go Back   English Amiga Board > Coders > Coders. System

 
 
Thread Tools
Old 09 January 2021, 20:21   #3581
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,860
Using IconCopier with the bug that I mentioned could make the system unstable. It's an old tool and I don't know if Mark Ritter still supports it with bug fixes.

Usually, RemLib should be executed before the first program tries to access icon.library. On Aros 68k IPrefs seems not to call icon.library as it is done on AmigaOS, so you're lucky and it may work even from user-startup. But in case that any program opens icon.library before RemLib is executed it would load it from the Aros Rom into memory and installing my library later from Libs: may fail.

The transparent disk icon in your video could be a ghosted deficon, a disk without an existing disk.info file. If your don't like that you could add the tooltype "NoGhost" to Envarc:Sys/def_disk.info (or what it is) or use "IconGhostingOff".

You are trying to rename some icons in your video with Icon->Information by changing the path. Nobody says that this would work. Why don't you use Icon->Rename instead? There is nothing at the path "Ram:downlod" and it should fail.

Sorry, concerning Alerts and Crashes of Wanderer I can't help you, that are covert Aros features, I guess ...
PeterK is offline  
Old 09 January 2021, 20:40   #3582
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,425
Quote:
Originally Posted by PeterK View Post
Using IconCopier with the bug that I mentioned could make the system unstable. It's an old tool and I don't know if Mark Ritter still supports it with bug fixes.

Usually, RemLib should be executed before the first program tries to access icon.library. On Aros 68k IPrefs seems not to call icon.library as it is done on AmigaOS, so you're lucky and it may work even from user-startup. But in case that any program opens icon.library before RemLib is executed it would load it from the Aros Rom into memory and installing my library later from Libs: may fail.
Yes it's true, but I have to be honest I never noticed any anomaly, even in the video I used RemLib in the User-startup and it seems to me that everything worked fine


Quote:
The transparent disk icon in your video could be a ghosted deficon, a disk without an existing disk.info file. If your don't like that you could add the tooltype "NoGhost" to Envarc:Sys/def_disk.info (or what it is) or use "IconGhostingOff".
No this happens with all the icons, if I set the "Fix" command the colors come back, and I use the Def icons with the "Nightly Build".

If I run Dopus5 "by AROS One" the icons are not transparent, see screnshot

Quote:
You are trying to rename some icons in your video with Icon->Information by changing the path. Nobody says that this would work. Why don't you use Icon->Rename instead? There is nothing at the path "Ram:downlod" and it should fail.

No, it was just to show that with the folder icon it didn't crash.
By the way, another bug, if you try to rename an icon (without files) from Wanderere the system crashesa

Last edited by AMIGASYSTEM; 19 January 2021 at 18:05.
AMIGASYSTEM is offline  
Old 09 January 2021, 21:15   #3583
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,860
Yes, DOpus5 has no support for ghosting.

Did you check whether there really was a #?.info file for that transparent icon, and if not whether it was created (becoming a real icon) by fixing it? Did you try "IconGhostingOff" ?

I don't have the latest Aros installed to test that (it's still from October 2020). So, I'm not up to date with the latest issues, need to download it again ...
PeterK is offline  
Old 09 January 2021, 21:51   #3584
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,425
Quote:
Originally Posted by PeterK View Post
Yes, DOpus5 has no support for ghosting.
Did you try "IconGhostingOff" ?
No tried now and it works perfectly "IconGhostingOff" , now all the icons are well visible, thank you !
AMIGASYSTEM is offline  
Old 10 January 2021, 09:40   #3585
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,425
Quote:
Originally Posted by PeterK View Post

Sorry, concerning Alerts and Crashes of Wanderer I can't help you, that are covert Aros features, I guess ...
Solved, Fixed the error

After going through the system file by file i found the culprit was the file named "Info" path:

SYS:System/Wanderer/Tools/Info

Replaced it with the version released last night and the problem is solved
AMIGASYSTEM is offline  
Old 10 January 2021, 18:28   #3586
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,860
Update to icon.library 46.4.542:

Just two small changes: 1.) In some applications like YAM icons didn't have a transparent background (mask) and its deficons were ghosted (ie. for attachments). 2.) zlib.library is no longer opened by default at Init(), but is loaded only on demand by "ConvertPNGtoOS4" or when Eastern writes its preview icons to disk. I'm still waiting for OS 3.2 to test the new features (only in v51, not included in v46 yet).

Last edited by PeterK; 10 January 2021 at 19:26.
PeterK is offline  
Old 11 January 2021, 08:50   #3587
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 43
Posts: 2,229
Quote:
Originally Posted by PeterK View Post
Update to icon.library 46.4.542:
I'm still waiting for OS 3.2 to test the new features (only in v51, not included in v46 yet).
Let me know, and I can give you a hand.
gulliver is offline  
Old 11 January 2021, 12:44   #3588
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,860
Thanks, in case that the NDK is already available now, you could send me a download link, if you like and are allowed to do that. I hope the NDK is still for free.
PeterK is offline  
Old 14 January 2021, 20:33   #3589
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,860
Does somebody still have IconLib_46.4.229.lha and IconLib_46.4.230.lha or the asm source files (from 2012)?

All old lha packages from build #165 up to build #269 are also missing in my collection since two HDDs died many years ago. Everything else still exists and some versions in this range too, but with many gaps.

Last edited by PeterK; 16 January 2021 at 14:51.
PeterK is offline  
Old 01 February 2021, 17:24   #3590
James
Registered User

 
Join Date: Mar 2010
Location: Beckenham/England
Posts: 672
Bit late here, but I've put 230 in the zone just in case you still haven't found it elsewhere. Would have attached it, but have run low on space...
James is offline  
Old 01 February 2021, 19:07   #3591
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,860
Perfect! Thanks James!

Even though I could find the bug and made a fix already, it's still good to have another old version that fills one of the gaps in my collection.

A new update may come as soon as my solution was tested successfully by the user who has reported the problems.
PeterK is offline  
Old 04 February 2021, 18:57   #3592
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,860
Update to icon.library 46.4.543:

1.) For ColorIcons of the type Trashcan the planar images are now only replaced by internal defaults if there was only one image available (ie. Project or Tool from icon sets) and when the tag "PreserveOldIconImages" is set to "False". This should make it possible to create, keep or edit old trashcan icons in IconEdit again.

2.) I've added a new option "Reduce8PlanesTo3" which changes the depth to 3 and PlanePick to 7 for planar icons with 8 planes. That way MWB icons with 256 colors are converted to use the pens 0-7 only. Planar images with 1-7 planes are not changed in order to keep some rare icon sets with 16 colors still working. This new option is an alternative to "KillPlanarImages", "KeepPlanarImages" and the default behavior of my library which usually replaces all images with more than 3 planes by internal icons. Btw, the code for "KeepPlanarImages" was broken since #539 and is fixed again.

PS. Unfortunately, IconEdit of OS 3.9 has the habit to display the first and the last 4 colors of the screen palette for images with 8 colors. That's a bit confusing for MWB icons with 3 planes only.

http://aminet.net/package/util/libs/IconLib_46.4

Last edited by PeterK; 08 February 2021 at 13:28.
PeterK is offline  
Old 11 February 2021, 12:27   #3593
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,425
Hi Peter, i wanted to ask you if on Amiga there is a program that allows to change the color of an icon in a temporary way.

Example if I use a grey screen also the icons should be grey.

Also is there a software to change the color of the fonts, I would need it for AROS 68k that doesn't have a "colors" fonts preference program.
AMIGASYSTEM is offline  
Old 11 February 2021, 14:02   #3594
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,860
Hi Carlo!

No problem for gray icons on native WB screens (not on Hi/TrueColor). Just use my option GrayscaleOnOff and also set the icon quality in Prefs/Workbench to "Bad" to activate it or the option FastColors. But old and MWB icons still keep their colors and it won't work on AfA_OS, of course.

It seems to work on Aros 68k with 8-bit screens too (GrayscaleOnOff and FastColors), but Aros has a strange palette, and no, I don't know how to change Font colors.

Sorry, it's not possible yet to change the color of icons at runtime, but maybe you can get a color filter overlay film for your monitor?
PeterK is offline  
Old 12 February 2021, 11:35   #3595
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,425
Quote:
Originally Posted by PeterK View Post
Hi Carlo!

No problem for gray icons on native WB screens (not on Hi/TrueColor). Just use my option GrayscaleOnOff and also set the icon quality in Prefs/Workbench to "Bad" to activate it or the option FastColors. But old and MWB icons still keep their colors and it won't work on AfA_OS, of course.
Yes tested it works with OS3.9 RTG but only with 8Bit though

Quote:
but maybe you can get a color filter overlay film for your monitor?
Could you please explain how to do this thank you

I didn't understand how ProcessIcon works, it can help to change colors temporarily! too bad it doesn't have a GUI this useful application

http://aminet.net/search?query=processicon
AMIGASYSTEM is offline  
Old 12 February 2021, 13:39   #3596
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,860
Quote:
Originally Posted by AMIGASYSTEM View Post
Yes tested it works with OS3.9 RTG but only with 8Bit though
You can use my 68000 version for Hi/TrueColor WB screens, because that always works with color mapping, but is a little bit slower and misses several features of the higher versions (68020 or TC020). It won't work on Aros 68k!

Quote:
Could you please explain how to do this thank you
No, better not, just kidding ...

Quote:
I didn't understand how ProcessIcon works, it can help to change colors temporarily! too bad it doesn't have a GUI this useful application
No, I can't see that. ProcessIcon has an option REMAP for OS 1.3 icons and an option SBP to reduce the number of bitplanes, maybe something like my "Reduce8PlanesTo3". But it has nothing for changing the palette of ColorIcons.

So, what do you really want to do, and with which type of icons?

You could also have a look at VisualPrefs and Prefs/GUI, but I don't know whether that can help you. It can change at least some default colors for GUI elements, unfortunately not the icon label colors.
PeterK is offline  
Old 12 February 2021, 14:59   #3597
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,425
Quote:
Originally Posted by PeterK View Post
So, what do you really want to do, and with which type of icons?
I wish that on Amiga there was a software like iColorFolder but temporarily
AMIGASYSTEM is offline  
Old 12 February 2021, 15:28   #3598
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,860
On Aminet there are Classic Drawer Icons in many different colors and sizes and excellent PNG quality.

And there also exists a tool from Thomas Rapp which generates a drawer ColorIcon in any desired color, which can be adjusted with sliders.

http://eab.abime.net/showthread.php?...99#post1117999

http://eab.abime.net/showthread.php?t=84520

Of course, these colorful drawer icons are not temporary. Once created the colors are permanent.

Last edited by PeterK; 12 February 2021 at 15:35.
PeterK is offline  
Old 12 February 2021, 20:14   #3599
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 6,425
Thanks Peter, I would have liked a temporary change, for the icons I guess I don't need it.

In the screnshoot you can see some of the hundreds of PNG Icons I created for AROS One 68k and x86, in addition to those that I created for AfA One, I attach the two Preview of my 68k and x86 distributions, I would like your opinion.

Test WinUAE and yours Icon.library:

AROS One 68k v1.3 Preview: Tutorial Video

AROS One x86 Test VMVare:

AROS One x86 v1.4 Preview: Tutorial Video (for quality viewing set the video to 720p)

AROS One x86 Test VirtualBox

AROS One x86 1.4 Preview: Tutorial Video (for quality viewing set the video to 720p)

AROS One x86 Test PC Real Inspiron Mini 910

One 68k 1.4 Preview: Tutorial Video (for quality viewing set the video to 720p)

Last edited by AMIGASYSTEM; 01 March 2021 at 17:55.
AMIGASYSTEM is offline  
Old 12 February 2021, 21:24   #3600
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,860
Carlo, it's amazing how much time you spend putting all these distros together, configuring the applications and creating very nice looking icons for them, but I think I'm the wrong person to evaluate your work, since I've not much interest using the AmigaOS or Aros anymore (icon.library included).

I once did or tried that 25 years ago what you are showing in your video clips: playing music, videos, demos (but never games), displaying pictures, connecting to the internet with the first browsers, ftp or email clients. Since the start of the millennium I don't do that anymore. It has no attraction for me to demonstrate what AmigaOS is able to do (now), that's over for long. I use my Mini-PC with the damned Windows 10 for everything today, starting WinUAE just keeps my memories of the good old times alive.

Your new icons are looking great, although I would prefer to have something like a glowing effect for the second images, because that shows much clearer which icons are selected than just a smaller or a different image.
PeterK is offline  
 


Currently Active Users Viewing This Thread: 16 (0 members and 16 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
ClassicWB Full and icon.library 46.4 Retroplay project.ClassicWB 8 05 August 2018 14:57
WB library conflict/versions Akira support.Apps 3 22 July 2010 19:47
PNG Icon to Color Icon Converter? Leandro Jardim request.Apps 1 24 May 2010 05:39
What's the latest version of icon.library for OS3.9? NovaCoder support.Apps 3 30 June 2009 16:43
Requesting icon.library v44+... nikvest request.Other 2 16 September 2007 02:58

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:41.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.29917 seconds with 16 queries