English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 10 September 2018, 22:53   #1
captainjoe
Registered User

 
Join Date: Aug 2018
Location: Europe
Posts: 1
Angry Amiga 1081 monitor, no image...

Hi all
I recently picked up an Amiga 1081 monitor (PAL), but it does not work:
When I push the power button, the LED lights up and immmediately turns off again.
When a working computer is connected, no image appears on the screen. Also when I keep holding the power button down, no image appears.
See the gif below.
Anybody an idea what might be wrong here?

Thanks a lot in advance!

captainjoe is offline  
Old 11 September 2018, 09:30   #2
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 38
Posts: 6,920
Disconnect the chassis from the PSU and see if the PSU stays on that way. If not, then your PSU has a fault.

If the PSU stays on, then there is a problem with the chassis. My crystal ball says: LOPT + HOT. Perhaps do a cap kit at the same time when you have it all out on the table.
Jope is offline  
Old 13 September 2018, 05:34   #3
Shadowfire
Registered User
Shadowfire's Avatar
 
Join Date: Aug 2001
Location: Connecticut USA
Posts: 559
What happens if you push the switch in and hold it there?
(i.e. probably the switch isn't staying on when you press it)
Shadowfire is offline  
Old 13 September 2018, 10:56   #4
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 38
Posts: 6,920
If it's an intermittent switch, the LED doesn't fade out.
Jope is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
[FS] 1081 Monitor Loedown MarketPlace 0 29 April 2018 04:37
For sale: Commodore Amiga monitor 1081 jman MarketPlace 0 30 November 2011 10:35
For Sale/Trade: Amiga 1081 Monitor Fingerlickin_B MarketPlace 0 24 December 2009 06:37
Amiga Monitor 1081 does not turn on dir_marillion support.Hardware 16 06 February 2009 14:39
Trade: 1081 Monitor for What You Got Fingerlickin_B MarketPlace 0 01 December 2008 01:29

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 19:16.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06056 seconds with 13 queries