English Amiga Board


Go Back   English Amiga Board > Support > New to Emulation or Amiga scene

 
 
Thread Tools
Old 08 September 2009, 16:05   #1
dframeli
Registered User
 
Join Date: Jan 2009
Location: Kyle, Texas (USA)
Posts: 33
Amithlon / AHI Sound Configuration Guide?

Does anyone know whether an Amithlon/AHI sound configuration guide exists?

I have Amithlon installed, along with an Amithlon compatible sound card (SB 512), Kernal v3.10, Drivers v0.90, AHI v6.0 (w/Paula), OpenPCI v2.1 and powerpci library.

I've configured AHI properly (I think).

When I play a song, I can see AmigaAMP's leds move as if the player is playing my song, however there's no sound output...

BTW, I editted and then started Puh, but that made no difference. I also tried two other Amithlon compatible cards, yet the result is the same.

I must have overlooked some small detail... Can anyone recommend that it might have been?

Thanks,
Dale
dframeli is offline  
AdSense AdSense  
Old 08 September 2009, 16:33   #2
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,542
Probably the sound card is muted. Find the Mixer utility which allows you to change the volumes for the sound card.

Also there is a conflict between the new Linux-wrapper drivers and the original Amithlon drivers. You may install only one kind. Read the docs of the updates.
thomas is offline  
Old 09 September 2009, 15:56   #3
dframeli
Registered User
 
Join Date: Jan 2009
Location: Kyle, Texas (USA)
Posts: 33
Thomas,

I checked the AHI and Sound control panels, but did not find a mute option. (Volume levels are set to MAX)

I also checked the AmigaAmp configuration, but did not find one there either. (Volume is set to MAX and EQ Boost is also set to MAX)

I have the AC'97 mixer (all options are unmuted) but since this is a SB board, I didn't think I needed to use it...

Were you referring to something else when you mentioned unmuting the mixer utility?

Any other suggestions?

Thanks!
dframeli is offline  
Old 09 September 2009, 16:37   #4
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,542
I am not sure what it's called, it's quite some time since I used Amithlon last time. Probably it's the AC97 mixer.

Every platform which uses PC sound cards (Morphos, OS4, Meditator, Amithlon) comes with some kind of mixer utility. Some of the sound card drivers mute the sound card by default, so you have to run the mixer first, before you can hear anything.
thomas is offline  
Old 10 September 2009, 15:58   #5
dframeli
Registered User
 
Join Date: Jan 2009
Location: Kyle, Texas (USA)
Posts: 33
I have 3 different SB sound cards sitting here.

All 3 are supposedly Amithlon compatible (SoundBlaster 128 w/ES1371 chip, SoundBlaster 128 w/CT5880 chip and SoundBlaster 512).

I've tested each of these 3 sound cards (one at a time, seperately), all 3 react the same way... I can see the leds in AmigaAMP moving for the duration of the song that is being played, however I hear nothing...

At the moment, only one card, the SoundBlaster 128 w/ES1371 chip is installed.

Even though I'm using a SB card, I tried the AC'97 Mixer utility. I confirmed that all options were unmuted, however I'm still not getting any sound output.

I editted PuhDerBaer and launched that, but again, no sound....

Currently, I have AHI v6.0 installed, and PAULA Stereo ++ selected in the AHI control panel as my output... (I tried the other options already)

Just so that I'm clear on the process, can you tell me what I need to install to get sound working, and also the sequence of steps that need to be taken within the Amiga OS to enable Amithlon sound output?

Also, is there a SB specific mixer, or just is the AC'97 Mixer utility the only one available?

Thanks!

Last edited by dframeli; 10 September 2009 at 16:08.
dframeli is offline  
Old 10 September 2009, 21:37   #6
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,263
Quote:
Originally Posted by dframeli View Post
Also, is there a SB specific mixer, or just is the AC'97 Mixer utility the only one available?
Hi Dale,

A while ago, there was a site (amigabest.com) which hosted a lot of drivers and utilities for the Amiga including Amithlon. Unfortunately the site no longer exists in that guise.

When it was online, there was an AC97 Mixer 2.1 for Amithlon listed, but nothing for SoundBlaster or other sound cards.

I can upload it for you if it's different to yours and you'd like to try it.
prowler is offline  
Old 11 September 2009, 18:22   #7
dframeli
Registered User
 
Join Date: Jan 2009
Location: Kyle, Texas (USA)
Posts: 33
Prowler,

Thanks. I have a copy of the AC'97 Mixer utility.

Question, how do I load the Amithlon sound drivers???

They do not shown up in my AHI control panel.


Thanks Again!
Dale

Last edited by dframeli; 11 September 2009 at 19:35.
dframeli is offline  
Old 11 September 2009, 21:47   #8
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,263
Hi Dale,

I've uploaded the AC97 Mixer 2.1 for Amithlon to the Zone, just in case there's something in the archive you don't have.

I think that if the SoundBlaster had been fitted before installing Amithlon, the drivers would have installed automatically. There may be no provision to install the drivers retrospectively, if you have added it since then.
prowler is offline  
Old 11 September 2009, 21:53   #9
dframeli
Registered User
 
Join Date: Jan 2009
Location: Kyle, Texas (USA)
Posts: 33
Prowler,

Thanks!

I just kept messing with it until "finally", the Amithlon sound driver appeared in my AHI control panel. Not sure exacly what the problem was, but it appears to be fixed now

(BTW, the AHI SB and AHI AC'97 drivers did not work for me).

Thanks Again!
dframeli is offline  
Old 11 September 2009, 22:00   #10
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,263
Quote:
Originally Posted by dframeli View Post
(BTW, the AHI SB and AHI AC'97 drivers did not work for me).
But the AC97 Mixer does seem to have good compatibility with the SoundBlaster according to the AmigaGuide included with it.
prowler is offline  
Old 11 September 2009, 23:51   #11
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,263
Hi Dale,

I've found the new web address for the amigabest.com site:
http://amithlon.free.fr/~amigabest/english/frame_en.htm
However, none of the downloads ( http://www.chez.com/amigabest/indexeng.php3 ) are working, and the site was last updated on 3rd August 2003.

Edit: Fortunately, there's still quite a lot of useful info under the SUPPORT, COMPATIBILITY, TEST, FAQS and INSTALL tabs.

Last edited by prowler; 12 September 2009 at 00:48.
prowler is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amithlon Setup Guide Charlie project.Green Amiga Alien GUIDES 1124 06 September 2017 02:40
Mediator and AHI sound query DoogUK support.Hardware 8 18 November 2016 13:18
Amithlon-Guide / PDF-version Paul News 0 10 March 2006 16:43
AHI - no sound icewizard2k5 support.Apps 6 28 March 2005 12:48
Sound emulation on WB, AHI support?!? Guest New to Emulation or Amiga scene 0 21 January 2002 21:16

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:01.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.15192 seconds with 12 queries