English Amiga Board


Go Back   English Amiga Board > Support > support.Games

 
 
Thread Tools
Old 02 February 2008, 02:48   #1
demoniac
Registered User
 
Join Date: Jul 2005
Location: -
Posts: 1,358
Faery Tale Adventure - Sound Issues

Came across a weird sound emulation issue when testing out Faery Tale Adventure today. Tried several different settings like en-/disabling cycle-exact, no Slow RAM, A500 quickstart with KS1.2 or KS 1.3, etc. The sound starts weird and eventually syncs up.
demoniac is offline  
Old 02 February 2008, 03:03   #2
NLS
Ancient User
 
Join Date: Apr 2007
Location: GREECE
Age: 45
Posts: 617
Well in fact this happens with real Amiga too (I think with some cracks and/or FTA versions).
NLS is offline  
Old 02 February 2008, 09:58   #3
stainy
Zone Friend
stainy's Avatar
 
Join Date: Mar 2001
Location: Concord, NC, USA
Age: 48
Posts: 1,447
Send a message via ICQ to stainy Send a message via MSN to stainy
Quote:
Originally Posted by demoniac View Post
Came across a weird sound emulation issue when testing out Faery Tale Adventure today. Tried several different settings like en-/disabling cycle-exact, no Slow RAM, A500 quickstart with KS1.2 or KS 1.3, etc. The sound starts weird and eventually syncs up.

Confirmed!! me and a mate played this to death.. and we regulary had the sound sync issue
stainy is offline  
Old 03 February 2008, 22:02   #4
demoniac
Registered User
 
Join Date: Jul 2005
Location: -
Posts: 1,358
I vaguely remember that it happens on a real Amiga, but I also vaguely remember that it's an issue of having non-Chip expanded memory. My real floppies need to be relocated, so I can't perform this experiment immediately. Anyone else want to give it a go?

I just can't picture MicroIllusion (or any company) would release a game with faulty music at the title screen.
demoniac is offline  
Old 03 February 2008, 22:07   #5
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 47
Posts: 11,810
Just tried the WHDLoad installed game on my miggy. I can't hear any music issues. But jotd fixed something for this install:

Quote:
version 1.0 (20.11.04) done by JOTD:
- initial release
- document protection removed
- music & snoop bugs fixed
- saves games to HD (file "disk.2")
- original quit option works
- manual, solution, and hints included
- nice icons by Exoticons & Frank
- source code included
Retro-Nerd is online now  
Old 03 February 2008, 22:20   #6
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,348
Problem is very simple: music player do not initialize audio data pointers, first sample starts playing from address 0.

I noticed this long long time ago and my guess was: game was programmed and tested on an A1000 (it is really old game). A1000 boot rom moves audio pointers to area that is normally empty after hard reset.

Or they simply never tested it after hard reset
Toni Wilen is offline  
Old 03 February 2008, 23:52   #7
demoniac
Registered User
 
Join Date: Jul 2005
Location: -
Posts: 1,358
Thanks for the explanation, Toni. I'm pretty sure it was tested for the A1000. I remembered that the audio worked on my friend's A1000, but not on my A500. FYI, I did try KS1.1 on WinUAE earlier just to see if it was a KS issue..
demoniac is offline  
Old 04 February 2008, 00:08   #8
NLS
Ancient User
 
Join Date: Apr 2007
Location: GREECE
Age: 45
Posts: 617
mystery solved
NLS is offline  
Old 08 February 2008, 01:43   #9
andreas
Zone Friend
 
Join Date: Jun 2001
Location: Germany
Age: 45
Posts: 5,857
Send a message via ICQ to andreas Send a message via AIM to andreas
Quote:
Originally Posted by demoniac View Post
I just can't picture MicroIllusion (or any company) would release a game with faulty music at the title screen.
OH YES demoniac, they can!

http://hol.abime.net/2796

read this!! http://www.whdload.de/games/UltimateGolf.html (->NOTES)
andreas is offline  
Old 23 March 2019, 18:58   #10
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 43
Posts: 15,713
Just experienced this when trying to setup the game running from floppy disk (.ADF or .IPF)

...guess WHDLoad is the only way to go then.

Though it would be nice if there was a "ButtonWait" inserted into the slave, as the title screen flashes by too quickly.
DamienD is online now  
Old 23 March 2019, 19:50   #11
NLS
Ancient User
 
Join Date: Apr 2007
Location: GREECE
Age: 45
Posts: 617
Damien I actually like it, as it reminds me the floppy I had!
I never knew the game without the bug.

11 year old thread...
NLS is offline  
Old 23 March 2019, 20:18   #12
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 43
Posts: 15,713
Quote:
Originally Posted by NLS View Post
Damien I actually like it, as it reminds me the floppy I had!
I never knew the game without the bug.
I hear what you're saying... I usually use floppy disks in emulation as that's how I remember playing them (and I love cracktros / trainers); and luckily with WinUAE there are tricks to speed up boring loading times

...but, this sound bug is quite annoying. It's much better fixed IMHO so I'm now using the WHDLoad version

Quote:
Originally Posted by NLS View Post
11 year old thread...
Yeah I know, thread necromancy
DamienD is online now  
Old 23 March 2019, 21:36   #13
NLS
Ancient User
 
Join Date: Apr 2007
Location: GREECE
Age: 45
Posts: 617
Are we talking about the same bug? Music 2-3 seconds messed up in the start when reading the book?
Because, I cannot see something as annoying if it happens for a couple of seconds.

Except if you guys talk about some other sound problem.
NLS is offline  
Old 23 March 2019, 23:56   #14
amiwolf
Registered User

 
Join Date: Aug 2015
Location: Emerald City
Posts: 70
I remember this issue from my brief A1000 days. The garbled music at the intro began with Kickstart 1.2 so I always booted 1.1 when playing Faery Tale.

NB: Under emulation, you'll have to load a Kickstart 1.1 adf from df0: into the A1000's WCS-RAM. The A1000 1.1 256K ROM produces the same distorted sound.
amiwolf is offline  
Old 24 March 2019, 00:23   #15
NLS
Ancient User
 
Join Date: Apr 2007
Location: GREECE
Age: 45
Posts: 617
I never expected to read about a solution to a problem, that was 30+ years ago.

(I now need to test this just because)
NLS is offline  
Old 24 March 2019, 00:29   #16
malko
Ex nihilo nihil

malko's Avatar
 
Join Date: Oct 2017
Location: CH
Posts: 2,329
Quote:
Originally Posted by NLS View Post
Are we talking about the same bug? Music 2-3 seconds messed up in the start when reading the book?
[...]
I played this game so often. Yes, this issue. But honnestly it's only for 1 or 2 seconds in the beginning when the book appears on screen. Nothing really disturbing as music is playing fine after that and during the game.
malko is offline  
Old 24 March 2019, 00:47   #17
Pyromania
Moderator

Pyromania's Avatar
 
Join Date: Jan 2002
Location: Chicago, IL
Posts: 2,167
I think the sound issue you are having can’t be real. It must be a micro illusion.
Pyromania is offline  
Old 24 March 2019, 15:54   #18
ross
Per aspera ad astra

ross's Avatar
 
Join Date: Mar 2017
Location: Crossing the Rubicon
Age: 49
Posts: 2,230
Interesting thread.
Initially I could not understand, even after Toni's description, why a fix had never been made for this ADF after so many years.
Probably the answer is that it was not fully understood by patchers the culprit: the biggest problem is not the failure to initialize audio pointers (which is true) but a lack on AUDxLEN setup!

There is too much wrong documentation about this register(s) that circulates, where it is specified that the DMA can play at most 65535 * 2 samples with a single command.
Wrong!, you can also set a 65536 words fetch, setting it = 0 that is the "uninitilized" value at cold start.
With this values, and a DMA start, you "listen" Amiga low memory area
A1000 boot ROM jingle change this behavior and, by chance, the audio problem is not here.

So you can even leave the pointers to location 0 (normally zeroed) but if you set AUDxLEN = 1 at start you have patched the game

Do I create a working version for you?

Another question..
A version "with some corrections" seems to be available where the writing "Copyright (C) 1986 MicroIllusions" at start is not present.
In fact, making a binary comparison between the two ADFs there are differences both in the executable and little differencies on some raw tracks.
Someone can enlighten me so I can make a definitive working ADF version?

Cheers.
ross is offline  
Old 24 March 2019, 16:04   #19
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 43
Posts: 15,713
Quote:
Originally Posted by ross View Post
Do I create a working version for you?

Another question..
A version "with some corrections" seems to be available where the writing "Copyright (C) 1986 MicroIllusions" at start is not present.
In fact, making a binary comparison between the two ADFs there are differences both in the executable and little differencies on some raw tracks.
Someone can enlighten me so I can make a definitive working ADF version?

Cheers.
That would be awesome my friend

You could use the .IPF and also crack the protection / word check
DamienD is online now  
Old 24 March 2019, 16:07   #20
ross
Per aspera ad astra

ross's Avatar
 
Join Date: Mar 2017
Location: Crossing the Rubicon
Age: 49
Posts: 2,230
Quote:
Originally Posted by DamienD View Post
That would be awesome my friend

You could use the .IPF and also crack the protection / word check
Sure
So the IPS is the latest definitive version or there is some "after release" patch?
ross is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with the sound of "The Faery Tale Adventure" [Solved] Marskilla support.FS-UAE 2 25 October 2012 15:13
Faery Tale Adventure gfx issues rmcin329 support.Games 2 15 July 2008 20:44
The Faery Tale Adventure MainCore support.Games 2 26 September 2006 13:07
Faery Tale adventure crx MarketPlace 0 07 February 2005 22:36
Faery Tale Adventure and Emulator dpwicz support.Games 0 10 February 2003 05:10

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:44.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.09803 seconds with 16 queries