English Amiga Board


Go Back   English Amiga Board > Off Topic > OT - Technical

 
 
Thread Tools
Old 30 July 2019, 16:19   #1
xraynorm
Registered User
 
Join Date: Oct 2010
Location: suffolk
Posts: 70
Faulty powered speakers

Hi

I have a Creative gigworks t20 series 2 powered stereo speaker set which have become faulty in a very strange way. Basically they only work for a second or so when the power is turned OFF (power cord removed). Other than that they do not work. The power light is on. I have checked the PSU and it outputting 27v as it should.


Any ideas what type of fault this could be?

Last edited by xraynorm; 30 July 2019 at 16:38.
xraynorm is offline  
Old 30 July 2019, 17:52   #2
Daedalus
Registered User

Daedalus's Avatar
 
Join Date: Jun 2009
Location: Dublin, then Glasgow
Posts: 4,346
Faulty power regulation internally - the circuitry most likely uses something other than 27V internally, and it might not be able to maintain that. First thing to look at is capacitors in the power control area. Also, did you measure the PSU output under load (i.e., inside the speakers while turned on)?
Daedalus is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
What speakers do you use for your Commodore computers? hansel75 Retrogaming General Discussion 48 18 November 2019 18:47
A10 speakers for sale. ravard MarketPlace 0 21 June 2014 13:03
WTB: Speakers CU_AMiGA MarketPlace 1 12 December 2009 01:49
Computer speakers from Amiga era... Paul_s Nostalgia & memories 10 18 November 2009 10:02
pc speakers for Amiga? Angus support.Hardware 12 24 September 2009 21:05

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:42.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.05685 seconds with 13 queries