English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 23 July 2018, 04:33   #1
hardgb
HARDGB

 
Join Date: Jan 2016
Location: Fortaleza / Brasil
Posts: 14
Shapeshifter and MuEVD Help

I'm working with ShapShifter using an Apollo 1260 but I can not work with 256 colors, it's all black and white. I do not know how to configure MuEVD.
Please I need help.
hardgb is offline  
Old 23 July 2018, 06:49   #2
SKOLMAN_MWS
Registered User

 
Join Date: Jan 2014
Location: Poland
Posts: 147
Under Mac OS, did you switch from black and white to colors?
SKOLMAN_MWS is offline  
Old 23 July 2018, 08:52   #3
Cammy
Registered User
Cammy's Avatar
 
Join Date: Aug 2007
Location: Tasmania, Australia
Age: 34
Posts: 1,138
There's really not much configuration necessary if you have installed all the files correctly. So make sure you have this in your Startup-Sequence...

C:MuMove4k PrepareEmul
C:MuFastZero On

And remove C:PrepareEmul, as MuMove4K replaces it.

And from within Shapeshifter, choose a 256 colour 640x480 Amiga screenmode. Select MuEVD as your Video Driver, and boot into MacOS. Once in MacOS, open the Screen settings and select Color.

Hopefully that's all you need to get it working!
Cammy is offline  
Old 23 July 2018, 14:02   #4
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,391
And it is a good idea to read the MuEVD.guide.
daxb is offline  
Old 24 July 2018, 04:04   #5
hardgb
HARDGB

 
Join Date: Jan 2016
Location: Fortaleza / Brasil
Posts: 14
Many thanks for the guidance, I did not know I had to change the color settings inside the MacOs. I did it and it worked, now it's colorful. But I think there must be something wrong, because sometimes it will lock and restart the Amiga. I'll put here my "startup-sequence"
Please, if there is anything I can insert into my startup-sequence to optimize things, I appreciate if you can help me.
Note: Forgive me my English, it is horrible

Code:
;ClassicWB Startup-Sequence
;--------------------------
;OS39

;Start OS3.9 Checks

DRAP
If WARN
RemApollo MAC QUIET
EndIf

IF EXISTS C:SquirrelSCSI
    C:SquirrelSCSI
EndIF
Set SCSIUpdate 1
IF EXISTS C:IDEFix
    C:IDEFix
    Set SCSIUpdate 0
EndIF
IF EXISTS SYS:Expansion/XSurfIDE
    Set SCSIUpdate 0
EndIF
IF EXISTS SYS:Prefs/Env-Archive/NOSCSIUPDATE
    Set SCSIUpdate 0
EndIf
IF $SCSIUpdate EQ 1
   SetPatch SKIPROMUPDATES "exec.library" QUIET
Else
   SetPatch SKIPROMUPDATES "scsi.device,exec.library" QUIET
   ;C:SetPatch QUIET
;ELSE
   ;C:SetPatch SKIPROMUPDATES "scsi.device" QUIET
EndIF
Unset SCSIUpdate
;End OS3.9 Checks

C:GetMouseInput LOCAL

IF $MouseInput EQ 1
  Unset MouseInput
  C:Assign >NIL: ENV: RAM:
  C:Assign >NIL: T: RAM:
  C:Execute S:Maxmem-Sequence
  EndCLI >NIL:
EndIF

IF $MouseInput EQ 2
  Unset MouseInput
  C:Execute S:Bootmenu-Sequence
  EndCLI >NIL:
EndIF

Unset MouseInput

IF EXISTS C:StackAttack
  C:StackAttack
EndIF

C:Version >NIL:
FailAt 21

IF EXISTS SYS:WBstartupD
  C:Rename >NIL: SYS:WBStartup SYS:WBStartupM
  C:Rename >NIL: SYS:WBStartupD SYS:WBStartup
EndIF

Resident >NIL: C:IconX PURE
Resident >NIL: C:WBRun PURE
Resident >NIL: C:Assign PURE
Resident >NIL: C:Execute PURE
Resident >NIL: C:SetEnv PURE REPLACE

IF EXISTS L:env-handler
  C:MakeDir RAM:T RAM:Clipboards
  L:env-handler
ELSE
  C:MakeDir RAM:T RAM:Clipboards RAM:ENV RAM:ENV/Sys
  C:Copy >NIL: ENVARC: RAM:ENV ALL NOREQ
  Assign >NIL: ENV: RAM:ENV
EndIF

IF EXISTS C:PatchRAM
  C:PatchRAM
EndIF

IF EXISTS C:TagLiFE
  C:TagLiFE
EndIF

Assign >NIL: T: RAM:T
Assign >NIL: CLIPS: RAM:Clipboards
Assign >NIL: REXX: S:
Assign >NIL: PRINTERS: DEVS:Printers
Assign >NIL: KEYMAPS: DEVS:Keymaps
Assign >NIL: LOCALE: SYS:Locale
Assign >NIL: LIBS: SYS:Classes ADD
Assign >NIL: HELP: LOCALE:Help DEFER

C:CPU60 B >NIL:
RUN >NIL: CopyMem060

IF EXISTS C:BlazeWCP
  C:BlazeWCP
EndIF

IF EXISTS SYS:System/FBlit/FBlit
  SYS:System/FBlit/FBlit
  SYS:System/FBlit/FText
EndIF

BindDrivers
C:Mount >NIL: DEVS:DOSDrivers/~(#?.info)

C:LoadMonDrvs

SetEnv Language "english"
SetEnv Workbench $Workbench
SetEnv Kickstart $Kickstart
UnSet Workbench
UnSet Kickstart

IF EXISTS C:CyberBugFix
  C:CyberBugFix
EndIF

IF EXISTS C:IconBeFast
  C:IconBeFast 0
EndIF

C:AddDataTypes REFRESH QUIET
IF EXISTS SYS:System/VPrefs/VisualPrefs
  Run > NIL: SYS:System/VPrefs/VisualPrefs
EndIF
C:IPrefs
SYS:System/FPalette/FPPrefs
C:ConClip

Path >NIL: RAM: C: SYS:Utilities SYS:Rexxc SYS:System S: SYS:Prefs SYS:WBStartup SYS:Tools SYS:Tools/Commodities

SYS:System/REXXMast >NIL:

IF EXISTS S:User-Startup
  Execute S:User-Startup
EndIF

Resident Execute REMOVE
Resident Assign REMOVE

IF EXISTS C:StackAttack
  C:StackAttack AUTO
EndIF

C:LoadWB

EndCLI >NIL:
hardgb is offline  
Old 24 July 2018, 15:48   #6
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,391
Quote:
Originally Posted by hardgb View Post
Note: Forgive me my English, it is horrible
Your english is ok but your S-S is horrible. If you changed it you should know what/how it works.
daxb is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
ShapeShifter Doc Mindie support.Apps 23 21 March 2018 18:41
ShapeShifter Help coope1999 support.Apps 17 21 July 2015 08:18
Shapeshifter help! (Again?) watertonian support.Apps 18 27 May 2010 19:03
ShapeShifter 3.10 Flashlab request.Apps 0 11 June 2007 22:27
Shapeshifter dkovacs support.Apps 12 25 January 2006 02:25

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:42.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.06342 seconds with 13 queries