English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 27 July 2018, 04:38   #121
Ferry
Registered User

Ferry's Avatar
 
Join Date: Jul 2018
Location: Spain
Posts: 14
Well, I received my new A1200 keyboard membrane just yesterday, and today I had the time to try my crazy experiment.

I bought it advised by another Amiga user and friend, Fireboy, that also bought a membrane for his Vampirized A600. But since he's always trying new hardware, his keyboard is detached and reattached every now and then, and his keyboard connector got worn out very quickly. Of course I didn't want mine to happen the same, so I thought about a possible solution: to use aluminium foil to cover connector pins, so it's the aluminium that receives the pressure and the wear-out, not the connector. Aluminium is so tough that it would be possible that the wear-out would never prevent the keyboard to function, and in any case you could always replace the covering.

The domestic one, even if it is conductive, doesn't work because there's no (cheap) way to stick it on, but there's one alternative: the adhesive aluminium foil in rolls used in air conditioner installations.

The problem with this one is that while one of the sides is conductive, the adhesive one is not, but is very easy to rub the adhesive away with alcohol (preferably isopropyl).

So I have tried today, and IT WORKS!

If you want to try it too, you will need:

-Roll of adhesive aluminium foil, 5 cm wide
-Watchmaker tweezers
-Watchmaker magnifying glass or lamp with magnifying glass (I used something like this one: https://i.imgur.com/QjchY2L.jpg)
-Scissors
-Preferably, paper cutter. I used this kind: https://i.imgur.com/HNJMZ1j.jpg, the better the easier.
-Alcohol, preferably isopropyl (no residues)
-Cotton buds
-Multimeter
-Patience…

1. Cut a square piece of aluminium foil wider than the keyboard ribbon.

2. Cut the back paper at the middle of the piece, so a strip of 6 mm wide of the adhesive side gets exposed:





3. Rub the exposed adhesive with a cotton bud soaked in alcohol. You'll notice you are taking the adhesive out because the color will change from matte to brilliant:



4. Cover again the rubbed area with the white back.

5. Cut strips like 0'8 mm wide, with the rubbed part in the middle. You will need 31 strips, but cut some more, just in case.





6. Start sticking strips in place, connector by connector, starting in the back of the KB ribbon and adjusting the start of the rubbed part with the end of the ribbon, so when you turn it around the rubbed part covers the connector pin. Double check that one strip does not touch the previous one.

(NOTE: I have found that you can flatten a strip out, make them smoother by running a nail over it)



7. One thing you MUST CHECK with the multimeter is that two contiguous strips don't make contact, and you must check ALL STRIPS for this.

8. You can also check if the aluminium cover really works: follow the track of the contact you just covered with aluminium and find the first key contact in the keyboard corresponding to that track, and check continuity with the multimeter:



Of course, to follow every single track for 31 connectors is a really painstaking work, so you can check only some of them, f.ex., the ones that have their corresponding key connectors near.

9. Once finished, the ribbon should look something like this:

Back:

Front:

Of course, with a better paper cutter the strips would have been more even, more uniform.

10. Put the membrane back in place inside the keyboard (of course if, like me, you have been working on the membrane itself.)

11. Connecting the KB back to the motherboard: insert the ribbon into the connector latch.

12. Insert the ribbon into the motherboard connector itself. It should slide smoothly into it, despite being a bit thicker.

13. Close the latch. Here you will notice the extra thickness, you will have to apply a bit more pressure than usual.

Done!

One more advantage is that if one strip gets broken, whatever the reason, it should be easily replaceable.

Well, I have my new membrane protected, my keyboard working and I cannot imagine any drawback with this method that could hurt the membrane or harm in any way the computer. If you know any, just share it.

I hope you find this useful.

Saluditos,

Ferrán.

PD: I've put this post also as an independent new post in the support.Hardware forum.

Last edited by Ferry; 27 July 2018 at 04:51.
Ferry is offline  
Old 03 August 2018, 14:13   #122
sneckburger
Registered User

 
Join Date: Apr 2018
Location: Wakefield
Posts: 139
I did something similar with this https://www.halfords.com/motoring/pa...-heater-repair.
I Painted the whole damaged area and scratched the gaps back using a steel rule and a pointy tool (not too sharp). This was much easier than trying to paint the lines neat enough not to bridge tracks.
The results worked perfectly. Though I didn't need to paint the contacts that connect to the motherboard.
I also covered the ribbon with decorators "Frog" tape (what I had to hand, but I suppose any insulation tape would do) just to stop the paint from rubbing off when opening closing the case.

Last edited by sneckburger; 03 August 2018 at 14:18.
sneckburger is offline  
Old 21 October 2018, 02:24   #123
FLiP79
Registered User

FLiP79's Avatar
 
Join Date: Oct 2018
Location: Turin, Italy
Posts: 12
Hi, I want to share my experience: after reading the whole topic I tried with my A1200 that had about 70% of keys not working: it was enough to cut about 1mm of ribbon cable to get the whole keyboard work again, including the caps lock light
FLiP79 is offline  
Old 07 November 2018, 16:15   #124
supaduper
Registered User
supaduper's Avatar
 
Join Date: Oct 2012
Location: Birmingham UK
Posts: 886
Just want to add to this thread as it is all about our K/boards problems

So I just recieved a A1200 K/board and the contacts looked great puts it in a A1200 mobo which I have not used for a long time and one row was not working so did the `1 mill cut off the bottom of the connector ..still no good..Hmmm

So i thought oh no its a track on the mobo as one row was not working or the chip had gone, anyways had a sit and just had a thought I had not used the Motherboard in years and checked the Connecter on the board and it did look to be oxidized !,

so I sprayed it with a copious amount of alchol and used a new cardboard Taxi credit card sized ad and cut it to the exact length of the slot then pinched it with the locking clip and pushed it in and out a few times ...and hey presto she`s all working..so something else to think about guys
supaduper is offline  
Old 12 February 2019, 18:55   #125
Torti-the-Smurf
Registered User

Torti-the-Smurf's Avatar
 
Join Date: Dec 2018
Location: Earth
Posts: 34
Most of my A600 Key´s did not work. (maybe 10% did work)
I tried 2 Motherboards. Same result on both.

Not sweet at all
I thought i need a new Membrane/Ribon cable.

But then i took a very sharp Scissor and i cut 1mm of the Ribbon Cable´s End.

Result is that all Keys are working now.

Smurftastic

PS: Funny, Flip79 and i had the same idea

Last edited by Torti-the-Smurf; 13 February 2019 at 10:59.
Torti-the-Smurf is offline  
Old 17 April 2019, 14:43   #126
fpmpaolo
Registered User
fpmpaolo's Avatar
 
Join Date: Aug 2014
Location: Bologna / italy
Age: 39
Posts: 116
Quote:
Originally Posted by Ferry View Post

The domestic one, even if it is conductive, doesn't work because there's no (cheap) way to stick it on, but there's one alternative: the adhesive aluminium foil in rolls used in air conditioner installations.
Congrats for a hell of a job!
What about copper bihadesive tape?
Is it too heavy? Could it damage the motherboard?
fpmpaolo is offline  
Old 29 July 2019, 10:19   #127
Turrican_3
Registered User

Turrican_3's Avatar
 
Join Date: Jul 2017
Location: Italy
Posts: 143
Just for the record (this could very well be a NOT recommended procedure), I was able to fix an A1200 keyboard flat cable that I had accidentally damaged by peeling off ~1.5 cm of the green cover layer.

Since the normally exposed part was already partly destroyed (again, my fault) I decided to cut it off completely, then the remaining part - after the peeling treatment - just slid into the keyboard connector on the motherboard and everything started working again flawlessly.

I have no idea how much this is going to last, but considering this A1200 restoration is now complete I hope fiddling with the flat cable as little as possible *might* prove effective.

Feel free to tell me whether I did an utterly stupid thing or not by the way.
(it's not like I had so many options available to be honest... it was either this, or keeping a non-working keyboard, so I said to myself "ok, there's probably nothing to lose")
Turrican_3 is offline  
Old 14 August 2019, 05:35   #128
RenderEng
Registered User
 
Join Date: Jul 2019
Location: Vancouver/Canada
Posts: 7
I fixed mine with a graphite pencil. The column for the P letter was not working, cleaning the ribbon cable didn't work, so I gently scratched the contacts in the ribbon cable with the pencil and it worked. Also I disassembled the keyboard and used the pencil in all key contacts.
RenderEng is offline  
Old 15 October 2019, 20:04   #129
DrFruit
Resident Nutter...

 
Join Date: Oct 2019
Location: Norfolk, UK
Age: 42
Posts: 60
Mines started to play up on certain keys, but then work again when i move the ribbon about a little. Can you not just use rubbing alcohol on the existing contacts?

Cheers,
DrFruit is offline  
Old 14 November 2019, 11:23   #130
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 616
I hate the ribbon connector on the A600 and A1200. I think it is the cause of a lot of the damage to the ends of the ribbon cable as it is not easy to release and most people end up just pulling the ribbon cable out with the connector pushed down.

I use a simple ribbon-saver mod to allow me to easily release the connector before pulling out the ribbon cable:



You still need to be careful and not to pull too hard as you might break the connector.
solarmon is offline  
Old 14 November 2019, 14:51   #131
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 39
Posts: 7,449
My solution is to leave the top shield out and throw it away. This way it's easy to undo the clip with my fingers.
Jope is offline  
Old 14 November 2019, 15:00   #132
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 616
Quote:
Originally Posted by Jope View Post
My solution is to leave the top shield out and throw it away. This way it's easy to undo the clip with my fingers.
Yes, that will help. But it can still be a bit fiddly - especially on the A600 with the floppy power connector next to it.
solarmon is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
A600 Keyboard LEDS cable Supamax support.Hardware 17 30 June 2016 23:53
Want to Buy - A600 Keyboard (Blue cable type) kipper2k MarketPlace 4 21 April 2012 20:00
A600 Keyboard Problem. Melonfish support.Hardware 11 02 April 2010 19:45
A600 keyboard problem Predseda support.Hardware 3 21 October 2007 00:10
A600 keyboard problem Jope support.Hardware 11 16 July 2006 21:55

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:14.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.08117 seconds with 16 queries