English Amiga Board


Go Back   English Amiga Board > abime.net - Hosted Projects > project.ClassicWB

 
 
Thread Tools
Old 04 April 2006, 11:50   #1
rare_j
Zone Friend

rare_j's Avatar
 
Join Date: Apr 2005
Location: London
Posts: 1,009
ClassicWB with systempatch

I installed the latest version of systempatch2 to classicWB and some strange things happened -

1. When opening lha files in voodoox a black screen popped up with an orange flashing box telling me Xvs.Library is corrupted or hacked or something

2. So I started janoeditor to remove the patch fron the user startup the amiga did a guru. In the end I had to use ed which wasn't pleasant. Then all was back to normal.


Is there some option I should have specified to systempatch or should I not use systempatch at all with scalos?
rare_j is offline  
Old 04 April 2006, 15:08   #2
mr_a500
Amiga-based Cyborg
mr_a500's Avatar
 
Join Date: Dec 2004
Location: Canada
Posts: 807
This latest version of SystemPatch (2.96) has problems with xvs.library. I sent an email to the program's author the day this new version was released explaining this problem, but he hasn't replied.

You can either do without SystemPatch or use version 2.95.
mr_a500 is offline  
Old 04 April 2006, 17:36   #3
rare_j
Zone Friend

rare_j's Avatar
 
Join Date: Apr 2005
Location: London
Posts: 1,009
I tried the 2.95a version with the NOEXEC option. It works much better now.
rare_j is offline  
Old 04 April 2006, 17:56   #4
mr_a500
Amiga-based Cyborg
mr_a500's Avatar
 
Join Date: Dec 2004
Location: Canada
Posts: 807
I suggest you also use the NOINTUITION option. Otherwise you'll have problems with programs using custom file requesters - like DigiPaint3, DSS, PageRender.
mr_a500 is offline  
Old 04 April 2006, 18:36   #5
rare_j
Zone Friend

rare_j's Avatar
 
Join Date: Apr 2005
Location: London
Posts: 1,009
I wondered why that was in there by default. Thanks, I put it back in just in case.
rare_j is offline  
Old 04 April 2006, 19:13   #6
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,770
Yes, SystemPatch 2.96 has indeed a problem with the new
LoadSeg() patch for dos.library, which causes the error with
xvs.library. I've already reported this to the author Sante, but
no reply and no changes of SystemPatch yet
For my own system with WinUAE and P96, I switched back to
version 2.95a again calling it with these options:
SystemPatch >NIL: NOLAYERS -BltClear

If you want to use v2.96, then add the NoDOS option to fix the bug.
Unfortunately, that would disable the faster file access, too.
PeterK is offline  
Old 04 April 2006, 22:36   #7
mr_a500
Amiga-based Cyborg
mr_a500's Avatar
 
Join Date: Dec 2004
Location: Canada
Posts: 807
Quote:
I wondered why that was in there by default. Thanks, I put it back in just in case.
What? The NOINTUITION option is in the ClassicWB startup-sequence? I don't use the ClassicWB packs, just my own setup on my A500. Even Sante couldn't help me fix the Digipaint 3 and DSS file requester problems. I had to find that out with lots of tedious testing. Gee - I could have just looked at the ClassicWB setup.

Last edited by mr_a500; 04 April 2006 at 22:42.
mr_a500 is offline  
Old 05 April 2006, 00:34   #8
rare_j
Zone Friend

rare_j's Avatar
 
Join Date: Apr 2005
Location: London
Posts: 1,009
Systempatch isnt part of classicwb as far as I know, that's why I was adding it myself. The systempatch installation script adds the NOINTUITION switch to user-startup by default, without any explaination in the docs. I took it out but you gave me a good reason to leave that switch in.
rare_j is offline  
Old 05 April 2006, 00:51   #9
mr_a500
Amiga-based Cyborg
mr_a500's Avatar
 
Join Date: Dec 2004
Location: Canada
Posts: 807
Ah ha! I've just been copying over the new versions of SystemPatch without using the installer. Maybe Sante put that in as default after my problems and forgot to tell me.
mr_a500 is offline  
Old 08 April 2006, 15:17   #10
Bloodwych
Moderator

Bloodwych's Avatar
 
Join Date: Jun 2001
Location: I'm behind you!
Posts: 3,763
Scalos, being a workbench replacement, has many performance patches already included. What is so good about SystemPatch?

It seems to cause more issues than perceivable benefits? Or am I being ignorant since I haven't truly tested it. Let me know peeps just what benefits you notice after installing this patch!

Last edited by Bloodwych; 08 April 2006 at 19:06.
Bloodwych is offline  
Old 10 April 2006, 14:25   #11
rare_j
Zone Friend

rare_j's Avatar
 
Join Date: Apr 2005
Location: London
Posts: 1,009
As far as I can tell it patches some system libraries for better performance and perhaps some chipram savings. I don't know if the patches in systempatch overlap with the stuff Scalos does.
rare_j is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
SystemPatch 3.1 ziosante News 32 30 August 2018 14:08
SystemPatch 3.x tolkien request.Apps 2 02 April 2013 00:03
SystemPatch 3.3 Leandro Jardim request.Apps 2 22 May 2010 03:56
SystemPatch 3.0 ziosante News 11 02 January 2008 00:50
New release of SystemPatch! Paul News 0 04 January 2005 12:59

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:09.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.07994 seconds with 15 queries