English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 23 February 2011, 22:15   #1
ceedy
Old-Amiga-Git
ceedy's Avatar
 
Join Date: Feb 2011
Location: Somerset , in the UK
Posts: 175
Did the 500+ battery forgot the 501's

Suddenly remembered the 2 501's lying in the box ..after the mess left by the 500plus battery.

Ripped them apart. well carefully .

and found this ..



the bat on the left looked the worst all furry and horrid .
and the one one the right looked ok apart from a bit of rust ...
but look at the mess its left all round the board.
its leeched all round under the laquer on the Ground plane mostly .. yuk..

We will see if they still live ??
C.
ceedy is offline  
Old 24 February 2011, 03:47   #2
rkauer
I hate potatos and shirts
rkauer's Avatar
 
Join Date: Oct 2007
Location: Sao Leopoldo / Brazil
Age: 53
Posts: 3,482
Send a message via MSN to rkauer Send a message via Yahoo to rkauer
Probably both will be OK. Do the neutralizing+cleaning routine, let the boards dry up, add (or not) a proper CR3025 holder + diode instead the barrel battery and apply nail varnish over the affected area after all checked & proven working.
rkauer is offline  
Old 24 February 2011, 11:45   #3
ceedy
Old-Amiga-Git
ceedy's Avatar
 
Join Date: Feb 2011
Location: Somerset , in the UK
Posts: 175
Both work ok .. will do the same as I did on the Plus

a Coin holder and rechargable..

Just found another, a fluffy battery but hardly any corrosion. will still clean/ lemon flavour and revarnish.

C....
ceedy is offline  
Old 25 February 2011, 02:41   #4
8bitbubsy
Registered User

8bitbubsy's Avatar
 
Join Date: Sep 2009
Location: Norway
Posts: 1,309

Why did you not write "WARNING: Grotesque torture pictures" in the topic title?
I almost got a heart attack when I saw the card to the right... It's a fortune the damage only ate the clock area of the board.
8bitbubsy is offline  
Old 25 February 2011, 20:18   #5
ceedy
Old-Amiga-Git
ceedy's Avatar
 
Join Date: Feb 2011
Location: Somerset , in the UK
Posts: 175
Quote:
Originally Posted by 8bitbubsy View Post

Why did you not write "WARNING: Grotesque torture pictures" in the topic title?
I almost got a heart attack when I saw the card to the right... It's a fortune the damage only ate the clock area of the board.

It was just as bad on the reverse side..

But no tracks were lost and this afternoon they all got laquered and new coin battery holders..

and they all work perfectly despite the looks ...
ceedy is offline  
Old 25 February 2011, 23:43   #6
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,300
Quote:
Originally Posted by ceedy View Post
It was just as bad on the reverse side..

But no tracks were lost and this afternoon they all got laquered and new coin battery holders..

and they all work perfectly despite the looks ...
An extremely fortunate example of "Just In Time" Amiga kit resurrection there, Chris!
prowler is offline  
Old 26 February 2011, 12:24   #7
ceedy
Old-Amiga-Git
ceedy's Avatar
 
Join Date: Feb 2011
Location: Somerset , in the UK
Posts: 175
Quote:
Originally Posted by prowler View Post
An extremely fortunate example of "Just In Time" Amiga kit resurrection there, Chris!

yup

Once I get my rechargable 2032's I can solder the cases back on and hide all the nasty looking hhistory

Now it on to CAP's PSU's and the 20 odd Spectrums I have to sort out

And my lil bag of CF adaptors has turned up from HK today ! so more to do!

Take my word for it Even tho' I'm slightly retired there's never enough time to do stuff !!

C.
ceedy is offline  
Old 27 February 2011, 02:49   #8
rkauer
I hate potatos and shirts
rkauer's Avatar
 
Join Date: Oct 2007
Location: Sao Leopoldo / Brazil
Age: 53
Posts: 3,482
Send a message via MSN to rkauer Send a message via Yahoo to rkauer
They will work OK after a bit of TLC.
rkauer is offline  
Old 27 February 2011, 16:29   #9
ElectroBlaster
Junior Member
ElectroBlaster's Avatar
 
Join Date: Mar 2002
Location: Exeter, Devon, UK
Age: 45
Posts: 1,491
Send a message via ICQ to ElectroBlaster
Ive got one of those boards like the left one. All the chips are socketed. I removed the nasty old battery and thankfully the damage was very small, hardly anything to write home about. But afaik it didnt work when I tested it... this was years ago when I aquired 20 odd a500's that needed sorting out.
I wonder if its worth saving?
ElectroBlaster is offline  
Old 27 February 2011, 22:07   #10
orange
Registered User
orange's Avatar
 
Join Date: Apr 2007
Location: Belgrade
Posts: 567
@electroblaster
I got the same board and same problem. thinking about socketing the chips, but can't help wondering if its worth the effort.
there must be a way to test individual chips.
for eg, one zx repair manual says resistance across voltage supply and GND pins should be over some value
orange is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant believe I forgot about my 500+ :) wood-chris Member Introductions 26 25 February 2011 11:00
500 plus battery replacement ceedy Hardware mods 10 24 February 2011 10:35
Need Help! Forgot Name Of Game amigamenough Looking for a game name ? 4 26 January 2009 02:55
Amiga 500 Plus Battery Removal Kristian support.Hardware 2 09 May 2004 15:42
Amiga 501? Mr Softy Amiga scene 4 04 March 2003 12:27

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:20.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.07216 seconds with 13 queries