English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 08 September 2019, 00:28   #1
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 43
Posts: 3,584
z-out display problem

hi toni,
there is a problem with z-out,
launch the game with winuae 4.2.1, wait for the game.
It's directly there.
i tested with winuae 4.2.0 beta 7 29.03.2019, this is the less older one i tsill have, the display is normal !
edited : the problem began with 4.2.1 beta 5, the beta 4 display it correctly.
2 screenshots joined
It looks like if some lines has moved horiz left or right, but just by one pixel... The game itself works well.
If you need something more ??

edited : 1st screenshot 4.2.1 final (wrong pixel alignement) , 2nd 4.2.0 beta 7 (good) , 3rd 4.2.1 final (default config, no resize) bottom missing and wrong pixel alignement.

I used win7, winuae quickstart a500, Z-Out (1991)(Rainbow Arts)[0609], default winuae config. same result with d3d9-11 or ddraw
ps: i just set resize because if i don't i lost a part of the screen at the bottom (3rd screenshot added) It did it with the 2 winuae version.
ps2: tested winth winuae 2.4.1, i still miss the bottom screen, but i think it comes from my computer because i never noticed it earlier, anyway, it's easy to correct. The real problem are the lines badly aligned
edited : i must add that the problem occur with every versions whdload sps adf...
Attached Thumbnails
Click image for larger version

Name:	Z-Out_007.png
Views:	110
Size:	11.0 KB
ID:	64376   Click image for larger version

Name:	Z-Out_006.png
Views:	121
Size:	10.8 KB
ID:	64377   Click image for larger version

Name:	Z-Out_008.png
Views:	107
Size:	8.8 KB
ID:	64378  

Last edited by turrican3; 08 September 2019 at 02:04.
turrican3 is offline  
Old 08 September 2019, 09:14   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,136
Try switching OCS/ECS. I think this game has ECS compatibility problem.
Toni Wilen is online now  
Old 09 September 2019, 00:43   #3
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 43
Posts: 3,584
thanks for the answer,

your proposal didn't do the trick,
it really began with 4.2.1 beta 5 before this beta , no problem.
It works well with 4.2.1 beta 4.
turrican3 is offline  
Old 12 September 2019, 13:36   #4
Zarnal
Registered User

 
Join Date: Feb 2018
Location: France
Posts: 49
Hello,

Do you activate any filters ? Because i've tried Z-Out with A500/WinUae 4.2.1 config without filtering. No particular issue (see picture).
Attached Thumbnails
Click image for larger version

Name:	Image3.jpg
Views:	47
Size:	201.1 KB
ID:	64443  
Zarnal is offline  
Old 12 September 2019, 15:19   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,136
Ah, it is that one which needs some specific scaling option and only happens in few "special cases".

Was already fixed soon after 4.2.1 was out (but there is no official update yet)
Toni Wilen is online now  
Old 13 September 2019, 01:03   #6
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 43
Posts: 3,584
i see, avery special case then.
where do we have to look for the next beta ?
when it will be available.
turrican3 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Display in OS 3.9 videofx support.Apps 4 24 July 2013 18:45
Display Problem ABKStorm support.WinUAE 0 25 September 2010 05:19
display problem! help please! Gordon support.Hardware 3 06 September 2009 22:09
Display problem abelthorne support.WinUAE 1 25 November 2003 13:25
Problem with screen display. KidCanary support.WinUAE 3 02 December 2002 01:53

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:34.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.06743 seconds with 16 queries