English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 25 December 2008, 22:31   #1
Another World
 
Posts: n/a
Hooooo CD32 graphic problem

These are two screenshots which shows a graphic problem of CD32 emulation

Any idea how to fix this ?

Last edited by Another World; 02 January 2009 at 09:43.
 
Old 25 December 2008, 22:33   #2
Shoonay
Global Caturator
Shoonay's Avatar
 
Join Date: Aug 2004
Location: Porando
Posts: 6,057
Turn off scanlines?
Shoonay is offline  
Old 25 December 2008, 22:34   #3
TCD
Registered User

TCD's Avatar
 
Join Date: Sep 2006
Location: Germany
Age: 42
Posts: 24,024
Have you enabled 'Correct Aspect Ratio' Another World? With 640x400 this can cause these funny lines

Edit : Oh or what Shoonay said
TCD is offline  
Old 26 December 2008, 00:21   #4
TCD
Registered User

TCD's Avatar
 
Join Date: Sep 2006
Location: Germany
Age: 42
Posts: 24,024
Try it in windowed mode with 640x512 and tell us if the problemis still there.
TCD is offline  
Old 26 December 2008, 00:29   #5
Another World
 
Posts: n/a
Something tell me that answer is ..... yes !

Last edited by Another World; 02 January 2009 at 09:42.
 
Old 26 December 2008, 00:31   #6
Shoonay
Global Caturator
Shoonay's Avatar
 
Join Date: Aug 2004
Location: Porando
Posts: 6,057
And now the scanlines, please, I beg you!
For the love of Amiga games!!!
Shoonay is offline  
Old 26 December 2008, 00:38   #7
Ian
Global Moderator

Ian's Avatar
 
Join Date: May 2001
Location: Derby, UK
Age: 42
Posts: 2,238
I think they are using an interlaced mode to display those images. Don't know why it doesn't display properly but it's always been like that.
Ian is offline  
Old 26 December 2008, 00:39   #8
TCD
Registered User

TCD's Avatar
 
Join Date: Sep 2006
Location: Germany
Age: 42
Posts: 24,024
If you select 'normal' instead of 'double' line mode it's okay. Guess it's some interlace effect. Maybe Toni can have a look what's wrong there with the double line mode
TCD is offline  
Old 26 December 2008, 00:45   #9
Another World
 
Posts: n/a
Also i try scanlines ON, this is the result

Last edited by Another World; 02 January 2009 at 09:42.
 
Old 26 December 2008, 00:47   #10
TCD
Registered User

TCD's Avatar
 
Join Date: Sep 2006
Location: Germany
Age: 42
Posts: 24,024
Quote:
Originally Posted by Another World View Post
Also i try scanlines ON, this is the result
Shoonay was joking Yes it's only this one screen so we can live with that, but a 'fix' would be nice of course.
TCD is offline  
Old 26 December 2008, 09:57   #11
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 23,954
First, what does this have to do with CD32?

I don't see any program names either. (yes, I see screenshots but as usual I am not going to test some random version that is supposed to be the same one as here..)

Please try again

EDIT: can't see anything wrong, tested with some random interlaced image.

Last edited by Toni Wilen; 26 December 2008 at 10:24.
Toni Wilen is offline  
Old 26 December 2008, 10:26   #12
TCD
Registered User

TCD's Avatar
 
Join Date: Sep 2006
Location: Germany
Age: 42
Posts: 24,024
Quote:
Originally Posted by Toni Wilen View Post
First, what does this have to do with CD32?

I don't see any program names either. (yes, I see screenshots but as usual I am not going to test some random version that is supposed to be the same one as here..)

Please try again
Okay Toni
I use this version : Pinball Fantasies (1993)(21st Century)[!] (for CD32)
Problem only occurs on the title screen when Line Mode is set to 'Double'.
TCD is offline  
Old 06 January 2009, 14:23   #13
Another World
 
Posts: n/a
Quote:
Originally Posted by Toni Wilen View Post
First, what does this have to do with CD32?
You are right Toni

It's an AGA graphic problem really

This is another proof of the same problem:
a title screen that in double line mode is bad drawn, only normal mode works

Last edited by Another World; 21 January 2009 at 14:39.
 
Old 06 January 2009, 16:14   #14
Ian
Global Moderator

Ian's Avatar
 
Join Date: May 2001
Location: Derby, UK
Age: 42
Posts: 2,238
Well if you use the example of Pinball fantasies CD32 I think it doesn't display all the image, it displays every other line like double mode just without the gap. There is stuff missing in the CD32 image that I am positive they didn't leave off.

Maybe someone with the real thing can check. It's been several years since I played the game on a real CD32 so maybe it's also missing there too.

If you look at the part it says "Edition" all the letters are missing the top line.
Attached Thumbnails
Click image for larger version

Name:	001.png
Views:	194
Size:	12.8 KB
ID:	19608  
Ian is offline  
Old 06 January 2009, 16:50   #15
Another World
 
Posts: n/a
Quote:
Originally Posted by Ian View Post
Well if you use the example of Pinball fantasies CD32 I think it doesn't display all the image, it displays every other line like double mode just without the gap. There is stuff missing in the CD32 image that I am positive they didn't leave off.

Maybe someone with the real thing can check. It's been several years since I played the game on a real CD32 so maybe it's also missing there too.

If you look at the part it says "Edition" all the letters are missing the top line.
CD32 isn't the problem (i know, thread name should be changed)

Egg Salad is a normal adf image of a floppy AGA game
 
Old 06 January 2009, 16:55   #16
Ian
Global Moderator

Ian's Avatar
 
Join Date: May 2001
Location: Derby, UK
Age: 42
Posts: 2,238
I know it's a general problem, it's just easier so someone to check that than anything else as there is clearly something that you can see is missing.

If the letters are fully visible "on the real thing" there is an emulation problem with high res/interlaced images.
Ian is offline  
Old 06 January 2009, 16:59   #17
Another World
 
Posts: n/a
Quote:
Originally Posted by Ian View Post
I know it's a general problem, it's just easier so someone to check that than anything else as there is clearly something that you can see is missing.

If the letters are fully visible "on the real thing" there is an emulation problem with high res/interlaced images.
Sadly, i don't have real Miggy to try the adf image
 
Old 06 January 2009, 18:20   #18
robotriot
Tubby mechanical friend
robotriot's Avatar
 
Join Date: Jun 2004
Location: Regensburg / Germany
Posts: 107
Send a message via ICQ to robotriot
I made a photo of Pinball Fantasies running on a real CD32, it has the same "bug."
Attached Thumbnails
Click image for larger version

Name:	pinfant.jpg
Views:	180
Size:	148.4 KB
ID:	19615  
robotriot is offline  
Old 06 January 2009, 18:27   #19
Ian
Global Moderator

Ian's Avatar
 
Join Date: May 2001
Location: Derby, UK
Age: 42
Posts: 2,238
So it does, thanks.

So the only problem then is that WinUAE is adding a blank line in with double mode enabled on certain interlaced images.
Ian is offline  
Old 06 January 2009, 18:31   #20
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 48
Posts: 12,006
But i can't see any problems in Egg Salad, look fine.
Attached Thumbnails
Click image for larger version

Name:	egg_salad_(19xx)(quartz_pd)(pd)[amos]-amiga_001.png
Views:	160
Size:	23.9 KB
ID:	19619  
Retro-Nerd is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
(CD32 + AGA) Heimdall 2 graphic glitches predcon support.WinUAE 11 26 November 2014 16:14
Strange graphic effect with CD32 demodisc 2.0 a4k-oerx support.WinUAE 2 24 November 2008 19:00
Problem with graphic display in WinUAE.... nikvest support.WinUAE 9 28 October 2007 12:20
Graphic Problem with all winuae editions srnickolas support.WinUAE 6 01 October 2007 12:14
Amiga 1200 Graphic problem BobRedthorp support.Hardware 21 06 March 2004 08:14

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:56.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.09418 seconds with 16 queries