English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 04 February 2007, 22:45   #1
ag_woodward
Registered User
 
Join Date: Jan 2007
Location: Accrington/Lancashire
Posts: 26
A4000D Keyboard Problem

Hope someone may have experienced this.

I have an A4000D (T version still on its way from the US). The keyboard is fully operational except the space bar.

I assumed it needed cleaning so disassembled the whole thing....rediculous number of screws! and cleaned it - even swapped the help key with the space bar in case faulty contactor.

No joy - still no space bar, yet every other key def works.

Any ideas?

Thanks
Andrew
ag_woodward is offline  
AdSense AdSense  
Old 05 February 2007, 09:17   #2
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 37
Posts: 6,360
Send a message via Skype™ to Jope
Use a multimeter to trace the spacebar contacts all the way to the keyboard controller. Perhaps there's a broken diode on the way.. If both contacts conduct all the way to the controller, then the controller is probably your suspect.
Jope is offline  
Old 12 February 2007, 23:36   #3
ag_woodward
Registered User
 
Join Date: Jan 2007
Location: Accrington/Lancashire
Posts: 26
Hi - just an update

Turned out to be either a trace or the carbon pad was faulty. To fix it, I soldered a wire direct to the ribbon connector of the PCB (tracing the pad back to the relevant pin) and then splayed/flattened the other end of the wire and tinned it - then cellotaped it to the original location of the faulty pad.

A working space bar....without parting with 40 on Ebay for a new keyboard!
ag_woodward is offline  
Old 13 February 2007, 07:35   #4
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 37
Posts: 6,360
Send a message via Skype™ to Jope
Great!
Jope is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with my keyboard ! Mazout support.WinFellow 6 23 October 2014 12:15
Wanted: Keyboard for A4000D with US or UK layout stachu100 MarketPlace 0 29 July 2010 15:07
A4000D power light problem. THX1138 support.Hardware 4 20 April 2008 22:22
Keyboard problem AndyDE support.WinUAE 9 25 June 2004 13:25
Keyboard problem nethermancer support.WinUAE 0 29 September 2002 21:11

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 03:53.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.17569 seconds with 14 queries