English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 25 July 2018, 23:28   #1
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 42
Posts: 1,102
NetInfo II (Vapor) not working anymore?

Just tried again after a long time the app NetInfo from Vapor and noticed is unable to Traceroute again as it did in the good old days…
I have Netinfo-II 2.11 (22.12.2001)
There was some hardcoded host not working anymore for this service now, or is it a problem under WinUAE? Yes I understand it's quite old… but everything else from Vapor suite seems to work fine… so I'm just asking

http://aminet.net/package/comm/tcp/netinfo

Last edited by hexaae; 26 July 2018 at 10:31.
hexaae is offline  
Old 16 August 2018, 12:28   #2
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 42
Posts: 1,102
Please, can someone kindly test this (if it's working for you the traceroute function…)?
hexaae is offline  
Old 16 August 2018, 13:57   #3
jPV
Registered User
jPV's Avatar
 
Join Date: Feb 2008
Location: RNO
Posts: 599
Works here under MorphOS at least. So there shouldn't be nothing outdated in the program itself.
jPV is offline  
Old 16 August 2018, 15:59   #4
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,360
I can certainly imagine that it doesn't work with bsdsocket.library emulation in UAE, since you are then not running a TCP stack on the Amiga, and the host OS will "eat" those ICMP packets anyways.

Anything else than simple TCP, I would expect to fail with bsdsocket.library emulation.
kolla is offline  
Old 17 August 2018, 01:11   #5
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 42
Posts: 1,102
Thank you all.

@Kolla
So do you think it's a limitation in using emulated bsdoscket.library itself? Mmh...

EDIT:
You're right: resumed my old MiamiDx stack, reconfigured for uaenet.device, and also NetInfo II is working fine again!

EDIT2:
From NetInfoII docs indeed it's written:

NetInfo works with Genesis, Miami and AmiTCP. "socket.library"-based
TCP/IP stacks (as225r2 etc.) are not supported, and the traceroute
and PING functionality won't work with SOCKS (whois and finger will,
though).

Last edited by hexaae; 17 August 2018 at 01:36.
hexaae is offline  
Old 17 August 2018, 15:42   #6
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,360
Yes, it makes perfect sense to me
kolla is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
uaenet.device is not working here anymore Leandro Jardim support.WinUAE 2 07 November 2016 21:09
NetInfo 2.10 HanSolo request.Apps 8 19 July 2016 15:09
Amiga 600HD not working anymore Supamax support.Hardware 13 13 June 2015 15:04
Demo not working anymore mai support.WinUAE 10 18 May 2014 11:38
hdd not working anymore nightlord support.Hardware 8 13 January 2008 05:58

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:24.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06891 seconds with 15 queries