English Amiga Board


Go Back   English Amiga Board > Coders > Coders. Language > Coders. AMOS

 
 
Thread Tools
Old 01 March 2017, 23:44   #1
volvo_0ne
Registered User

 
Join Date: Mar 2015
Location: Sheffield UK
Posts: 248
HAM colour problem, HELP please?

OK without trying to explain too much, why does ....



Screen Open 1,320,200,16,Lowres
Flash Off : Curs Off : Cls 0
Locate 0,16
Centre "A Picture of Our Cat!"
Screen Open 0,320,121,4096,Lowres
Flash Off : Cls 0
Load Iff "Tango1.ham"

result in the upper HAM picture having the horrid grey into the borders on WinUAE?

I WANT IT TO BE BLACK!!!!

I think it has a lot to do with the palette order, but what is the solution?

Any help would be much appreciated

oh yeah, heres a screenshot.....................
Attached Thumbnails
Click image for larger version

Name:	008.png
Views:	75
Size:	44.1 KB
ID:	52307  
volvo_0ne is offline  
AdSense AdSense  
Old 03 March 2017, 11:12   #2
roondar
Registered User

 
Join Date: Jul 2015
Location: The Netherlands
Posts: 262
Well, Amiga's show colour 0 in the border by default.

So it should be fixable by making sure that colour 0 of the HAM palette is black (or whatever colour you want your border to be).
roondar is offline  
Old 05 March 2017, 21:43   #3
volvo_0ne
Registered User

 
Join Date: Mar 2015
Location: Sheffield UK
Posts: 248
Thanks for looking, I finally sussed out the problem
Attached Thumbnails
Click image for larger version

Name:	009.png
Views:	39
Size:	46.9 KB
ID:	52376  

Last edited by volvo_0ne; 05 March 2017 at 21:49.
volvo_0ne is offline  
Old 05 March 2017, 22:00   #4
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,060
Quote:
Originally Posted by volvo_0ne View Post
Thanks for looking, I finally sussed out the problem
what about to reveal your solution?
emufan is offline  
Old 05 March 2017, 22:26   #5
volvo_0ne
Registered User

 
Join Date: Mar 2015
Location: Sheffield UK
Posts: 248
Quote:
Originally Posted by emufan View Post
what about to reveal your solution?
Well

Photon Paint 2.0 then change to standard palette then remap the picture and resave.

It changed colour 0 to black(which is all I needed), however there IS evidence of it in the output picture, but I can live with it in this case.

Not sure how it would hold up in fleshtones or something like that, maybe I'll try it sometime .
volvo_0ne is offline  
Old 05 March 2017, 23:01   #6
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,060
ok, thanks.
emufan is offline  
Old 05 March 2017, 23:53   #7
idrougge
Registered User
 
Join Date: Sep 2007
Location: Stockholm
Posts: 3,076
Does Photon Paint 2 handle HAM?
idrougge is offline  
Old 06 March 2017, 00:02   #8
volvo_0ne
Registered User

 
Join Date: Mar 2015
Location: Sheffield UK
Posts: 248
Quote:
Originally Posted by idrougge View Post
Does Photon Paint 2 handle HAM?
Well it did the job for me (infact I got the idea from the "Amos the Creator" manual by Mandarin) because none of the other HAM programs I tried worked without devastating image corruption (however that may have been down to my unfamiliarity with the software of course).
volvo_0ne is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
1084s-D2 composite colour problem loggio support.Hardware 3 16 February 2014 04:02
Rick Dangerous colour problem scymnodon project.WHDLoad 10 29 May 2011 23:35
Colour problem over scart pcut support.Hardware 26 27 November 2009 01:59
A1200 Colour problem (black has become blue) Mr_AGA support.Hardware 0 12 April 2006 03:52
WinUAE colour problem Walker support.WinUAE 4 07 May 2003 10:27

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:02.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.14303 seconds with 15 queries