English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 27 October 2019, 07:57   #1
badflame
Registered User

 
Join Date: Feb 2018
Location: Spain
Posts: 78
Roland MT-32 support (possible bug?)

Hi,

to use the Roland MT-32 in the compatible Sierra games, I have installed "Munt". So, now I can select the "MT-32 Synth Emulator" as MIDI in the "IO ports" settings.

The problem is, when the music begins in the game, MIDI music is on, but not the MT-32 instruments.

Then, I must to press F12, to go to the WinUAE's gui, select any other MIDI driver and go back to the game, press F12 one more time to select "MT-32 Synth Emulator" again and go return to the game.

At this point the Roland MT-32 instruments are heard, but as soon as the game changes melody (because it loads a new screen, for example), the MT-32 sounds are lost again and to recover them I must to perform the same process again.

Has anyone else experienced this kind of problem running games with MT-32 sound from WinUAE?

Thanks
badflame is offline  
Old 27 October 2019, 10:35   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,513
More information please..

Floppy? Normal HD installation? Whdload? Something else (some debugger?) writing to serial port confusing MIDI emulator? winuaelog.txt?
Toni Wilen is offline  
Old 27 October 2019, 14:00   #3
badflame
Registered User

 
Join Date: Feb 2018
Location: Spain
Posts: 78
Quote:
Originally Posted by Toni Wilen View Post
More information please..

Floppy? Normal HD installation? Whdload? Something else (some debugger?) writing to serial port confusing MIDI emulator? winuaelog.txt?
I have tried floppy and WHDload versions.

I am not aware of having any debugger installed.

winuaelog.txt
Code:
2019-10-27 12:50:55
55-670 [136 000-000]: CPU tracer disabled
2019-10-27 12:51:03
03-017 [506 173-178]: SERIAL: period=368, baud=9600, hsyncs=14, bits=8, PC=55935a
03-022 [506 171-194]: SERIAL: period=112, baud=31400, hsyncs=4, bits=8, PC=55935a
03-037 [506 171-194]: MIDI OUT: midiOutSetVolume error Esta función no es compatible. Use la función de capacidades para determinar las funciones y mensajes compatibles con su controlador. / 8
03-038 [506 171-194]: Midi enabled
13-077 [1008 000-000]: CPU tracer enabled
13-113 [1009 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
13-113 [1009 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
13-127 [1009 000-000]: GUIBase 813x600 (6x13)
13-128 [1009 000-000]: GUIBase 813x600 (6x13)
13-128 [1009 000-000]: Requested GUI size = 800x600 (720x568)
13-218 [1009 000-000]: Got GUI size = 799x600
20-713 [1009 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
20-713 [1009 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
21-521 [1009 000-000]: KS ver = 40 (0x28)
21-521 [1009 000-000]: Native resolution: 1920x1080
21-521 [1009 000-000]: Native resolution: 1920x1080
21-521 [1009 000-000]: Native resolution: 1920x1080
21-521 [1009 000-000]: Native resolution: 1920x1080
21-541 [1009 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
21-541 [1009 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
21-556 [1009 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
21-556 [1009 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
21-572 [1009 000-000]: CPU tracer disabled
21-572 [1009 000-000]: CPU tracer enabled
21-577 [1009 000-000]: MIDI: closed.
21-671 [1011 000-000]: CPU tracer disabled
23-254 [1090 000-000]: CPU tracer enabled
23-289 [1091 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
23-289 [1091 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
23-301 [1091 000-000]: GUIBase 813x600 (6x13)
23-303 [1091 000-000]: GUIBase 813x600 (6x13)
23-303 [1091 000-000]: Requested GUI size = 800x600 (720x568)
23-322 [1091 000-000]: Got GUI size = 799x600
25-605 [1091 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
25-605 [1091 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
26-379 [1091 000-000]: KS ver = 40 (0x28)
26-379 [1091 000-000]: Native resolution: 1920x1080
26-379 [1091 000-000]: Native resolution: 1920x1080
26-379 [1091 000-000]: Native resolution: 1920x1080
26-379 [1091 000-000]: Native resolution: 1920x1080
26-399 [1091 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
26-399 [1091 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
26-414 [1091 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
26-414 [1091 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
26-437 [1091 000-000]: CPU tracer disabled
26-437 [1091 000-000]: CPU tracer enabled
26-481 [1091 000-000]: MIDI: closed.
26-481 [1091 000-000]: MIDI OUT: midiOutSetVolume error Esta función no es compatible. Use la función de capacidades para determinar las funciones y mensajes compatibles con su controlador. / 8
26-513 [1093 000-000]: CPU tracer disabled
28-015 [1168 000-000]: CPU tracer enabled
28-050 [1169 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
28-050 [1169 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
28-063 [1169 000-000]: GUIBase 813x600 (6x13)
28-064 [1169 000-000]: GUIBase 813x600 (6x13)
28-064 [1169 000-000]: Requested GUI size = 800x600 (720x568)
28-084 [1169 000-000]: Got GUI size = 799x600
29-475 [1169 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
29-475 [1169 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
29-490 [1169 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
29-490 [1169 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
29-507 [1169 000-000]: CPU tracer disabled
29-507 [1169 000-000]: CPU tracer enabled
29-523 [1170 008-000]: ROM VP 00F00000 - 00F03000 3000 (12k) UNPROT
29-524 [1170 008-000]: ROM VP 00F80000 - 01000000 80000 (512k) UNPROT
29-543 [1170 008-000]: MIDI: closed.
29-543 [1170 008-000]: mapped_free direct Fast memory
29-543 [1170 008-000]: mapped_free direct Filesystem autoconfig
29-554 [1170 008-000]: mapped_free direct Kickstart ROM
29-554 [1170 008-000]: mapped_free direct Chip memory
29-554 [1170 008-000]: mapped_free direct UAE Boot ROM

I use also "Munt" MT-32 drivers under DOSBox and works well.

Thanks
badflame is offline  
Old 27 October 2019, 14:09   #4
badflame
Registered User

 
Join Date: Feb 2018
Location: Spain
Posts: 78
Another log, but without interaction for my hand. I don't change the MIDI source, I just let it ring incorrectly.

Code:
2019-10-27 13:06:26
26-779 [420 000-000]: CPU tracer disabled
30-191 [590 032-177]: SERIAL: period=368, baud=9600, hsyncs=14, bits=8, PC=5592fa
30-196 [590 189-192]: SERIAL: period=112, baud=31400, hsyncs=4, bits=8, PC=5592fa
30-212 [590 189-192]: MIDI OUT: midiOutSetVolume error Esta función no es compatible. Use la función de capacidades para determinar las funciones y mensajes compatibles con su controlador. / 8
30-212 [590 189-192]: Midi enabled
42-437 [1196 000-000]: ROM VP 00F00000 - 00F03000 3000 (12k) UNPROT
42-437 [1196 000-000]: ROM VP 00F80000 - 01000000 80000 (512k) UNPROT
42-469 [1196 000-000]: MIDI: closed.
42-469 [1196 000-000]: mapped_free direct Fast memory
42-469 [1196 000-000]: mapped_free direct Filesystem autoconfig
42-480 [1196 000-000]: mapped_free direct Kickstart ROM
42-480 [1196 000-000]: mapped_free direct Chip memory
42-480 [1196 000-000]: mapped_free direct UAE Boot ROM
badflame is offline  
Old 27 October 2019, 14:15   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,513
Attach zipped whdload slave directory, including save(s) that can be used to easily and quickly test missing MIDI sound.
Toni Wilen is offline  
Old 27 October 2019, 14:24   #6
badflame
Registered User

 
Join Date: Feb 2018
Location: Spain
Posts: 78
Quote:
Originally Posted by Toni Wilen View Post
Attach zipped whdload slave directory, including save(s) that can be used to easily and quickly test missing MIDI sound.
Here you have the file: www.shorturl.at/fW089

You can test the intro music. This is the correct MT-32 sound: [ Show youtube player ]
badflame is offline  
Old 27 October 2019, 15:12   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,513
I never trust any videos as usual..

I don't see any winuae related problems, serial data goes out and munt plays something (but I don't think instruments are correct but I have no idea if munt is correctly configured). Music changes when game loads other screen.

Switching MIDI output on the fly most likely causes Munt to reset and losing init data that gets only sent then music starts. At least I see chunk of data getting sent when game starts but before any music can be heard.

You can use -log -serlog command line parameters to see it in real time. Perhaps there is something unexpected.

Any difference with or without whdload preload parameter?
Toni Wilen is offline  
Old 28 October 2019, 03:39   #8
badflame
Registered User

 
Join Date: Feb 2018
Location: Spain
Posts: 78
I just tried without PRELOAD and the same thing happens.

I have captured all the events:


Code:
WinUAE 4.2.1 (2019.05.16) 64-bit (6.1.7601 Service Pack 1 [2]) 64-bit 9.6.1A05 4 06:45 0
(c) 1995-2001 Bernd Schmidt   - Core UAE concept and implementation.
(c) 1998-2019 Toni Wilen      - Win32 port, core code updates.
(c) 1996-2001 Brian King      - Win32 port, Picasso96 RTG, and GUI.
(c) 1996-1999 Mathias Ortmann - Win32 port and bsdsocket support.
(c) 2000-2001 Bernd Meyer     - JIT engine.
(c) 2000-2005 Bernd Roesch    - MIDI input, many fixes.
Press F12 to show the Settings Dialog (GUI), Alt-F4 to quit.
End+F1 changes floppy 0, End+F2 changes floppy 1, etc.
'H:\hyperspin\Emulators\WinUAE\winuae64.exe'
EXE: 'H:\hyperspin\Emulators\WinUAE\', DATA: 'H:\hyperspin\Emulators\WinUAE\', PLUGIN: 'H:\hyperspin\Emulators\WinUAE\plugins\'
'H:\hyperspin\Emulators\WinUAE\winuae.ini' enabled
Autoconfig board list:
Card 01: '<no name>' no autoconfig 00da0000 - 00daffff.
Card 02: '<no name>' no autoconfig 00600000 - 00a7ffff.
Card 03: 'UAE Boot ROM' no autoconfig 00f00000 - 00f0ffff.
Card 04: 'Z2 Fast RAM'
  e7.51.00.00.07.db.00.00.00.01.00.00.00.00.00.00
  MID 2011 (07db) PID 81 (51) SER 00000001
  Z2 0x00200000 0x00200000 4096K RAM 0
Card 05: 'UAE FS ROM'
  d1.52.40.00.07.db.00.00.00.03.20.00.00.00.00.00
  MID 2011 (07db) PID 82 (52) SER 00000003
  Z2 0x00e90000 0x00e90000   64K ROM 0
END
MMAN: Selected REAL Z3 mapping mode
Total 256M Z3 Total 256M, HM 0M
Autoconfig board list:
Card 01: '<no name>' no autoconfig 00da0000 - 00daffff.
Card 02: '<no name>' no autoconfig 00600000 - 00a7ffff.
Card 03: 'UAE Boot ROM' no autoconfig 00f00000 - 00f0ffff.
Card 04: 'Z2 Fast RAM'
  e7.51.00.00.07.db.00.00.00.01.00.00.00.00.00.00
  MID 2011 (07db) PID 81 (51) SER 00000001
  Z2 0x00200000 0x00200000 4096K RAM 0
Card 05: 'UAE FS ROM'
  d1.52.40.00.07.db.00.00.00.03.20.00.00.00.00.00
  MID 2011 (07db) PID 82 (52) SER 00000003
  Z2 0x00e90000 0x00e90000   64K ROM 0
END
MMAN: Our special area: 0000000080000000-0000000090000000 (0x10000000 256M)
KS ver = 40 (0x28)
Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
Port0: COMBO 'Windows mouse' + 'WINMOUSE1' matched
Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
Port1: COMBO 'Controller (XBOX 360 For Windows)' + '\\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}' matched
Port2: NONE
Port3: NONE
Native resolution: 1920x1080
Native resolution: 1920x1080
Native resolution: 1920x1080
Native resolution: 1920x1080
Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
RTAREA located at 00F00000
shmget of size 65536 (64k) for rtarea (UAE Boot ROM)
0000000080F00000: VA 00F00000 - 00F10000 10000 (64k) ok (0000000080F00000)
TRAP_ENTRY = 00f01e1a
shmget of size 4194304 (4096k) for * (Fast memory)
0000000080200000: VA 00200000 - 00600000 400000 (4096k) ok (0000000080200000)
shmget of size 524288 (512k) for kick (Kickstart ROM)
0000000080F80000: VA 00F80000 - 01000020 80020 (512k) ok (0000000080F80000)
shmget of size 2097152 (2048k) for chip (Chip memory)
0000000080000000: VA 00000000 - 00200000 200000 (2048k) ok (0000000080000000)
ROM VP 00F00000 - 00F03000 3000 (12k) UNPROT
ROM VP 00F80000 - 01000000 80000 (512k) UNPROT
ROM loader.. (<none>)
Known ROM 'KS ROM v3.1 (A1200)' loaded
ROM loader end
memory init end
No disk in drive 0.
CPU cycleunit: 128 (0.250)
1870 CPU functions
Max hardware surface size: 16384x16384
SetCursorPos 960x540
Mon 0 reserved draw temp buffer (1600*1280*32)
Direct3D: Pixel shader 2.0+ support detected, shader filters enabled.
Device name: 'NVIDIA GeForce GTX 1050' 190015000e06eb.a1
D3D9Ex: 00000056 00020800 E0020000 000007A0 ALPHA DYNAMIC SCANLINE
D3D9Ex: PS=3.0 VS=3.0 1920*1080*0p FS VS=0 B=2WE 32-bit 0 (16384x16384)
D3D9Ex: Attempting to load 'H:\hyperspin\Emulators\WinUAE\plugins\filtershaders\direct3d\_winuae.fx'
D3D9Ex: pixelshader filter 'H:\hyperspin\Emulators\WinUAE\plugins\filtershaders\direct3d\_winuae.fx':-1 enabled
D3D9Ex: Attempting to load 'H:\hyperspin\Emulators\WinUAE\plugins\filtershaders\direct3d\CRT.D3D.bright.fx'
D3D9Ex: pixelshader filter 'H:\hyperspin\Emulators\WinUAE\plugins\filtershaders\direct3d\CRT.D3D.bright.fx':8 enabled
D3D9Ex: mask 1920*1088 (32*32) 1920*1088 ('Classic Scanlines.png':2) texture allocated
D3D9Ex: 3008*1152 working texture:1
D3D9Ex: 7680*4320 temp texture:1:3
D3D9Ex: 752*288 main texture, depth 32
HQ2X texture (7680x4320) (752x288):1
Buffer size (752*288) Native
ActiveHeight: 1080 TotalHeight: 1125 VFreq=60000/1000=60.00Hz HFreq=148500000/2200=67.500KHz
Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
CPU cycleunit: 128 (0.250)
Building CPU, 45912 opcodes (2 -2 1)
JIT: &countdown =  0000000014C0D530
JIT: &build_comp = 0000000010C85F20
JIT: <JIT compiler> : Max CPUID level=11 Processor is GenuineIntel [PentiumPro]
JIT: Installing vectored exception handler
JIT: <JIT compiler> : building compiler function tables
JIT: <JIT compiler> : supposedly 42292 compileable opcodes!
CPU=68020, FPU=0, MMU=0, JIT=0. ~cycle-exact 24-bit
clipboard: reset (00000000)
memory init end
Reset at 00000000. Chipset mask = 00000007
00000000    2048K/1 =    2048K ID C32 Chip memory
00200000    8704K/0 =    8704K -- F32 <none>
00A80000    1024K/2 =     512K ID F32 Kickstart ROM (1483A091)
=KS ROM v3.1 (A1200) rev 40.68 (512k) [391773-01/391774-01]
00B80000     448K/0 =     448K -- F32 <none>
00BF0000      64K/0 =      64K -- CIA CIA
00C00000    1536K/0 =    1536K -- C32 <none>
00D80000     256K/0 =     256K -- C16 Gayle (low)
00DC0000      64K/0 =      64K -- C16 Battery backed up clock (none)
00DD0000      64K/0 =      64K -- C16 Gayle (low)
00DE0000      64K/0 =      64K -- C16 Gayle (high)
00DF0000      64K/0 =      64K -- C16 Custom chipset
00E00000     512K/1 =     512K ID F32 Kickstart ROM (1483A091)
=KS ROM v3.1 (A1200) rev 40.68 (512k) [391773-01/391774-01]
00E80000      64K/0 =      64K -- F32 Autoconfig Z2
00E90000     448K/0 =     448K -- F32 <none>
00F00000      64K/1 =      64K -- F32 UAE Boot ROM
00F10000     448K/0 =     448K -- F32 <none>
00F80000     512K/1 =     512K ID F32 Kickstart ROM (1483A091)
=KS ROM v3.1 (A1200) rev 40.68 (512k) [391773-01/391774-01]
PAL mode V=50.0804Hz H=15625.0879Hz (227x312+0) IDX=10 (PAL) D=0 RTG=0/0
D3D9Ex: 3008*1148 working texture:1
D3D9Ex: 7680*4320 temp texture:1:3
D3D9Ex: 752*287 main texture, depth 32
HQ2X texture (7680x4320) (752x287):1
Buffer size (752*287) Native
RTGFREQ: 312*50.0804 = 15625.0879 / 50.1 = 312
POS (0 0 1920 1080) - (0 0 895 262)[895,262] (-55 10)
Autoconfig board list:
Card 01: '<no name>' no autoconfig 00da0000 - 00daffff.
Card 02: '<no name>' no autoconfig 00600000 - 00a7ffff.
Card 03: 'UAE Boot ROM' no autoconfig 00f00000 - 00f0ffff.
Card 04: 'Z2 Fast RAM'
  e7.51.00.00.07.db.00.00.00.01.00.00.00.00.00.00
  MID 2011 (07db) PID 81 (51) SER 00000001
  Z2 0x00200000 0x00200000 4096K RAM 0
Card 05: 'UAE FS ROM'
  d1.52.40.00.07.db.00.00.00.03.20.00.00.00.00.00
  MID 2011 (07db) PID 82 (52) SER 00000003
  Z2 0x00e90000 0x00e90000   64K ROM 0
END
Card 0: skipping autoconfig (not autoconfig)
Card 2: skipping autoconfig (not autoconfig)
ROM VP 00F00000 - 00F03000 3000 (12k) UNPROT
ROM VP 00F80000 - 01000000 80000 (512k) UNPROT
hardreset, memory cleared
WASAPI: '{0.0.0.00000000}.{f9f83b73-1de6-4032-84ed-3a7847bcecd5}'
WASAPI: Shared Pull CH=2 FREQ=48000 BUF=1366 (2732)
SNDRATE 312.0*227.0*50.080410=3546894.958099

2019-10-28 02:22:23
23-029 [7 167=060]: SERIAL: period=372, baud=9600, hsyncs=1, bits=8, PC=f8018a
23-030 [7 070=063]: B-Trap F201 at 00F80CA0 -> 00F80CC0
23-180 [14 221=229]: Card 4: Z2 0x00200000 4096K RAM Fast memory
23-181 [14 127=257]: shmget of size 65536 (64k) for * (Filesystem autoconfig)
23-181 [14 127=257]: 0000000080E90000: VA 00E90000 - 00EA0020 10020 (64k) ok (0000000080E90000)
23-181 [14 127=257]: Card 5: Z2 0x00e90000   64K ROM Filesystem autoconfig
23-182 [14 127=257]: Memory map after autoconfig:
23-182 [14 127=257]: 00000000    2048K/1 =    2048K ID C32 Chip memory
23-182 [14 127=257]: 00200000    4096K/1 =    4096K ID F32 Fast memory
23-183 [14 127=257]: 00600000    4608K/0 =    4608K -- F32 <none>
23-184 [14 127=257]: 00A80000    1024K/2 =     512K ID F32 Kickstart ROM (1483A091)
23-185 [14 127=257]: =KS ROM v3.1 (A1200) rev 40.68 (512k) [391773-01/391774-01]
23-185 [14 127=257]: 00B80000     448K/0 =     448K -- F32 <none>
23-185 [14 127=257]: 00BF0000      64K/0 =      64K -- CIA CIA
23-186 [14 127=257]: 00C00000    1536K/0 =    1536K -- C32 <none>
23-186 [14 127=257]: 00D80000     256K/0 =     256K -- C16 Gayle (low)
23-186 [14 127=257]: 00DC0000      64K/0 =      64K -- C16 Battery backed up clock (MSM6242B)
23-187 [14 127=257]: 00DD0000      64K/0 =      64K -- C16 Gayle (low)
23-187 [14 127=257]: 00DE0000      64K/0 =      64K -- C16 Gayle (high)
23-187 [14 127=257]: 00DF0000      64K/0 =      64K -- C16 Custom chipset
23-189 [14 127=257]: 00E00000     512K/1 =     512K ID F32 Kickstart ROM (1483A091)
23-189 [14 127=257]: =KS ROM v3.1 (A1200) rev 40.68 (512k) [391773-01/391774-01]
23-190 [14 127=257]: 00E80000      64K/0 =      64K -- F32 Autoconfig Z2
23-190 [14 127=257]: 00E90000      64K/1 =      64K -- F32 Filesystem autoconfig
23-190 [14 127=257]: 00EA0000     384K/0 =     384K -- F32 <none>
23-191 [14 127=257]: 00F00000      64K/1 =      64K -- F32 UAE Boot ROM
23-191 [14 127=257]: 00F10000     448K/0 =     448K -- F32 <none>
23-193 [14 127=257]: 00F80000     512K/1 =     512K ID F32 Kickstart ROM (1483A091)
23-193 [14 127=257]: =KS ROM v3.1 (A1200) rev 40.68 (512k) [391773-01/391774-01]
23-330 [22 076=077]: filesystem: diagentry 00200098 configdev 00000c48
23-387 [25 000-000]: SNDRATE 313.0*227.0*49.920410=3546895.062012
23-388 [25 000-000]: PAL mode V=49.9204Hz H=15625.0879Hz (227x312+1) IDX=10 (PAL) D=0 RTG=0/0
23-590 [35 108-092]: Mounting uaehf.device:0 0 (0):
23-590 [35 108-092]: FS: mounted virtual unit DH0 (.\HDD\WHD)
23-591 [35 015-100]: Mounting uaehf.device:0 1 (0):
23-591 [35 015-100]: FS: mounted virtual unit DH1 (.\roms\Leisure Suit Larry 1 - In the Land of the Lounge Lizards (enhanced).7z)
23-730 [42 055-096]: FS: WHD (flags=00000002,E=0,ED=1,EF=0,native='.\HDD\WHD') starting..
23-781 [44 016-255]: FS: Games (flags=00000004,E=0,ED=0,EF=1,native='.\roms\Leisure Suit Larry 1 - In the Land of the Lounge Lizards (enhanced).7z') starting..
23-962 [53 051-294]: Illegal instruction: 4e7a at 00226700 -> 00226710
23-963 [53 066-294]: B-Trap F200 at 0022672A -> 0022674E
23-963 [53 085-294]: B-Trap F017 at 00226778 -> 002267AA
25-931 [144 000-000]: Mon 0 reserved draw temp buffer (1600*1280*32)
25-939 [144 000-000]: Switch from triple buffer to double buffer (-1).
25-940 [144 000-000]: Device name: 'NVIDIA GeForce GTX 1050' 190015000e06eb.a1
25-971 [144 000-000]: D3D9Ex: 00000056 00020800 E0020000 000007A0 ALPHA DYNAMIC SCANLINE
25-972 [144 000-000]: D3D9Ex: PS=3.0 VS=3.0 720*568*0p VS=0 B=1I 32-bit 0 (16384x16384)
25-972 [144 000-000]: D3D9Ex: Attempting to load 'H:\hyperspin\Emulators\WinUAE\plugins\filtershaders\direct3d\_winuae.fx'
25-988 [144 000-000]: D3D9Ex: pixelshader filter 'H:\hyperspin\Emulators\WinUAE\plugins\filtershaders\direct3d\_winuae.fx':-1 enabled
25-989 [144 000-000]: D3D9Ex: Attempting to load 'H:\hyperspin\Emulators\WinUAE\plugins\filtershaders\direct3d\CRT.D3D.bright.fx'
26-155 [144 000-000]: D3D9Ex: pixelshader filter 'H:\hyperspin\Emulators\WinUAE\plugins\filtershaders\direct3d\CRT.D3D.bright.fx':8 enabled
26-163 [144 000-000]: D3D9Ex: mask 736*576 (32*32) 736*576 ('Classic Scanlines.png':2) texture allocated
26-167 [144 000-000]: D3D9Ex: 3008*1152 working texture:1
26-168 [144 000-000]: D3D9Ex: 2880*2272 temp texture:1:3
26-169 [144 000-000]: D3D9Ex: 752*288 main texture, depth 32
26-173 [144 000-000]: HQ2X texture (2880x2272) (752x288):1
26-232 [144 000-000]: Buffer size (752*288) Native
26-233 [144 000-000]: ActiveHeight: 1080 TotalHeight: 1125 VFreq=60000/1000=60.00Hz HFreq=148500000/2200=67.500KHz
26-245 [144 000-000]: SNDRATE 313.0*227.0*49.920410=3546895.062012
26-246 [144 000-000]: PAL mode V=49.9204Hz H=15625.0879Hz (227x312+1) IDX=10 (PAL) D=0 RTG=0/0
26-247 [144 000-000]: D3D9Ex: 3008*1148 working texture:1
26-247 [144 000-000]: D3D9Ex: 2880*2272 temp texture:1:3
26-248 [144 000-000]: D3D9Ex: 752*287 main texture, depth 32
26-250 [144 000-000]: HQ2X texture (2880x2272) (752x287):1
26-318 [144 000-000]: Buffer size (752*287) Native
26-321 [144 000-000]: RTGFREQ: 312*49.9204 = 15575.1680 / 49.9 = 312
26-338 [145 000-000]: POS (0 0 720 568) - (0 0 672 275)[672,275] (56 4)
26-342 [145 000-000]: CPU tracer enabled
26-371 [147 000-000]: CPU tracer disabled

35-141 [590 173-178]: SERIAL: period=368, baud=9600, hsyncs=1, bits=8, PC=55935a

35-146 [590 171-194]: SERIAL: period=112, baud=31400, hsyncs=1, bits=8, PC=55935a
35-164 [590 171-194]: MIDI OUT: midiOutSetVolume error Esta función no es compatible. Use la función de capacidades para determinar las funciones y mensajes compatibles con su controlador. / 8
35-165 [590 171-194]: Midi enabled
.A... .................<...\!..A..............{..A..........P......A......p......._..A..............3..A..... ........[..A.....(........S..A.....0........K..A.....8........C..A.....@........;..A.....H........3..A.....P........+..A.....X........#..A.....`...........A.....h...........A.....p...........A.....x...........A..............z..A..............r..A..............j..A..............b..A..... ........Z..A.....(........R..A.....0........J..A.....8........B..A.....@........:..A.....H........,..A.....P........Z..A.....X........"..A.....`...........A.....h...........A.....p...........A.....x...........A..............y..A..............q..A..............i..A..............a..A..... ........Y..A.....(........Q..A.....0........I..A.....8........A..A.....@........9..A.....H........1..A.....P........)..A.....X........!..A.....`...........A.....h...........A.....p...........A.....x...........A... ......................!..A...R.
...... ...A......P
..{.....x.
@....@...@.{.....<.
6....@...@.{.....d.
"....@...@.{.....q.
^....@...@.{.....x.
J....@...@.{.....x.
@....@...@....@t.<d.+Z.@.....+..<..@U.@..!..>d.Am.-..A..!..-..>..A\.A..#..Bw.?d./j.B..#../..B^.?..B..CL.$..@d.$j.0u.0p.$..C..EH.0..$..4f.0..E..@\.4..<h.7k.@Z.&X.*].@..<..7..&..*..@..@..Ct.7n.<l.@d.*].<..@..7..*...A.1Z.0_....`C.@D.uD.$f.pK.%K.C..pK.;L.$...M.2M.ON..O..O.eO.yO..P..P.Ew.1.....?...@.7s.4f.0..7..9..4..7f.@P.<a.@M.?..&_.*a.<..@..7..*..&..@..9..E..4Z.7l.<h.@Z.@O.CE.*].@..<..7..C..*..4.CPU tracer enabled
47-226 [1191 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
47-226 [1191 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
47-240 [1191 000-000]: GUIBase 813x600 (6x13)
47-242 [1191 000-000]: GUIBase 813x600 (6x13)
47-242 [1191 000-000]: Requested GUI size = 800x600 (720x568)
47-335 [1191 000-000]: Got GUI size = 799x600
56-448 [1191 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
56-448 [1191 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
2019-10-28 02:23:02
02-410 [1191 000-000]: KS ver = 40 (0x28)
02-411 [1191 000-000]: Native resolution: 1920x1080
02-411 [1191 000-000]: Native resolution: 1920x1080
02-412 [1191 000-000]: Native resolution: 1920x1080
02-412 [1191 000-000]: Native resolution: 1920x1080
02-432 [1191 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
02-432 [1191 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
02-448 [1191 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
02-448 [1191 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
02-477 [1191 000-000]: CPU tracer disabled
02-477 [1191 000-000]: CPU tracer enabled
02-483 [1191 000-000]: MIDI: closed.
.@..Cw.Hr.7p.0c.$cCPU tracer disabled
.$..$..$..H..C..EU.CN.4X.0..4..Cw.C..<b.E..EX.&d.*a.7k.@Q.7..<..@..7..*..&..C..E..Ft.7b.Hr.<h.@U.*a.7..<..@..*..0W.$d..~.$.CPU tracer enabled
03-801 [1251 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
03-801 [1251 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
03-815 [1251 000-000]: GUIBase 813x600 (6x13)
03-817 [1251 000-000]: GUIBase 813x600 (6x13)
03-817 [1251 000-000]: Requested GUI size = 800x600 (720x568)
03-838 [1251 000-000]: Got GUI size = 799x600
05-970 [1251 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
05-971 [1251 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
22-593 [1251 000-000]: KS ver = 40 (0x28)
22-594 [1251 000-000]: Native resolution: 1920x1080
22-594 [1251 000-000]: Native resolution: 1920x1080
22-594 [1251 000-000]: Native resolution: 1920x1080
22-594 [1251 000-000]: Native resolution: 1920x1080
22-615 [1251 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
22-615 [1251 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
22-631 [1251 000-000]: Stored port 0/2 d=0: added 200 0 Windows mouse WINMOUSE1
22-631 [1251 000-000]: Stored port 1/2 d=0: added 100 0 Controller (XBOX 360 For Windows) \\?\HID#VID_045E&PID_028E&IG_00#7&88d49a7&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
22-667 [1251 000-000]: CPU tracer disabled
22-668 [1251 000-000]: CPU tracer enabled
22-700 [1251 000-000]: MIDI: closed.
22-700 [1251 000-000]: MIDI OUT: midiOutSetVolume error Esta función no es compatible. Use la función de capacidades para determinar las funciones y mensajes compatibles con su controlador. / 8
22-741 [1253 000-000]: CPU tracer disabled
....F..Ed.JA./Z..B..E.4M.rD.=E.0.."E..E.4..&^.*a.
E.<d.7^.@V.9U....Ck.9.."E.<..E..*..=E.zE.@..7...F.H..&..NF..G..G.qG.3H.LH.PH.SI.+J..K..L.BL.jL..M.Dw.AN.]N.jN..O.UP.C..eP.7d.<h.@^.@_.*a.tQ.gR.pS..U.5V.ZW.@..<..*...X.7.....]Y..[.0W.D..b[.h].EO..{.Af.$j.x].._.@..:_.Z_..`.$.....E..HO.5Q./..0..A..Dh.H..5..&k.*`.<g.9f.Aa.*..<..9..&..A..D..9d.<_.A].EZ.*a.<..A..9..*..C?.7n.0].$}.Eq.HA.nA.E..$b..B..B.mD.RE.7F..G.$..hG..H.8H.uH.)I.VI..J.BJ.QJ.dJ.mJ.7..$..Hw.E..5N.HK..@.<Z.0..<..5..H..9f.AZ.<].Jk.&c.*`.>{.<..A..9..*..&..9_.<a.A[.H..J..>..HU.9Z.Dt.*a.<..9..A..*..9..0U.H..<Z.D..Kr.$g.E(.)..$.ROM VP 00F00000 - 00F03000 3000 (12k) UNPROT
26-039 [1411 000-000]: ROM VP 00F80000 - 01000000 80000 (512k) UNPROT
26-067 [1411 000-000]: MIDI: closed.
26-068 [1411 000-000]: mapped_free direct Fast memory
26-068 [1411 000-000]: mapped_free direct Filesystem autoconfig
26-068 [1411 000-000]: mapped_free direct Kickstart ROM
26-069 [1411 000-000]: mapped_free direct Chip memory
26-069 [1411 000-000]: mapped_free direct UAE Boot ROM
badflame is offline  
Old 28 October 2019, 03:39   #9
badflame
Registered User

 
Join Date: Feb 2018
Location: Spain
Posts: 78
The line "02-483 [1191 000-000]: MIDI: closed." is when after push F12, I change the MIDI source for "Microsoft Midi Mapper". Next two lines with strange symbols are the MIDI sounds.

Then I push F12 again and in the line "22-700 [1251 000-000]: MIDI: closed." I reselect "MT-32 Synth Emulator" and go back to the game.

Next lines with strange symbols are the MIDI sounds of MT-32 with the instruments playing correctly (as in the shared YouTube video).

badflame is offline  
Old 28 October 2019, 04:14   #10
badflame
Registered User

 
Join Date: Feb 2018
Location: Spain
Posts: 78
To easily appreciate the bug, I have uploaded two .mp3 files, with the captured sound of the intro and the pub scene.

"intro (13) .mp3" is the music of the intro. At timeline 13" is when I do change the MIDI source. In this way the difference of instruments is evident.

In "pub (10).mp3" the change occurs at timeline 10".

And every time the game changes the melody, MT-32 instruments are "deactivated" or "changed" again, and to recover the sound you have to make the process of double change of MIDI source.

The .mp3 files: www.shorturl.at/eorO6

If you play this game from your WinUAE, how do you listen to MIDI instruments, as the first seconds or as the second part of the .mp3 files?

Last edited by badflame; 28 October 2019 at 04:35.
badflame is offline  
Old 29 October 2019, 20:31   #11
badflame
Registered User

 
Join Date: Feb 2018
Location: Spain
Posts: 78
Have you tested my mp3 files, Toni Wilen?
badflame is offline  
Old 29 October 2019, 20:45   #12
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,513
Not yet. But first, does the game actually sound like that when used with real MT-32?

Same game but different hardware sounding different or same is not good enough proof because weirder things have happened.
Toni Wilen is offline  
Old 30 October 2019, 00:50   #13
badflame
Registered User

 
Join Date: Feb 2018
Location: Spain
Posts: 78
Obviously I can't know how it sounds with a real MT-32, because I don't have it. But this is not the point.

The point is that I must to swicth the MIDI source (which internally means restarting the MT-32 driver), every time the game plays a new MIDI sound (regardless of whether the sound is exactly the same or not with a real MT-32), to reproduce the best possible sound.

This is the only thing that I ask you to check:

1) star the game with the "MT-32 Synth Emulator" selected
2) when music starts, press F12 and switch MIDI source to "Microsoft Midi Mapper"
3) return to the game
4) press F12 and switch MIDI source to "MT-32 Synth Emulator"
5) return to the game
6) Did you hear exactly the same sounds in step 2 (before switching to "Microsoft Midi Mapper") that now or has changed?

In my case, as you can hear in the file "intro (13) .mp3" is very evident the change. It's produced at time code 13".

The purpose is determining if it is a WinUAE bug or if it is a failure in my system configuration.

Thanks.

Last edited by badflame; 30 October 2019 at 01:18.
badflame is offline  
Old 30 October 2019, 19:38   #14
enigma776
Bringer of Death

enigma776's Avatar
 
Join Date: Apr 2017
Location: UK
Age: 36
Posts: 144
I am just going to through my hat in, tested Space Quest and got MT-32 audio just fine, have you made sure you are using the right roms for MUNT?
enigma776 is offline  
Old 30 October 2019, 22:11   #15
badflame
Registered User

 
Join Date: Feb 2018
Location: Spain
Posts: 78
Quote:
Originally Posted by enigma776 View Post
I am just going to through my hat in, tested Space Quest and got MT-32 audio just fine, have you made sure you are using the right roms for MUNT?
I use these drivers: www.shorturl.at/hwFOY

Are you sure? It is not easy to know since MIDI music plays, but it may not be correct instruments.

If you make the 6 steps of my previous post, the music not changes?
badflame is offline  
Old 30 October 2019, 23:08   #16
badflame
Registered User

 
Join Date: Feb 2018
Location: Spain
Posts: 78
Mmm, everything gets weirder.

I have tested "Space Quest" and "Conquest of the Longbow". Both change his sound switching MIDI, but ... in this case it seems that the correct sound is the played before BEFORE switching.

conquest of longbow - normal.mp3: www.shorturl.at/af468

conquest of longbow - switch MIDI.mp3: www.shorturl.at/bcfqC

space quest - normal.mp3: www.shorturl.at/FOSU1

space quest - switch MDI.mp3: www.shorturl.at/nxzJP

Perhaps the case of "Leisure Suit Larry" is an exception. I will have to test the rest of Sierra games compatible with MT-32.
badflame is offline  
Old 31 October 2019, 00:25   #17
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,733
Quite a few 68k games now support native MIDI... just saying
NovaCoder is offline  
Old 31 October 2019, 00:46   #18
badflame
Registered User

 
Join Date: Feb 2018
Location: Spain
Posts: 78
Quote:
Originally Posted by NovaCoder View Post
Quite a few 68k games now support native MIDI... just saying
But not Roland MT-32, really?

https://en.wikipedia.org/wiki/List_o...ommodore_Amiga
badflame is offline  
Old 31 October 2019, 01:08   #19
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,733
That list is out of date, most of my recent 68K ports support native MIDI

http://aminet.net/search?readme=NovaCoder
NovaCoder is offline  
Old 31 October 2019, 01:13   #20
badflame
Registered User

 
Join Date: Feb 2018
Location: Spain
Posts: 78
Quote:
Originally Posted by NovaCoder View Post
That list is out of date, most of my recent 68K ports support native MIDI

http://aminet.net/search?readme=NovaCoder
Oh, thanks!
badflame is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I run a Roland MT-32? Retrofan support.Other 67 18 October 2019 12:49
How to setup Roland MT32 emulation? Retrofan support.WinUAE 17 15 April 2019 02:27
winuae g15 support - bug? honx support.WinUAE 2 05 January 2019 12:04
roland sc55 - amiga gunstarrhero support.Other 1 22 June 2018 01:55
[Bug?] VHD support in 2.5.12 broken & unable to write to VHD in 2.5.11 amigafreak68k support.FS-UAE 8 01 March 2015 17:44

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 07:56.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.09671 seconds with 13 queries