English Amiga Board


Go Back   English Amiga Board > Support > support.FS-UAE

 
 
Thread Tools
Old 24 March 2020, 21:12   #41
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 45
Posts: 1,453
Send a message via ICQ to Foul Send a message via MSN to Foul
i'm using FBlit !

it's in my startup-sequence...

https://pastebin.com/NfEE9DHD if it can help.

(removed icon.library from Blizkick for the moment)
Foul is online now  
Old 24 March 2020, 21:30   #42
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,630
For the tests I used your AmigaTest.HDF from the 1. post of this thread. Of course, I know how to install FBlit or P96, but that was not required for checking your dot icon problem.

I think the bug is not fixed as long as there is no update for FS-UAE, but it may not be triggered that much obviously when you remove my library.
PeterK is offline  
Old 24 March 2020, 21:42   #43
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 45
Posts: 1,453
Send a message via ICQ to Foul Send a message via MSN to Foul
Another weird issue just for exemple : simply click on any file .info in Dopus 4

with icon.library 46.4.527 : requester appear on the Workbench behind



icon.library 44.543 : requester appear inside Dopus



The good news is, it will speed up Frode to release a new version
Foul is online now  
Old 24 March 2020, 21:49   #44
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,630
Never had that in WinUAE, but didn't test Dopus4 in FS-UAE yet. Let's see tomorrow ...

Update:
Tested Dopus 4.17pre21 successfully in FS-UAE with OS 3.1 and 3.9, no such hidden IconInfo window. Don't use the buggy 1260 emulation, it can cause a lot of unexpected errors. You can use the normal 68060 CPU instead.

Which OS are you using? I cannot test OS 3.5, and your icon.library is from OS 3.5. Which Dopus4 version, which screenmode and gfx driver? Usually, icon.library should have no influence on where Dopus4 opens the IconInfo window, but who knows ...

Check your Dopus4 configuration, for example the settings for Screen/Mode. Try to boot without SystemPatch.

Update2:
I've made a small debug package for Dopus4. It has no configuration files DirectoryOpus.CFG and DirectoryOpus.CLA in the s/ directory. Before you start this debug version make sure that no other instance of Dopus is running and that neither dopus.library exists in Libs: nor DopusRT in C: or somewhere else in the PATH and you have no Assign for Dopus:.

You can run this debug version once with my library and another time with the other icon.library, then double-click on an icon in Dopus to open the IconInfo window, and you should get some Sashimi output in a console window. Click into that window and type <CTRL>+<F> to get a copy of the output in T:Sashimi.out. Give that file a reasonable name and save it. You can also repeat the tests with your DirectoryOpus.CFG and DirectoryOpus.CLA in the s/ directory. Upload the 2 or 4 log files and your configuration, too. Maybe they can give some information about what happens with your IconInfo window, although I couldn't see anything on my system.

Important: Disable all your patch programs like SystemPatch, MCP and all window related commodities while you are doing any tests.
Attached Files
File Type: lha DebugDopus.lha (433.7 KB, 2 views)

Last edited by PeterK; 28 March 2020 at 06:33.
PeterK is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Crash with JIT and ReSource mark_k support.WinUAE 1 14 April 2017 12:48
WB 1.3 BindDrivers crash with JIT mark_k support.WinUAE 8 23 April 2012 18:32
Shapeshifter and Fusion crash without JIT enabled clauddio support.WinUAE 3 12 March 2012 11:44
Happy Xmas all (or happy holidays) + crash prob Mclane support.WinUAE 2 29 December 2004 22:34
JIT Emulation Doozy support.WinUAE 2 17 January 2002 07:14

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:13.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.06850 seconds with 15 queries