English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 06 May 2013, 13:01   #41
wawa
Registered User
 
Join Date: Aug 2007
Location: berlin/germany
Posts: 944
Quote:
Originally Posted by NovaCoder View Post
Cool, looks like it's going to come in handy then. I only started developing it to port Descent Rebirth.

The library is very buggy at the moment though (and very slow), you might want to wait a few weeks for a much improved version (I'll remove the library for now).
i hope you will release it though, nova. people have been always complaining sdl ports dont work on aga, one could recompile some of them in case performance will be ok.
otherwise if you need any testing on my a4000/os3.x&aros im at your disposal.
wawa is offline  
AdSense AdSense  
Old 06 May 2013, 14:40   #42
fishyfish
Banned
 
Join Date: Jul 2010
Location: Australia
Posts: 475
Quote:
Originally Posted by NovaCoder View Post
Cool, looks like it's going to come in handy then. I only started developing it to port Descent Rebirth.

The library is very buggy at the moment though (and very slow), you might want to wait a few weeks for a much improved version (I'll remove the library for now).
Yeah, that's cool. Im currently working on improving the 68k emulation of DGen anyway, so any additional AGA SDL improvements that come along are bonuses I might end up replacing SDL altogether, but for the moment it's nice to have so I can focus on other stuff.
fishyfish is offline  
Old 06 May 2013, 17:13   #43
Retro1234
Bo Bo

Retro1234's Avatar
 
Join Date: Jun 2006
Location: 5150
Posts: 3,911
cough...cough......http://eab.abime.net/showthread.php?p=752109#post752109......SDL.......Slow...030......maybe....
Retro1234 is offline  
Old 06 May 2013, 18:07   #44
fishyfish
Banned
 
Join Date: Jul 2010
Location: Australia
Posts: 475
SDL being slow is a misconception. The slowness comes from the implementation we have.
Check out warpscumm (uses warpsdl) for example. It's just as fast (faster even) than some of the "native" versions.

As for HOTA, I might still have the 68k/os3.x version somewhere (which was done by a friend).
fishyfish is offline  
Old 07 May 2013, 02:00   #45
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,450
Update:

Arti has sent me the NetSurf AGA source code so I'm going to look at it and try and improve the speed and fix up the small bugs he's seeing (the bugs are probably with my SDL library).

As to an SDL being slow, yes it will always add a small overhead but depending on what features you enable, I estimate that my AGA version will only slow down a large application by < 1% compared to just coding those features within your application in straight C.

The features that will slow it down are audio and the Timer, I might not even include those features in my library, haven't decided yet.

I'll start up a thread for this SDL AGA library so people can talk about it and we can leave this thread free for NetSurf AGA discussion.

SDL AGA thread

Last edited by NovaCoder; 07 May 2013 at 03:52.
NovaCoder is offline  
Old 07 May 2013, 02:03   #46
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,834
Wonderful
Retrofan is offline  
Old 07 May 2013, 07:39   #47
attila06
Zone Friend
 
Join Date: Oct 2006
Location: Nice / France
Posts: 181
Hip!Hip!Hip! Nova!
attila06 is offline  
Old 07 May 2013, 10:19   #48
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,450
Thanks but it's Arti's project, he's the one who's done all the hard work
NovaCoder is offline  
Old 08 May 2013, 19:24   #49
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 494
Update:

now ns works normally, doesn't crash.

Pages seem to load faster than on rtg version under emulation.


Still to do:
Fix images colors.
Get internal fonts working as truetype look bad on small screen size.

Nova is it possible to make window mode work?
arti is offline  
Old 08 May 2013, 19:43   #50
attila06
Zone Friend
 
Join Date: Oct 2006
Location: Nice / France
Posts: 181
It smells good here
attila06 is offline  
Old 08 May 2013, 23:03   #51
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,450
Windowed mode would be slower and would also have to match the users WB color depth which would probably be in even less colors.

Glad it's working, we should get people to do some AGA beta testing soon, just give me the time to help you create a decent build first.

Are we going to bother with an 030 build? I'm think you'll probably need a 040/060 to run this.

Why do we need to link with ixemul? It will be faster if we can remove that dependency.

Last edited by NovaCoder; 09 May 2013 at 01:46.
NovaCoder is offline  
Old 09 May 2013, 04:39   #52
wawa
Registered User
 
Join Date: Aug 2007
Location: berlin/germany
Posts: 944
ixemul is requirement for bernds sdl libs, i dont think netsurf core itself needs it. you could try to get rid of functions that make it necessary in your aga-sdl backend and try to link first against ixemul v48 and then libnix, but i doubt you ll succeed.
wawa is offline  
Old 09 May 2013, 05:57   #53
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,450
Quote:
Originally Posted by wawa View Post
ixemul is requirement for bernds sdl libs, i dont think netsurf core itself needs it. you could try to get rid of functions that make it necessary in your aga-sdl backend and try to link first against ixemul v48 and then libnix, but i doubt you ll succeed.
My AGA SDL library already links with libnix

Maybe Arti can give it a try and see if he can build NetSurf AGA like this:

Code:
-s -noixemul
NovaCoder is offline  
Old 09 May 2013, 17:45   #54
wawa
Registered User
 
Join Date: Aug 2007
Location: berlin/germany
Posts: 944
great!
wawa is offline  
Old 21 May 2013, 02:08   #55
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,450
Hi,

I got a progress update from Arti last night so I thought I'd share it here.

He's still working on the AGA port and he tells me that he's now got the 8bit colors working properly.

He's getting a single Enforcer hit on a bit of NetSurf code (eg a bug) which he wants to fix before he'll release a BETA, not sure if the bug is caused by my library or not.

I'm not sure if he's trying to build it with or without the nasty ixemul

And don't know if he's using my library in the slower double-buffered mode or if he's managed to get 'dirty rectangle' update rendering working (eg not double-buffered) which *should* be the faster approach with AGA.

Last edited by NovaCoder; 21 May 2013 at 08:22.
NovaCoder is offline  
Old 21 May 2013, 14:40   #56
crazyc
Registered User
 
Join Date: May 2012
Location: Gravesend - UK
Posts: 410
Am so looking forward to this!

crazyc is offline  
Old 25 May 2013, 21:21   #57
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 494
NetSurf for AGA test version is in The Zone!

Build with faster, no double buffering mode.
arti is offline  
Old 25 May 2013, 23:01   #58
attila06
Zone Friend
 
Join Date: Oct 2006
Location: Nice / France
Posts: 181
Thanks Arti,
I'm going to to test it on my 060 , and give you feedback.
attila06 is offline  
Old 25 May 2013, 23:05   #59
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,834
Great . But still 060, ixemul?
Retrofan is offline  
Old 25 May 2013, 23:28   #60
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 494
Yes this doesn't mean it won't work on 030.
Ixemul for now.
arti is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
(2012) Using EAB with amiga browser ? RCK project.EAB 2 03 October 2012 00:12
new to OS 3.9, whdload, amiga web browser sovietconscript New to Emulation or Amiga scene 17 07 November 2009 06:47
New Amiga Web Browser Solid Snake Amiga scene 7 19 June 2006 15:04
WWW Browser for Amiga 1200 Picard request.Apps 5 20 February 2006 22:53
What is the best browser to use with an Amiga 68040+RTG? Tolismlf New to Emulation or Amiga scene 2 20 November 2004 09:12

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:25.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.09222 seconds with 16 queries