English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 16 August 2018, 05:41   #1
rhester72
Registered User
 
Join Date: Feb 2008
Location: New York / USA
Posts: 139
HAM-E - any special tricks to use?

Trying it with WinUAE 4.0.1, using DKBTrace 2.12 to output HAM-E on an emulated A3000. First line or two appears to be colored correctly, everything else displays with a *very* odd palette.

Can't find anything else that even outputs HAM-E to see if the issue is with DKBTrace not setting the magic cookie properly, a configuration issue or a WinUAE issue.

Anyone have a working test case/tips? Not even sure how it's supposed to display, given my 'Amiga' is in 640x400 NTSC and HAM-E displays in low-res. (Is there another "monitor" I need to switch to? If so, how?)

Rodney
rhester72 is offline  
Old 16 August 2018, 16:32   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,015
I don't remember.. I guess it was some HAM-E demo disk that had example images that I used to test emulation. Or something like that.
Toni Wilen is online now  
Old 16 August 2018, 21:15   #3
rhester72
Registered User
 
Join Date: Feb 2008
Location: New York / USA
Posts: 139
Not even sure what to say - it seems quite busted. Steps to reproduce:

- A500 Quickstart (NTSC or PAL, makes no difference)
- Turn on HAM-E (Chipset/Video port display hardware/HAM-E)
- Enable second floppy drive
- Drive 1: Workbench 1.3, drive 2: disk 3 of HAM-E setup disks (from http://amiga.resource.cx/exp/hame)
- Boot, open up the hed3 disk, open HAME_Setup_2

Behold the mess of pixels =)
rhester72 is offline  
Old 16 August 2018, 22:12   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,015
It looks like something broke when multimonitor support was added. 3.6.1 works correctly.
Toni Wilen is online now  
Old 17 August 2018, 00:40   #5
rhester72
Registered User
 
Join Date: Feb 2008
Location: New York / USA
Posts: 139
Confirmed (and works with DKBTrace) - thank you!
rhester72 is offline  
Old 17 August 2018, 10:56   #6
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,015
Fixed. It looks like I did some later changes that broke it because I do remember testing at least HAM-E in multimonitor mode.
Toni Wilen is online now  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
tricks on others platforms ? turrican3 Retrogaming General Discussion 11 24 November 2013 17:23
PAL-M Filter Tricks Leandro Jardim support.WinUAE 0 25 October 2011 17:03
Copper tricks Lonewolf10 Coders. General 14 31 March 2011 23:09
Alien Breed Special Edition'92 - special level mailman Nostalgia & memories 7 14 April 2010 10:03
Old joysticks, new tricks twizzle Retrogaming General Discussion 14 30 April 2009 00:37

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:01.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06306 seconds with 13 queries