English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 08 August 2018, 18:03   #1
FlynnTheAvatar
Registered User

 
Join Date: Jan 2018
Location: Germany
Posts: 20
Strange mouse behavior with Surface Book 2

Hi Toni,


I hope you could help me with a strange mouse behavior that bugs me for a while on my Surface Book 2.


When using WinUAE 3.6, 4.0.0, 4.0.1 on my Surface Book 2 with Windows 1803 (and possible 1709), I cannot do a right click on the touchpad. Pressing with two finger does nothing, releasing shortly flashes the menu bar. I can right-click when activating the option "Press the lower right corner of the touchpad to right-click" in System->Touchpad and pressing the lower right corner.


It gets even stranger. When scrolling down (two fingers drag to top) will perform a right-click that gets stuck (need to click with two fingers or use lower right corner to release). This also happens with scrolling down with a wheel mouse.


This happens with all configuration (quick start or otherwise). The only way I get correct scrolling behavior is to plugin a wheel mouse and selecting the wheel mouse in Game Ports->Port 1 (HID-compliant mouse). Using the default Windows mouse is causing the issues above.


So, yes, the workaround is to use an external mouse and configure it in Port 1. But most of the time I use my Surface Book 2 without a mouse. So it would be great if you could take a look, please.


I attached a quickstart config, and the WinUAE logs. I booted into Workbench 1.2 with Kickstart 1.3 and did a two finger right click and two finger drag to top.


Thank you very much,
-Flynn
Attached Files
File Type: zip MouseIssue.zip (34.9 KB, 15 views)
FlynnTheAvatar is offline  
Old 10 August 2018, 18:30   #2
FlynnTheAvatar
Registered User

 
Join Date: Jan 2018
Location: Germany
Posts: 20
Okay, I did a take a look at the host messages logged by AmigaForever (not sure how to log them with plain WinUAE).


These are things I noticed:
  • There is no "right-press" using the touchpad. A long press with one or two fingers are translated to a "left-press"; Mouse Buttons 0x1 on press, Mouse Buttons 0x2 on release. Might be Windows specific behavior; it was possible to produce a right press with the touchpad on my MacBook Pro.
  • A tap with one finger translates to left-click (as expected); Mouse Buttons 0x1 and Mouse Buttons 0x2
  • A tap with two fingers translates to right-click. A very short right-click. Not helpful if you want to select a menu item. The AmigaOS expects that you press the right mouse button, select the menu item and release; Mouse Buttons 0x4 and Mouse Buttons 0x8
  • Wheel up and wheel down produces RP_IPC_TO_HOST_RAWINPUT_EVENT - Mouse Buttons 0x400 -> 0x400. There must be additional data that is transmitted, otherwise the emulation would not distinguish between scroll up/scroll down
FlynnTheAvatar is offline  
Old 10 August 2018, 19:58   #3
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,020
Use "-log -inputlog 2 -inputdevicelog 1" (without quotes) command line parameters. Start emulation, then try to create right click button press and check what gets logged.

Each click generates two lines: first line shows rawinput event info and second line (possibly) mapping to Amiga input event.

Touchpad most likely tries to be "helpful" for Windows use because keeping right mouse button pressed is mostly useless in Windows.
Toni Wilen is offline  
Old 10 August 2018, 22:27   #4
FlynnTheAvatar
Registered User

 
Join Date: Jan 2018
Location: Germany
Posts: 20
Hi Toni,

Thank you very much for logging parameters.

I do not have any issues with right-clicks. Using the option "Press the lower right corner of the touchpad to right-click" works very good as a workaround.

My issue is the right-click when scrolling up. It does not happen in any other program than WinUAE. This is the relevant copy from the log:
Code:
STATE=00000 MAX=00000 AF=0 QUAL=000000 'Mouse1 Horizontal'
STATE=00000 MAX=00000 AF=0 QUAL=000000 'Mouse1 Vertical'
0000000000000000 0000 0400 fffe 00000000   0   0 00000000 M=1 F=2
STATE=-0002 MAX=00000 AF=0 QUAL=000000 'Mouse1 Wheel'
STATE=-0002 MAX=00000 AF=0 QUAL=000000 'Mouse1 Wheel'
STATE=00001 MAX=00001 AF=0 QUAL=000000 'Joy1 2nd Button/Mouse1 Right Button'
0000000000000000 0000 0400 fffb 00000000   0   0 00000000 M=1 F=2
STATE=-0005 MAX=00000 AF=0 QUAL=000000 'Mouse1 Wheel'
STATE=-0005 MAX=00000 AF=0 QUAL=000000 'Mouse1 Wheel'
STATE=00001 MAX=00001 AF=0 QUAL=000000 'Joy1 2nd Button/Mouse1 Right Button'
0000000000000000 0000 0400 fff9 00000000   0   0 00000000 M=1 F=2
STATE=-0005 MAX=00000 AF=0 QUAL=000000 'Mouse1 Wheel'
STATE=-0005 MAX=00000 AF=0 QUAL=000000 'Mouse1 Wheel'
STATE=00001 MAX=00001 AF=0 QUAL=000000 'Joy1 2nd Button/Mouse1 Right Button'
0000000000000000 0000 0400 fff9 00000000   0   0 00000000 M=1 F=2
...
Somehow a right button click after each scroll event is created or detected.

Thanks,
-Josef
FlynnTheAvatar is offline  
Old 10 August 2018, 23:48   #5
FlynnTheAvatar
Registered User

 
Join Date: Jan 2018
Location: Germany
Posts: 20
More strangeness - scrolling down generates middle mouse clicks:

Code:
0000000000000000 0000 0400 0029 00000000   0   0 00000000 M=1 F=2
STATE=00041 MAX=00000 AF=0 QUAL=000000 'Mouse1 Wheel'
STATE=00044 MAX=00000 AF=0 QUAL=000000 'Mouse1 Wheel'
STATE=00001 MAX=00001 AF=0 QUAL=000000 'Joy1 3rd Button/Mouse1 Middle Button'
Switching to "HID-compliant mouse [1]" works correctly:
Code:
0000000027340E65 0000 0400 ff88 00000000   0   0 00000000 M=3 F=2
STATE=-0120 MAX=00000 AF=0 QUAL=000000 'Mouse1 Wheel'
0000000027340E65 0000 0400 0078 00000000   0   0 00000000 M=3 F=2
STATE=00120 MAX=00000 AF=0 QUAL=000000 'Mouse1 Wheel'
Any idea what might cause this?

Thanks,
-Flynn
FlynnTheAvatar is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange bitmap behavior losso support.WinUAE 2 31 December 2013 13:42
Very strange SFS behavior. Thorham support.Apps 26 17 October 2009 16:04
Strange hdf behavior [not really a problem]. olesio support.WinUAE 4 13 August 2009 09:34
discovered strange behavior NfernalNfluence support.WinUAE 7 26 May 2009 09:10
Strange behavior in A4000 Computolio support.Hardware 8 22 September 2007 13:39

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 09:21.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06498 seconds with 14 queries