English Amiga Board


Go Back   English Amiga Board > Coders > Coders. System

 
 
Thread Tools
Old 01 October 2018, 03:57   #2761
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,539
Ok, if it works better for you in this order. I don't use Rainboot and don't remember just like you why I prefer FPPrefs after IPrefs ...

Anybody here who wants to download HM020 46.4.503 ? I'm going to delete it now, because it should be available on Aminet in a few hours ... Aminet - util/libs/IconLib_46.4.lha

Last edited by PeterK; 01 October 2018 at 04:04.
PeterK is offline  
Old 01 October 2018, 10:45   #2762
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,190
Quote:
Originally Posted by Retrofan View Post
, and I was also trying to introduce Rainboot that depends a lot on that.
I in the past i have always used Rainboot on my systems, Rainboot I added it in the startup-sequence before LoadWB and after IPrefs, i set the right waiting time before the LoadWB is executed (Wait)

Run >nil: C:Rainboot dh0:Rainboot/AmigaOS35.config MODEID 1342443520 RTG

You can see Rainboot in use this my old video
[ Show youtube player ]
AMIGASYSTEM is offline  
Old 01 October 2018, 12:57   #2763
kolla
Banned
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,899
With 46.4.503, there is no doubt HAM8 icons - they look nice, are super slow and something is eating chipram like crazy, hehe
Attached Thumbnails
Click image for larger version

Name:	IMG_6618.jpg
Views:	78
Size:	208.6 KB
ID:	60081  
kolla is offline  
Old 01 October 2018, 13:18   #2764
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,539
Of course, FBlit is highly recommended. The screen always takes ChipMem, but the icons don't need it with FBlit. And it's also faster, although HM020 can never be as fast as the 68020 version, because HAM8 is done in the slow ChipMem and not on a fast gfxcard.
PeterK is offline  
Old 01 October 2018, 13:19   #2765
kolla
Banned
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,899
Ah yes, I had disabled fblit due to testing with p96, forgot to enable it again.
kolla is offline  
Old 01 October 2018, 13:32   #2766
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,539
The HAM8 drawer on your screenshot still seems to be the old version from 46.4.500. Please don't use the old FullPalette.prefs file anymore. There is a new one for 501+ to get the correct colors.
PeterK is offline  
Old 01 October 2018, 13:38   #2767
kolla
Banned
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,899
Correctly spotted. I just wanted to see how the monitor prefs icons look, and randomly picked the .500 archive.
kolla is offline  
Old 01 October 2018, 15:12   #2768
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 41
Posts: 2,005
Hi, in trying ham modes for workbench usage, and using PeterKĀ“s icon.libraries, what AmigaOS limitations have you found so far, besides setting the screenmode?

I ask this, because I suggested ham support as a feature in the OS development team and would like to know if it is a worthwhile endeavour that I insist on it due to the manpower we have.

So what works great, not so great and ultimately is a disaster in having workbench in ham mode?

Thanks
gulliver is offline  
Old 01 October 2018, 15:32   #2769
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,190
In my opinion the greatest limitation is that the system becomes very slow and not suitable for Amiga Real.
AMIGASYSTEM is offline  
Old 01 October 2018, 18:04   #2770
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,539
++ HAM8 icons are looking nicer than icons mapped to the 256 colors of the screens palette

-- you need an AGA system with a fast CPU, FBlit and more memory

-- there are no free pens left in HAM8 mode for applications, they have to share the existing base colors

-- some programs are doing stupid things when WB is in HAM mode, even Multiview sometimes opens just an empty gray screen. It seems to depend on some buggy WB startup code when you click on an icon with Multiview as default tool and does not happen if you do the same from CLI.

Quote:
So what works great, not so great and ultimately is a disaster in having workbench in ham mode?
Don't ask me, since I'm not an AmigaOS user for any other things than coding in assembler, I don't use any Amiga applications for my everyday work.
PeterK is offline  
Old 01 October 2018, 23:34   #2771
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 41
Posts: 2,005
Thank you both AMIGASYSTEM and PeterK.

It seems it is only really good for displaying things but not for doing real workbench work.

If only the chipset bandwith was faster...
gulliver is offline  
Old 02 October 2018, 03:10   #2772
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 6,068
Quote:
Originally Posted by AMIGASYSTEM View Post
In my opinion the greatest limitation is that the system becomes very slow and not suitable for Amiga Real.
I don't see what do you mean about using it in a real Amiga. It may be slower for a slow system (stay with 16 colors), but it has to work very well with a decent accelerator and you'll get, for example, better icons and backdrops images as I'm seeing, than using 256 colors while also using less ram.

BTW, I've just reminded now when they were talking about implementing HAM in the Indivision AGA. It was never made but it was a possibility that they could have tried with hardware/software.

Last edited by Retrofan; 02 October 2018 at 03:16.
Retrofan is offline  
Old 02 October 2018, 03:25   #2773
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,539
Hello Retrofan,

I'm glad to see that my HM020 version has got one follower and defender at least.

Some guys here (Michael, kolla and Thorham) are asking for a HAM6 version, and yes I might try to make one on the next days, although I won't expect good quality, but who knows. The coding for HAM6 is straight forward, no chance for personal decisions, because I have to use the 8 MWB colors, so only 8 base colors (2x2x2) are remaining, that seems to be all simple after doing HAM8. Let's see what comes out ...

Last edited by PeterK; 02 October 2018 at 16:40.
PeterK is offline  
Old 02 October 2018, 03:39   #2774
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 6,068
Ok, drop here what you make and we'll happily try it. Who knows?. If you don't try then you can't know how it can look like, but I'm very happy with HAM 8. In any case we always can have a dedicated library for each one.

Last edited by Retrofan; 02 October 2018 at 03:57.
Retrofan is offline  
Old 02 October 2018, 09:53   #2775
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,190
Quote:
Originally Posted by Retrofan View Post
I don't see what do you mean about using it in a real Amiga. It may be slower for a slow system (stay with 16 colors), but it has to work very well with a decent accelerator and you'll get, for example, better icons and backdrops images as I'm seeing, than using 256 colors while also using less ram.
.
At the moment all my Amiga have been sleeping in the closet for 25 years (A4000/060, 2 A1200 030/040, 2 A600HD, 2 A500, 1 A500Plus, 2 Cd32 1 SX32) and I can not do tests, and a su WinUAE I noticed the slowness very probably and even more it will be on a real Amiga, except I did not do something wrong, but I doubt it.
AMIGASYSTEM is offline  
Old 02 October 2018, 13:21   #2776
kolla
Banned
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,899
icon.library 46.4 test versions

As mentioned, I used HAM8 wb back in the days, it was a 030 system and though being slower, it was not unusable. I did not use HAM8 icons though, just newicons - the point was to have a public HAM8 screen for IBrowse.

@PeterK
I don't recall asking for HAM6
kolla is offline  
Old 02 October 2018, 16:49   #2777
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,539
Quote:
Originally Posted by kolla View Post
I don't recall asking for HAM6
Pardon! Yes, you just said that HAM8 is super slow (without FBlit). Ok, struck you from the list of bad guys.
PeterK is offline  
Old 02 October 2018, 22:34   #2778
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,539
Quote:
Originally Posted by AMIGASYSTEM View Post
... su WinUAE I noticed the slowness very probably and even more it will be on a real Amiga, except I did not do something wrong, but I doubt it.
It also depends a lot on the monitor driver how fast the HAM8 icons are displayed. I just noticed that the SuperPlus monitor is fastest and HighGFX is the slowest. For a benchmark with Ken's Icons v4 I get approximately the following results:

(68020 uaegfx 8 bit 1280x800 = 1.06) mapped to 256 screen colors
(68020 uaegfx 32 bit 1280x800 = 0.89) direct drawing in HiColor quality
(TC020 uaegfx 32 bit 1280x800 = 0.97) direct drawing in TrueColor quality
(HM020 uaegfx 32 bit 1280x800 = 1.10) in TC mode, no delayed image 2

HAM8 on AGA with HM020:
SuperPlus 800x600 = 1.52
Film24 .. 1280x600 = 1.75
PAL ........ 724x566 = 1.92
Xtreme 1280x1024 = 1.94 (same with 68020 64 colors = 1.76)
HD720 . 1280x720 = 1.99
HighGFX 1024x768 = 2.18

And never forget to use FBlit, P96 or GGX and FastMem.

Last edited by PeterK; 03 October 2018 at 22:09.
PeterK is offline  
Old 03 October 2018, 01:17   #2779
kolla
Banned
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,899
icon.library 46.4 test versions

Btw - slightly OT - anyone know of some tool that can create public HAM8 screens? Sadly the MUI (3.8) PSI doesn't support it.

Curious, must try superplus on MiST.
kolla is offline  
Old 03 October 2018, 01:30   #2780
retrogamer
Zone Friend
 
Join Date: May 2006
Location: Sweden
Age: 40
Posts: 279
Quote:
Originally Posted by kolla View Post
Btw - slightly OT - anyone know of some tool that can create public HAM8 screens? Sadly the MUI (3.8) PSI doesn't support it.

Curious, must try superplus on MiST.

Try this tool http://tool.anides.de
retrogamer is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
ClassicWB Full and icon.library 46.4 Retroplay project.ClassicWB 8 05 August 2018 14:57
WB library conflict/versions Akira support.Apps 3 22 July 2010 19:47
PNG Icon to Color Icon Converter? Leandro Jardim request.Apps 1 24 May 2010 05:39
What's the latest version of icon.library for OS3.9? NovaCoder support.Apps 3 30 June 2009 16:43
Requesting icon.library v44+... nikvest request.Other 2 16 September 2007 02:58

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:02.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.26443 seconds with 16 queries