English Amiga Board


Go Back   English Amiga Board > abime.net - Hosted Projects > project.ClassicWB

 
 
Thread Tools
Old 08 May 2011, 15:29   #1
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,890
Right mouse button not working?

Hiya,

Got a bit of a strange one, just got CW running on my real Amiga for the first time and everything seems fine apart from the fact that the right mouse button doesn't seem to work.

I've tried the mouse on the PC and it's ok and it also goes into the early startup if both buttons are held down so I guess that means it's work fine.

It's not use magic menu either, I mean the right mouse button seem to be ignored by WB (can't even access the top menu).

Any ideas?
NovaCoder is offline  
Old 08 May 2011, 15:41   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,058
Stuck right or middle button? (or bend mouse port pin etc) Does early startup open if you only keep left button pressed?
Toni Wilen is online now  
Old 08 May 2011, 16:38   #3
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 42
Posts: 5,754
Send a message via MSN to FOL
What about booting from floppy WB 3.1?
Does both buttons work there to?

This would rule out a software issue, if still dont work.
Then what toni said, could even be leaking caps (if you havent had them changed) / associated circuit?

Last edited by FOL; 09 May 2011 at 10:59.
FOL is offline  
Old 09 May 2011, 06:26   #4
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,890
Strange, installed a clean 3.9 install and then played with the Micromys buttons a bit and it's now working, not sure if it was a software or HW issue.
NovaCoder is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
2 Button support not working Fabie support.WinUAE 52 17 February 2017 07:31
A600 right mouse button not working protek support.Hardware 48 18 March 2013 14:57
Amiga Mouse Button Switches amigakit.com MarketPlace 0 09 September 2012 18:40
Problem right mouse button 3dfx4ever support.Hardware 3 17 February 2011 08:33
A2000 stopped seeing right mouse button shirsch support.Hardware 4 22 August 2008 03:03

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 19:14.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.11686 seconds with 13 queries