English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 13 February 2011, 17:19   #1
3dfx4ever
 
Posts: n/a
Problem right mouse button

Hi everyone !!!

I'm using again my Amiga 1200 from about 1 mounth...
I replaced my harddisk 120Mg with a 512Mb CF using ide44 adapter and I succeeded to restore my old WB.

Two days ago I noticed that in WB right mouse button stopped working...
The most strange thing is that if I press both mouse button at boot, I succeed to enter in boot menu.
I tried to remove hdd and to use WB disk (to understand if there is a data corruption in the hdd) but the behaviour is the same...
If I use Right Alt+Amiga, the keystroke works and I'm using amiga in this way now...

Can you help me to understand what's happened ?
Thanks.
 
Old 13 February 2011, 21:37   #2
amigoun
Registered User
amigoun's Avatar
 
Join Date: May 2010
Location: Czech Rep
Posts: 558
What kind of mouse do you use? Normal Amiga mouse or any PS2-Amiga adapter?
amigoun is offline  
Old 13 February 2011, 21:44   #3
rkauer
I hate potatos and shirts
rkauer's Avatar
 
Join Date: Oct 2007
Location: Sao Leopoldo / Brazil
Age: 54
Posts: 3,482
Send a message via MSN to rkauer Send a message via Yahoo to rkauer
A friend of mine had the same issue on his A1200, he ditch the board and bought a replacement.

Seems like killing cockroaches with dynamite packs, maybe it's just one TTL that interfaces with Lisa that had a death.

Right mouse button goes to Lisa through a SMD TTL chip and some resistors.
rkauer is offline  
Old 17 February 2011, 08:33   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,065
Stuck right mouse button? (Menus still work normally using keyboard shortcuts in this situation)

Do you get in early boot menu if you only press left mouse button? If yes, does same happen if you put joystick in mouse port and keep fire button pressed?
Toni Wilen is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
A600 right mouse button not working protek support.Hardware 48 18 March 2013 14:57
Amiga Mouse Button Switches amigakit.com MarketPlace 0 09 September 2012 18:40
Right mouse button not working? NovaCoder project.ClassicWB 3 09 May 2011 06:26
A2000 stopped seeing right mouse button shirsch support.Hardware 4 22 August 2008 03:03
Lost left button on mouse port. fc.studio support.Hardware 2 01 March 2008 02:41

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 01:12.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.06853 seconds with 13 queries