English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 19 May 2010, 14:10   #1
cosam
 
Posts: n/a
A1200 keyboard trouble

Greeting fellow Amiga fans,

I recently dug out my A1200 which is suffering from an odd keyboard problem. Every so often, it'll spit out a few random characters and then behave as if a key is being held down (usually "-", "*" or a number). This happens with both the original keyboard and a PC keyboard adapter - even with no keyboard at all. Looking at the schematics, I'm assuming it has something to do with the 68HC05 (U13) as there doesn't appear to be a lot more that could go wrong. I've had a 'scope on the KB_DATA line and sure enough you can see the extra pulses zipping along when it does its auto-repeat trick.

Now, if this was a DIP part I'd have replaced it by now but being SMD it's a little more tricky, so I'd like to be sure replacing it would fix the problem. Is there anything else that may cause these symptoms? There's also the matter of sourcing a replacement. I think I could get hold of a replacement 68HC05 easy enough, but it'd need programming. I'm guessing the only real option is to canibalise another A1200, or would one from an A600 work too?

Thanks in advance,

Steve
 
Old 19 May 2010, 14:19   #2
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 40
Posts: 7,997
Only the one from an a1200 will do. What kind of PC keyboard adapter do you have?
Jope is offline  
Old 19 May 2010, 14:52   #3
cosam
 
Posts: n/a
Quote:
Originally Posted by Jope View Post
What kind of PC keyboard adapter do you have?
I believe it's a PC-Key adapter, just a uC on a tiny PCB which fits in the keyboard socket. It appears to work fine, although it seems to stay in caps lock when shift is depressed. I'm not sure if that's part of the same problem or the next one, lurking around the corner ;-)
 
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
A600 keyboard trouble psygnosis support.Hardware 6 02 July 2013 22:26
Help required with keyboard trouble diablothe2nd support.Hardware 25 24 June 2013 14:59
Trouble Prepping CF for use as HD on A1200.... asm1 support.Hardware 14 09 March 2009 01:48
Keyboard and mouse trouble Coldwinter support.Hardware 12 29 July 2006 07:07
Having trouble with AT keyboard hack! Generale support.Hardware 0 08 April 2005 14:03

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:21.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.05964 seconds with 15 queries