English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 07 July 2019, 21:28   #1
UKShark
Registered User
 
Join Date: Jun 2010
Location: glos
Posts: 22
auto fire - no joystick.

Can anyone help suggest where to look?
I have an Amiga 500 rev 6 that fires the joystick with nothing plugged in.
I've tried swapping the CIA chip.
Unplugged memory etc, still fires slowly.
So no joysticks plugged in, load a game and its like someone is pressing the fire button over and over.


Any ideas?

Last edited by UKShark; 07 July 2019 at 23:39.
UKShark is offline  
Old 08 July 2019, 21:31   #2
Vypr
Registered User

Vypr's Avatar
 
Join Date: Dec 2016
Location: East Kilbride, Scotland
Posts: 422
I would check that pin 6 on the joystick port isn't shorted to ground first.
Vypr is offline  
Old 09 July 2019, 12:17   #3
Hewitson
Registered User
Hewitson's Avatar
 
Join Date: Feb 2007
Location: Melbourne, Australia
Age: 39
Posts: 3,747
Check the pullup resistors as well. Are you able to take a voltage reading on the fire button pin?
Hewitson is offline  
Old 09 July 2019, 15:46   #4
UKShark
Registered User
 
Join Date: Jun 2010
Location: glos
Posts: 22
A friend is sending me the schematic link, so ill check these on the weekend. Thanks for the directions.
UKShark is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto-Fire mapping for 2nd button Retro-Nerd support.FS-UAE 1 05 July 2016 06:24
Auto-Fire toggle not working (Mac OS X 10.9, PS3 Controller) burlshero support.FS-UAE 1 22 March 2014 23:06
Auto-fire Detection/Disabling? SunChild support.Games 3 12 September 2013 18:51
Auto auto fire? john4p request.UAE Wishlist 6 22 January 2010 08:50
Auto-fire Tim Janssen support.WinUAE 2 02 May 2002 08:42

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 09:02.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.09619 seconds with 13 queries